MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0027617Open CASCADE[OCCT] OCCT:Visualizationpublic2016-06-18 16:262016-12-09 16:38
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0027617: Visualization, TKOpenGl - apply highlighting color without disabling lighting
DescriptionCurrent implementation of OpenGl_PrimitiveArray disables lighting for applying highlighting color. This makes highlighting using Shaded presentation mode of AIS_Shape not very usable.

It is proposed to change this behavior and keep lighting enabled.
Steps To Reproduce
pload MODELING VISUALIZATION
box b 1 2 3
vclear
vinit View1
vdisplay -highMode 1 -dispMode 1 b
vaxo
vfit
vrotate 1 0 0
vfit
vmoveto 250 150
vreadpixel 200 150 name rgb

Current result: CYAN1
TagsNo tags attached.
Test case numberv3d materials bug27617
Attached Filespng file icon shaded_highlight_flat.png (3,043 bytes) 2016-06-18 16:28
png file icon shaded_highlight_with_lights.png (3,775 bytes) 2016-06-18 16:30

- Relationships
related to 0027818closedkgv Visualization - provide an interface to define highlight presentation properties 
related to 0027624closedbugmaster Draw Harness, ViewerTest - vdrawtext command ignores text display options 
related to 0026885closedbugmaster Visualization - drop redundant aspects from structure level 

-  Notes
(0055199)
git (administrator)
2016-06-18 16:48

Branch CR27617 has been created by kgv.

SHA-1: 506f43430113eed3e7d7d66d1a3fc0a2656d205a


Detailed log of new commits:

Author: kgv
Date: Sat Jun 18 16:47:56 2016 +0300

    0027617: Visualization, TKOpenGl - apply highlighting color without disabling lighting
(0055200)
kgv (developer)
2016-06-18 18:24

Patch is ready for review.
(0055201)
git (administrator)
2016-06-20 09:51

Branch CR27617 has been updated forcibly by kgv.

SHA-1: bdd124b8ef06d238639e36bf40d2cfe57fd75a78
(0055221)
san (developer)
2016-06-20 14:05

Branch CR27617 reviewed without remarks, ready for testing.
(0055257)
git (administrator)
2016-06-20 18:57

Branch CR27617 has been updated by kgv.

SHA-1: a5559c2c028d4925cf405f056ada9affca72718b


Detailed log of new commits:

Author: kgv
Date: Mon Jun 20 18:56:30 2016 +0300

    AIS_PointCloud now sets up ShadingAspect within Compute()
    and does not override PointAspect of global drawer.
    ViewerTest now sets group aspect within vuserdraw and vdrawparray.

(0055258)
git (administrator)
2016-06-20 18:57

Branch CR27617 has been updated forcibly by kgv.

SHA-1: bdd124b8ef06d238639e36bf40d2cfe57fd75a78
(0055261)
git (administrator)
2016-06-20 19:13

Branch CR27617_1 has been created by kgv.

SHA-1: 655577fec072ae3cd6952265ce62dd29351aefed


Detailed log of new commits:

Author: kgv
Date: Mon Jun 20 09:51:56 2016 +0300

    0027617: Visualization, TKOpenGl - apply highlighting color without disabling lighting
(0055262)
kgv (developer)
2016-06-20 19:14

Please take updated patch in branch CR27617_1.
(0055298)
mkv (tester)
2016-06-21 14:31

Dear BugMaster,
Branch CR27617_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 655577fec072ae3cd6952265ce62dd29351aefed

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 68 (68 on master)
Windows: 0 (0 on master)
MacOS : 1116

Regressions/Differences/Improvements:
http://occt-tests/CR27617-1-master-OCCT/Debian70-64/summary.html [^]
http://occt-tests/CR27617-1-master-OCCT/Windows-64-VC10/summary.html [^]
Failed:
  bugs vis bug22018, bug26217, bug26680, bug26960

Testing cases:
http://occt-tests/CR27617-1-master-OCCT/Debian70-64/v3d/materials/bug27617.html [^]
http://occt-tests/CR27617-1-master-OCCT/Windows-64-VC10/v3d/materials/bug27617.html [^]
v3d materials bug27617: OK

Testing on Linux:
occt component :
Total MEMORY difference: 88949901 / 89123611 [-0.19%]
Total CPU difference: 19379.55000000005 / 19457.32999999997 [-0.40%]
products component :
Total MEMORY difference: 27436769 / 27412842 [+0.09%]
Total CPU difference: 5172.869999999977 / 5165.429999999985 [+0.14%]

Testing on Windows:
occt component :
Total MEMORY difference: 55853513 / 55894150 [-0.07%]
Total CPU difference: 18136.457858598907 / 18534.946812998955 [-2.15%]
products component :
Total MEMORY difference: 18643452 / 18607822 [+0.19%]
Total CPU difference: 4972.017071699955 / 4997.570035499952 [-0.51%]

There are following differences in images found by testdiff.
(OK)
http://occt-tests/CR27617-1-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR27617-1-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10.html [^]
IMAGE v3d manipulator rotate: rotate_4.png differs
IMAGE v3d manipulator rotate: rotate_5.png differs
IMAGE v3d manipulator rotate: rotate_1.png differs
IMAGE v3d manipulator rotate: rotate_3.png differs
IMAGE v3d manipulator scale: scale_1.png differs
IMAGE v3d manipulator zoom_persistence: zoom_persistence_2.png differs
IMAGE v3d manipulator zoom_persistence: zoom_persistence_1.png differs
IMAGE v3d manipulator zoom_persistence: zoom_persistence_4.png differs
IMAGE v3d manipulator zoom_persistence: zoom_persistence_5.png differs
IMAGE v3d manipulator translate: translate_1.png differs
IMAGE v3d manipulator translate: translate_2.png differs
IMAGE v3d manipulator translate: translate_3.png differs
IMAGE bugs vis bug137_3: bug137_3.png differs
IMAGE bugs vis buc60876: buc60876.png differs
IMAGE bugs vis bug137_4: bug137_4.png differs
IMAGE bugs vis bug137_1: bug137_1.png differs
IMAGE bugs vis bug137_5: bug137_5.png differs
IMAGE bugs vis bug137_2: bug137_2.png differs
(0055299)
mkv (tester)
2016-06-21 14:31

Dear kgv,
Branch CR27617_1 has been rejected due to:
- regressions/differences/improvements
(0055304)
git (administrator)
2016-06-21 15:02

Branch CR27617_1 has been updated by kgv.

SHA-1: 25efdeb6b1e04b9e6e7a7961e275d13e9cbe6486


Detailed log of new commits:

Author: kgv
Date: Tue Jun 21 15:02:49 2016 +0300

    update colors in test cases

(0055305)
kgv (developer)
2016-06-21 15:03

New screenshots look OK.
Failed test cases have been updated with new colors (pushed to CR27617_1).
(0055307)
mkv (tester)
2016-06-21 16:02

Dear BugMaster,
following test cases are retested, now its are OK.

bugs vis bug22018, bug26217, bug26680, bug26960
(0055308)
mkv (tester)
2016-06-21 16:03

Dear BugMaster,
Branch CR27617_1 is TESTED.
(0055416)
git (administrator)
2016-06-24 12:57

Branch CR27617_1 has been deleted by inv.

SHA-1: 25efdeb6b1e04b9e6e7a7961e275d13e9cbe6486
(0055425)
git (administrator)
2016-06-24 12:58

Branch CR27617 has been deleted by inv.

SHA-1: bdd124b8ef06d238639e36bf40d2cfe57fd75a78

- Related Changesets
occt: master f9ba5c4d
Timestamp: 2016-06-20 06:51:56
Author: kgv
Committer: bugmaster
Details ] Diff ]
0027617: Visualization, TKOpenGl - apply highlighting color without disabling lighting

Update colors in test cases
mod - src/OpenGl/OpenGl_BackgroundArray.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_CappingAlgo.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_GraduatedTrihedron.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Group.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_NamedStatus.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_PrimitiveArray.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Structure.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Text.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Trihedron.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace.hxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_OpenGlCommands.cxx Diff ] File ]
mod - tests/bugs/vis/bug22018 Diff ] File ]
mod - tests/bugs/vis/bug26217 Diff ] File ]
mod - tests/bugs/vis/bug26680 Diff ] File ]
mod - tests/bugs/vis/bug26960 Diff ] File ]
add - tests/v3d/materials/bug27617 Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-06-18 16:26 kgv New Issue
2016-06-18 16:26 kgv Assigned To => kgv
2016-06-18 16:26 kgv File Added: shaded_highlight_flat.png
2016-06-18 16:28 kgv Steps to Reproduce Updated View Revisions
2016-06-18 16:28 kgv File Deleted: shaded_highlight_flat.png
2016-06-18 16:28 kgv File Added: shaded_highlight_flat.png
2016-06-18 16:30 kgv File Added: shaded_highlight_with_lights.png
2016-06-18 16:31 kgv Steps to Reproduce Updated View Revisions
2016-06-18 16:48 git Note Added: 0055199
2016-06-18 18:24 kgv Note Added: 0055200
2016-06-18 18:24 kgv Assigned To kgv => san
2016-06-18 18:24 kgv Status new => resolved
2016-06-20 09:51 git Note Added: 0055201
2016-06-20 14:05 san Note Added: 0055221
2016-06-20 14:05 san Assigned To san => bugmaster
2016-06-20 14:05 san Status resolved => reviewed
2016-06-20 14:51 mkv Assigned To bugmaster => mkv
2016-06-20 18:50 san Relationship added related to 0027624
2016-06-20 18:57 git Note Added: 0055257
2016-06-20 18:57 git Note Added: 0055258
2016-06-20 19:13 git Note Added: 0055261
2016-06-20 19:14 kgv Note Added: 0055262
2016-06-20 19:14 kgv Relationship added related to 0026885
2016-06-21 14:31 mkv Note Added: 0055298
2016-06-21 14:31 mkv Note Added: 0055299
2016-06-21 14:31 mkv Assigned To mkv => kgv
2016-06-21 14:31 mkv Status reviewed => feedback
2016-06-21 14:31 mkv Test case number => v3d materials bug27617
2016-06-21 15:02 git Note Added: 0055304
2016-06-21 15:03 kgv Note Added: 0055305
2016-06-21 15:03 kgv Assigned To kgv => mka
2016-06-21 15:04 kgv Assigned To mka => mkv
2016-06-21 16:02 mkv Note Added: 0055307
2016-06-21 16:03 mkv Note Added: 0055308
2016-06-21 16:03 mkv Assigned To mkv => bugmaster
2016-06-21 16:03 mkv Status feedback => tested
2016-06-24 12:41 bugmaster Changeset attached => occt master f9ba5c4d
2016-06-24 12:41 bugmaster Status tested => verified
2016-06-24 12:41 bugmaster Resolution open => fixed
2016-06-24 12:57 git Note Added: 0055416
2016-06-24 12:58 git Note Added: 0055425
2016-10-13 11:28 kgv Relationship added related to 0027818
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:38 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker