MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026885Open CASCADE[OCCT] OCCT:Visualizationpublic2015-11-17 16:002016-12-09 16:38
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0026885: Visualization - drop redundant aspects from structure level
DescriptionOriginal quotation from 0023117:

2. Aspects at the level of Graphic3d_Structure and OpenGl_Structure.
Currently, if e.g. a face aspect is defined at structure level, and a group inside this structure also defines a face aspect, then the structure's one is simply ignored. Since it is a common practice to define the necessary aspects at the level of the current group (not at the level of the structure), holding structure aspects is of no use.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0026612closedbugmaster Community High memory footprint displaying model with big amount of solids 
related to 0027617closedbugmaster Open CASCADE Visualization, TKOpenGl - apply highlighting color without disabling lighting 
parent of 0027717closedbugmaster Open CASCADE Visualization - drop broken Prs3d_Drawer::ShadingAspectGlobal() flag 
child of 0023117closedbugmaster Open CASCADE TKV3d and TKOpenGl code clean-up 

-  Notes
(0055115)
git (administrator)
2016-06-16 23:26

Branch CR26885 has been created by kgv.

SHA-1: e17ea5d2fc29dc2ad399b457d92a7c53e8eb23f5


Detailed log of new commits:

Author: kgv
Date: Thu Jun 16 23:26:19 2016 +0300

    0026885: Visualization - drop redundant aspects from structure level
    
    Graphic3d_CStructure and OpenGl_Structure do not store structure aspects anymore.
    Graphic3d_Structure, Prs3d_Presentation - structure aspect methods have been removed.
    
    AIS_InteractiveObject::SetAspect() - globalChange argument has been removed.
    
    Undocumented test methods V3d::DrawSphere(), ::SetPlane(), ::PickGrid() have been removed.
(0055116)
kgv (developer)
2016-06-16 23:27

Patch is ready for review.
(0055123)
git (administrator)
2016-06-17 10:30

Branch CR26885 has been updated forcibly by kgv.

SHA-1: 02204e375a077585e82dd494090b6ae77d0aa984
(0055125)
git (administrator)
2016-06-17 11:16

Branch CR26885 has been updated forcibly by kgv.

SHA-1: da779162cbbbc2cd216e89882f9b064198e3aa9c
(0055175)
san (developer)
2016-06-17 14:46

Branch CR26885 reviewed without remarks, ready for testing.
(0055240)
apv (tester)
2016-06-20 16:26
edited on: 2016-06-20 16:26

Dear BugMaster,

Branch CR26885 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: da779162cbbbc2cd216e89882f9b064198e3aa9c

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 0 (0 on master)
products component:
   Linux: 68
   Windows: 0
   MacOS: 1119

Regressions/Differences:
http://occt-tests/CR26885-master-OCCT/Debian70-64/summary.html [^]
http://occt-tests/CR26885-master-OCCT/Windows-64-VC10/summary.html [^]
bugs vis bug23067, bug26754, bug26975

Testing on Linux:
Total MEMORY difference: 89671289 / 89135419 [+0.60%]
Total CPU difference: 19427.789999999997 / 19457.88999999997 [-0.15%]

Testing on Windows:
Total MEMORY difference: 55860575 / 55898813 [-0.07%]
Total CPU difference: 18441.205812098793 / 18535.524016698953 [-0.51%]

There are differences in images found by testdiff:
http://occt-tests/CR26885-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
http://occt-tests/CR26885-master-OCCT/Windows-64-VC10/diff-Windows-64-VC10.html [^]
v3d point_cloud sphere

(0055241)
apv (tester)
2016-06-20 16:28

Dear Kirill,

Branch CR26885 has been rejected due to:
- regressions/differences/improvements
- differences in images
(0055259)
git (administrator)
2016-06-20 19:05

Branch CR26885 has been updated by kgv.

SHA-1: 3d23d8a36a27fbcbbf3954eaf88cdb34b15cd8da


Detailed log of new commits:

Author: kgv
Date: Mon Jun 20 18:56:30 2016 +0300

    AIS_PointCloud now sets up ShadingAspect within Compute()
    and does not override PointAspect of global drawer.
    ViewerTest now sets group aspect within vuserdraw and vdrawparray.

(0055260)
git (administrator)
2016-06-20 19:10

Branch CR26885_1 has been created by kgv.

SHA-1: 0da88b20899dcd481230237bda9c6bbcd53d6f29


Detailed log of new commits:

Author: kgv
Date: Mon Jun 20 19:10:51 2016 +0300

    0026885: Visualization - drop redundant aspects from structure level
    
    Graphic3d_CStructure and OpenGl_Structure do not store structure aspects anymore.
    Graphic3d_Structure, Prs3d_Presentation - structure aspect methods have been removed.
    
    AIS_InteractiveObject::SetAspect() - globalChange argument has been removed.
    
    Undocumented test methods V3d::DrawSphere(), ::SetPlane(), ::PickGrid() have been removed.
(0055267)
kgv (developer)
2016-06-20 19:40

Regressions should be fixed within updated patch CR26885_.
(0055326)
apv (tester)
2016-06-22 11:02

Dear BugMaster,

Branch CR26885_1 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 0da88b20899dcd481230237bda9c6bbcd53d6f29

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 0 (0 on master)
products component:
   Linux: 68
   Windows: 0
   MacOS: 1140

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 88723219 / 89129632 [-0.46%]
Total CPU difference: 19421.43000000002 / 19458.48999999997 [-0.19%]

Testing on Windows:
Total MEMORY difference: 55859943 / 55904007 [-0.08%]
Total CPU difference: 18101.73203599882 / 18535.836018698956 [-2.34%]
(0055419)
git (administrator)
2016-06-24 12:57

Branch CR26885_1 has been deleted by inv.

SHA-1: 0da88b20899dcd481230237bda9c6bbcd53d6f29
(0055420)
git (administrator)
2016-06-24 12:57

Branch CR26885 has been deleted by inv.

SHA-1: 3d23d8a36a27fbcbbf3954eaf88cdb34b15cd8da

- Related Changesets
occt: master 2831708b
Timestamp: 2016-06-20 16:10:51
Author: kgv
Committer: bugmaster
Details ] Diff ]
0026885: Visualization - drop redundant aspects from structure level

Graphic3d_CStructure and OpenGl_Structure do not store structure aspects anymore.
Graphic3d_Structure, Prs3d_Presentation - structure aspect methods have been removed.

AIS_InteractiveObject::SetAspect() - globalChange argument has been removed.

Undocumented test methods V3d::DrawSphere(), ::SetPlane(), ::PickGrid() have been removed.
mod - dox/dev_guides/upgrade/upgrade.md Diff ] File ]
mod - src/AIS/AIS_InteractiveContext.cxx Diff ] File ]
mod - src/AIS/AIS_InteractiveContext.hxx Diff ] File ]
mod - src/AIS/AIS_InteractiveObject.cxx Diff ] File ]
mod - src/AIS/AIS_InteractiveObject.hxx Diff ] File ]
mod - src/AIS/AIS_Manipulator.cxx Diff ] File ]
mod - src/AIS/AIS_PointCloud.cxx Diff ] File ]
mod - src/AIS/AIS_Shape.cxx Diff ] File ]
mod - src/AIS/AIS_TexturedShape.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_CStructure.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_CStructure.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Group.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Structure.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Structure.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_Structure.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Structure.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Raytrace.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Workspace.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_Presentation.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_Presentation.hxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_Presentation.cxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_Presentation.hxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_PresentationManager.cxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_PresentationManager.hxx Diff ] File ]
mod - src/V3d/V3d.cxx Diff ] File ]
mod - src/V3d/V3d.hxx Diff ] File ]
mod - src/V3d/V3d_Plane.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_OpenGlCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-11-17 16:00 kgv New Issue
2015-11-17 16:00 kgv Assigned To => kgv
2015-11-17 16:00 kgv Relationship added child of 0023117
2016-06-16 23:26 git Note Added: 0055115
2016-06-16 23:27 kgv Note Added: 0055116
2016-06-16 23:27 kgv Assigned To kgv => san
2016-06-16 23:27 kgv Severity minor => integration request
2016-06-16 23:27 kgv Status new => resolved
2016-06-17 10:30 git Note Added: 0055123
2016-06-17 11:16 git Note Added: 0055125
2016-06-17 14:46 san Note Added: 0055175
2016-06-17 14:46 san Assigned To san => bugmaster
2016-06-17 14:46 san Status resolved => reviewed
2016-06-17 15:05 kgv Relationship added related to 0026612
2016-06-17 15:25 apv Assigned To bugmaster => apv
2016-06-20 16:26 apv Note Added: 0055240
2016-06-20 16:26 apv Assigned To apv => kgv
2016-06-20 16:26 apv Status reviewed => assigned
2016-06-20 16:26 apv Note Edited: 0055240 View Revisions
2016-06-20 16:28 apv Note Added: 0055241
2016-06-20 19:05 git Note Added: 0055259
2016-06-20 19:10 git Note Added: 0055260
2016-06-20 19:14 kgv Relationship added related to 0027617
2016-06-20 19:40 kgv Note Added: 0055267
2016-06-20 19:40 kgv Assigned To kgv => bugmaster
2016-06-20 19:40 kgv Status assigned => resolved
2016-06-20 19:40 kgv Status resolved => reviewed
2016-06-21 11:12 apv Assigned To bugmaster => apv
2016-06-22 11:00 apv Test case number => Not needed
2016-06-22 11:02 apv Note Added: 0055326
2016-06-22 11:02 apv Assigned To apv => bugmaster
2016-06-22 11:02 apv Status reviewed => tested
2016-06-24 12:41 bugmaster Changeset attached => occt master 2831708b
2016-06-24 12:41 bugmaster Status tested => verified
2016-06-24 12:41 bugmaster Resolution open => fixed
2016-06-24 12:57 git Note Added: 0055419
2016-06-24 12:57 git Note Added: 0055420
2016-07-27 16:44 kgv Relationship added parent of 0027717
2016-12-09 16:31 user533 Status verified => closed
2016-12-09 16:38 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker