MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025542Community[OCCT] OCCT:Modeling Algorithmspublic2014-12-01 16:342018-07-14 12:42
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformLinuxOSVC++ 2013OS Version64 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0025542: Boolean operation failure for Cylinder and Cone in critical location.
DescriptionBoolean operation for Cylinder and Cone works in most cases, but there are problem if the relative location is critical, e.g. the Cone's axis is coincident with the generatrix of the Cylinder. The shapes Cylinder.brep and Cone.brep files will help to reproduce the problem. Boolean Fuse/Common/Cut none works.

The bug is reproduced on Linux platform only.
Steps To ReproduceTest case has already been created and pushed to the branch.
TagsNo tags attached.
Test case numberbugs modalg_6 bug25542
Attached Filespng file icon Cylinder_Cone_BOP_Failure_Case.png (40,524 bytes) 2014-12-01 16:34
? file icon Cylinder.brep (14,447 bytes) 2014-12-01 16:34
? file icon Cone.brep (48,948 bytes) 2014-12-01 16:35

- Relationships
related to 0024418assignednbv Open CASCADE Wrong section curves when intersecting analytical surfaces 
related to 0029807verifiedbugmaster Open CASCADE [Regression to 7.0.0] Impossible to cut cone from prism 

-  Notes
(0048794)
nbv (developer)
2015-12-07 14:26

Dear Mikhail,

The result seems to be valid on the current MASTER.
(0048810)
msv (developer)
2015-12-07 16:49

Dear Nikolay, please create test case for this bug.
(0048867)
git (administrator)
2015-12-08 17:07

Branch CR25542 has been created by nbv.

SHA-1: bebe70670309dd856241670edd357b734e64b1a5


Detailed log of new commits:

Author: nbv
Date: Tue Dec 8 17:05:27 2015 +0300

    0025542: Boolean operation failure for Cylinder and Cone in critical location.
    
    Creation test case for this issue.
(0048868)
nbv (developer)
2015-12-08 17:08

Dear Mikhail,

Please review CR25542 branch.
(0048874)
msv (developer)
2015-12-08 18:20

Please make some modifications in order to:
1) not to involve vinit/vdisplay commands;
2) add checking by sprops.
(0049039)
git (administrator)
2015-12-11 15:01

Branch CR25542 has been updated forcibly by nbv.

SHA-1: 9550162a468a370cca8a40e425a93fe23712ee1c
(0049040)
nbv (developer)
2015-12-11 15:02

Dear Mikhail,

Please review the current state of CR25542 branch.
(0049061)
msv (developer)
2015-12-11 19:03

OK.
(0049149)
mkv (tester)
2015-12-15 15:04

Dear BugMaster,
Branch CR25542 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 9550162a468a370cca8a40e425a93fe23712ee1c

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 132 (134 on master)

products component :
Linux: 37 (37 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR25542-master-occt-64/Debian70-64/bugs/modalg_6/bug25542.html [^]
bugs modalg_6 bug25542: FAILED
http://occt-tests/CR25542-master-occt-64/Windows-64-VC10/bugs/modalg_6/bug25542.html [^]
bugs modalg_6 bug25542: OK

Testing on Linux:
occt component :
Total MEMORY difference: 93739489 / 94051408 [-0.33%]
Total CPU difference: 19803.38999999984 / 19278.349999999908 [+2.72%]
products component :
Total MEMORY difference: 26193717 / 26088083 [+0.40%]
Total CPU difference: 7840.439999999994 / 7351.649999999994 [+6.65%]

Testing on Windows:
occt component :
Total MEMORY difference: 56334671 / 56346339 [-0.02%]
Total CPU difference: 17827.201476198887 / 17820.197031298892 [+0.04%]
products component :
Total MEMORY difference: 16510174 / 16523518 [-0.08%]
Total CPU difference: 5659.107876099968 / 5736.593572799976 [-1.35%]

There are no differences in images found by testdiff.
(0049150)
git (administrator)
2015-12-15 15:04

Branch CR25542 has been updated by mkv.

SHA-1: 6e5ac74c6d1c6f25f09c3021ce5e5b64fb6cbdb1


Detailed log of new commits:

Author: mkv
Date: Tue Dec 15 15:03:50 2015 +0300

    Small correction of test case

(0049151)
mkv (tester)
2015-12-15 15:04

Dear nbv,
Branch CR25542 has been rejected due to:
- failed test-case for issue
(0049160)
nbv (developer)
2015-12-15 15:36

On the current MASTER, the bug is reproduced on Linux platform only.

On Windows, the Bug is fixed.
(0059154)
nbv (developer)
2016-10-26 11:31

The problem is still reproduced.
(0076759)
nbv (developer)
2018-06-14 09:52

This problem is fixed by the branch CR29807*
(0077385)
nbv (developer)
2018-07-09 10:31

This problem has been fixed. See "tests/bugs/modalg_7/bug25542" test case.
(0077626)
git (administrator)
2018-07-14 12:42

Branch CR25542 has been deleted by inv.

SHA-1: 6e5ac74c6d1c6f25f09c3021ce5e5b64fb6cbdb1

- Issue History
Date Modified Username Field Change
2014-12-01 16:34 Vico Liang New Issue
2014-12-01 16:34 Vico Liang Assigned To => msv
2014-12-01 16:34 Vico Liang File Added: Cylinder_Cone_BOP_Failure_Case.png
2014-12-01 16:34 Vico Liang File Added: Cylinder.brep
2014-12-01 16:35 Vico Liang File Added: Cone.brep
2015-07-16 09:23 nbv Relationship added related to 0024418
2015-07-16 09:23 nbv Assigned To msv => nbv
2015-10-28 10:53 msv Target Version 7.0.0 => 7.1.0
2015-12-07 14:26 nbv Note Added: 0048794
2015-12-07 14:26 nbv Assigned To nbv => msv
2015-12-07 14:26 nbv Status new => feedback
2015-12-07 16:49 msv Note Added: 0048810
2015-12-07 16:49 msv Assigned To msv => nbv
2015-12-07 16:49 msv Status feedback => assigned
2015-12-08 17:07 git Note Added: 0048867
2015-12-08 17:08 nbv Note Added: 0048868
2015-12-08 17:08 nbv Assigned To nbv => msv
2015-12-08 17:08 nbv Status assigned => resolved
2015-12-08 17:08 nbv Steps to Reproduce Updated View Revisions
2015-12-08 18:20 msv Note Added: 0048874
2015-12-08 18:20 msv Assigned To msv => nbv
2015-12-08 18:20 msv Status resolved => assigned
2015-12-11 15:01 git Note Added: 0049039
2015-12-11 15:02 nbv Note Added: 0049040
2015-12-11 15:02 nbv Assigned To nbv => msv
2015-12-11 15:02 nbv Status assigned => resolved
2015-12-11 19:03 msv Note Added: 0049061
2015-12-11 19:03 msv Assigned To msv => bugmaster
2015-12-11 19:03 msv Status resolved => reviewed
2015-12-14 13:13 mkv Assigned To bugmaster => mkv
2015-12-15 15:04 mkv Note Added: 0049149
2015-12-15 15:04 git Note Added: 0049150
2015-12-15 15:04 mkv Note Added: 0049151
2015-12-15 15:04 mkv Assigned To mkv => nbv
2015-12-15 15:04 mkv Status reviewed => assigned
2015-12-15 15:05 mkv Test case number => bugs modalg_6 bug25542
2015-12-15 15:36 nbv Note Added: 0049160
2015-12-15 15:37 nbv Platform Windows => Linux
2015-12-15 15:37 nbv Description Updated View Revisions
2016-10-25 19:04 msv Target Version 7.1.0 => 7.2.0
2016-10-26 11:31 nbv Note Added: 0059154
2017-07-21 11:34 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:09 msv Target Version 7.3.0 => 7.4.0*
2018-06-04 16:14 nbv Relationship added related to 0029807
2018-06-14 09:52 nbv Note Added: 0076759
2018-06-14 09:52 nbv Status assigned => feedback
2018-07-09 10:31 nbv Note Added: 0077385
2018-07-09 10:31 nbv Assigned To nbv => bugmaster
2018-07-09 10:56 bugmaster Status feedback => verified
2018-07-09 10:56 bugmaster Resolution open => fixed
2018-07-14 12:42 git Note Added: 0077626


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker