View Issue Details

IDProjectCategoryView StatusLast Update
0024418Open CASCADEOCCT:Modeling Algorithmspublic2022-03-17 09:06
Reporteremv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version6.6.0 
Target Version7.7.0 
Summary0024418: Modeling Algorithms - Wrong section curves when intersecting analytical surfaces
DescriptionThe intersection algorithm produces wrong section curves in the following test cases:
boolean bfuse_complex E6, F8
bugs modalg_2 bug20964_*
draft angle F9
Steps To Reproduce1. test bugs modalg_2 bug20964_1
brestore [locate_data_file OCC20964_revsolid.brep] b1
brestore [locate_data_file OCC20964_sphere.brep] b2
explode b1 f; copy b1_7 b1
explode b2 f; copy b2_1 b2
mksurface s1 b1
mksurface s2 b2
trimv s1t s1 0 230.14184397163115

# Sphere + Cylinder

intersect ii s1t s2
# 3 curves

bounds ii_2 u1 u2
xdistcs ii_2 s1 u1 u2 10 2.0e-7
# Max distance = 3.2632852455436544e-006

xdistcs ii_2 s2 u1 u2 10 2.0e-7
# Max distance = 0.01375619471412208

2. test draft angle F9
ptorus b1 25 24 90
plane p 20 20 10 0 0 1
pcone b2 p 10 8 40
explode b1 f; copy b1_1 b1
explode b2 f; copy b2_1 b2
mksurface s1 b1
mksurface s2 b2
trimu s1t s1 0 1.5707963267948966
trimv s2t s2 0 40.049968789001575
intersect ii s1t s2t

bounds ii_1 u1 u2
xdistcs ii_1 s1 u1 u2 10 2.0e-7
# Max distance = 4.0530416013101348e-006

xdistcs ii_1 s2 u1 u2 10 2.0e-7
# Max distance = 1.7347713433437292e-005

3.
Test case bugs modalg_5 bug25715_3
TagsNo tags attached.
Test case numberlowalgos intss bug24418_1

Attached Files

  • 001.png (12,063 bytes)

Relationships

related to 0024299 closedemv Open CASCADE Wrong section curve 
related to 0025404 closednbv Open CASCADE Even for analytical surfaces (cylinder-cylinder) intersection result is not commutative 
related to 0025542 closedbugmaster Community Boolean operation failure for Cylinder and Cone in critical location. 
related to 0024772 verifiedknosulko Community Modeling Algorithms - Intersection of cylinder and cone produces incorrect results 
related to 0025956 assignedmsv Open CASCADE Modeling Algorithms - Wrong result obtained by intersection algorithm. 
child of 0024094 closedbugmaster Community Issure by option of BRepAlgoAPI_Section 

Activities

emv

2014-12-22 12:08

developer  

001.png (12,063 bytes)

nbv

2015-01-15 11:49

developer   ~0036091

Dear msv.

I think, it is better for us to fix in this bugs some problems with ANALYTICAL intersection only.

Therefore, it is not worth bug # 25416 being related to this

nbv

2017-03-13 17:05

developer   ~0064281

Steps To Reproduce has been updated according to its behavior on the current state of OCCT developer version.

mkv

2017-11-02 12:24

tester   ~0071931

Problem is reproduced on the current master.

knosulko

2021-11-19 14:45

developer   ~0105270

Analysis
Debugging

knosulko

2021-11-23 20:35

developer   ~0105378

Analysis
Debugging

knosulko

2021-11-26 14:46

developer   ~0105449

Analysis
Solution elaboration

knosulko

2021-12-02 15:11

developer   ~0105607

Solution elaboration

knosulko

2021-12-03 16:05

developer   ~0105633

Solution implementation

knosulko

2021-12-10 14:50

developer   ~0105783

Solution implementation

knosulko

2021-12-10 14:51

developer   ~0105784

Testing

git

2021-12-10 17:24

administrator   ~0105790

Branch CR24418 has been created by knosulko.

SHA-1: 4447f294b7a5d44a5b896684e05e2d7b602b0eae


Detailed log of new commits:

Author: knosulko
Date: Mon Nov 15 17:02:03 2021 +0300

    0024418: Modeling Algorithms - Wrong section curves when intersecting analytical surfaces

git

2021-12-10 18:01

administrator   ~0105791

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: c428138cef918495f1abd4d031c2aa3e9cec33db

git

2021-12-15 23:39

administrator   ~0106005

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: dbf9fe14f31875ad485090f212c60a496b6b8a2d

git

2021-12-16 00:08

administrator   ~0106006

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: bce14a0d5244fc4d7e0c39885b796fef183838f1

git

2021-12-24 15:52

administrator   ~0106185

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: 8eb957152b10faba77878c312549c624ea00f3a5

knosulko

2021-12-24 16:13

developer   ~0106186

Branch CR24418 is ready for review
http://jenkins-test-08.nnov.opencascade.com/view/CR24418-master-knosulko/view/COMPARE/

Branches for Integration:
OCCT - CR24418
Products - Not

ifv

2021-12-24 18:14

developer   ~0106187

1. "Exact" comparison of two real value can lead to different results on different platforms or debug and release version of application.:
if ((aStep >= aLPar - aParameter) && (aLPar != aParameter)) - line 451 of IntPatch_ALineToWLine.cxx

2. Tests lowalgos intss bug27302, bug27282_2 are dedicated to check that intersection algorithm creates only one intersection curve, see issues #0027302, #0027282.
In your branch number of curves are 2, it can consider as regressions.

 

git

2021-12-30 13:48

administrator   ~0106243

Branch CR24418 has been updated by knosulko.

SHA-1: e460f80b467286b4e8e2c28527485c248db55074


Detailed log of new commits:

Author: knosulko
Date: Thu Dec 30 13:48:23 2021 +0300

    #fix remarks

git

2022-02-08 22:57

administrator   ~0106806

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: 69fbc9182a1651cec895e2d6a6e265b10eaf09c8

git

2022-02-17 03:21

administrator   ~0106938

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: 7ca4cf9bedec0b223cfbe793233c159b97e5741b

git

2022-02-17 12:38

administrator   ~0106943

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: 5beffa2f3b1ebd6e2fa6ce1862d0afb41e96c049

git

2022-02-17 14:00

administrator   ~0106944

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: 6920ed8f03084dc459d9df4657662b68d9bde759

knosulko

2022-02-17 15:45

developer   ~0106947

Branch CR24418 is ready for review
http://jenkins-test-08.nnov.opencascade.com/view/CR24418-master-knosulko/view/COMPARE/

Branches for Integration:
OCCT - CR24418
Products - Not

ifv

2022-02-18 11:09

developer   ~0106957

Remarks:
Standard_Boolean IsNeedSkipWL(....)
it is necessary to use static: static Standard_Boollean IsNeedSkipWL(...) for inner functions.

The function IsNeedSkipWL looks rather strange: on the one hand general adaptor surfaces are used, on the other - they have specific values of periods - 2pi. It is necessary to coordinate the types of surfaces and their properties in order to avoid misuse.

It is better to use a more generally accepted method ElCLib::InPeriod(...) instead of GeomInt::AdjustPeriodic(...)

git

2022-02-18 15:00

administrator   ~0106959

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: 3fbcc5e9a3ec54c7b910e9d203981da2976b0d1d

knosulko

2022-02-18 17:01

developer   ~0106961

Branch CR24418 is ready for review
http://jenkins-test-08.nnov.opencascade.com/view/CR24418-master-knosulko/view/COMPARE/

Branches for Integration:
OCCT - CR24418
Products - Not

ifv

2022-02-21 10:14

developer   ~0106998

Remove please useless #include <GeomInt.hxx> from IntPatch_WLineTool.cxx

git

2022-02-21 10:33

administrator   ~0106999

Branch CR24418 has been updated forcibly by knosulko.

SHA-1: bbdd700796f9a383ce54ec084c954c934fea3290

knosulko

2022-02-21 10:37

developer   ~0107000

Please review the branch CR24418.
http://jenkins-test-08.nnov.opencascade.com/view/CR24418-master-knosulko/view/COMPARE/

Branches for Integration:
OCCT - CR24418
Products - Not

ifv

2022-02-21 10:45

developer   ~0107004

Branch CR24418 seems to be valid

Branches for Integration:
OCCT - CR24418
Products - Not

smoskvin

2022-02-26 18:10

administrator   ~0107072

Combination -
OCCT branch : IR-2022-02-25
master SHA - e61aa824dbdbe2cdbdf3606827c136f3f70de90f
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2022-02-25 SHA - 859115827d7f98f21dc3e653fecea4c712aae052
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18467.180000000375 / 18497.380000000365 [-0.16%]
Products
Total CPU difference: 11716.630000000077 / 11705.020000000135 [+0.10%]
Windows-64-VC14:
OCCT
Total CPU difference: 20359.046875 / 20453.9375 [-0.46%]
Products
Total CPU difference: 13140.734375 / 13176.3125 [-0.27%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-02-26 19:21

administrator   ~0107076

Branch CR24418 has been deleted by mnt.

SHA-1: bbdd700796f9a383ce54ec084c954c934fea3290

Related Changesets

occt: master cfde7eeb

2021-11-15 17:02:03

knosulko


Committer: smoskvin Details Diff
0024418: Modeling Algorithms - Wrong section curves when intersecting analytical surfaces

IntPatch_ALineToWLine.cxx - setting minimal number of points in a WLine depending on step size
IntPatch_WLineTool.cxx - fix WLines connecting check condition
test cases has been changed according to new behavior
Affected Issues
0024418
mod - src/IntPatch/IntPatch_ALineToWLine.cxx Diff File
mod - src/IntPatch/IntPatch_WLineTool.cxx Diff File
mod - tests/bugs/modalg_1/bug10606_1 Diff File
mod - tests/bugs/modalg_1/bug10606_2 Diff File
mod - tests/bugs/modalg_1/bug10606_3 Diff File
mod - tests/bugs/modalg_1/bug10606_4 Diff File
mod - tests/bugs/modalg_1/bug10606_5 Diff File
mod - tests/bugs/modalg_1/bug10842_5 Diff File
mod - tests/bugs/modalg_2/bug20964_1 Diff File
mod - tests/bugs/modalg_2/bug20964_2 Diff File
mod - tests/bugs/modalg_2/bug20964_3 Diff File
mod - tests/bugs/modalg_2/bug20964_4 Diff File
mod - tests/bugs/modalg_2/bug20964_5 Diff File
mod - tests/bugs/modalg_5/bug25715_3 Diff File
mod - tests/bugs/modalg_6/bug28626_3 Diff File
mod - tests/lowalgos/intss/bug24418_1 Diff File

Issue History

Date Modified Username Field Change
2013-11-29 11:21 emv New Issue
2013-11-29 11:21 emv Assigned To => nbv
2013-11-29 11:27 emv Status new => assigned
2013-11-29 11:27 emv Description Updated
2013-11-29 11:27 emv Steps to Reproduce Updated
2013-11-29 11:27 emv Relationship added child of 0024094
2013-11-29 11:28 emv Relationship added related to 0024299
2014-09-12 13:01 abv Target Version => 7.1.0
2014-10-21 11:14 nbv Relationship added related to 0025404
2014-12-22 12:07 emv Steps to Reproduce Updated
2014-12-22 12:08 emv File Added: 001.png
2015-01-15 11:33 nbv Summary Wrong section curves => Wrong section curves when intersecting analytical surfaces
2015-01-15 11:49 nbv Note Added: 0036091
2015-01-28 09:33 nbv Steps to Reproduce Updated
2015-07-16 09:23 nbv Relationship added related to 0025542
2016-10-25 19:04 msv Target Version 7.1.0 => 7.2.0
2017-03-02 15:31 nbv Relationship added related to 0028503
2017-03-13 17:05 nbv Note Added: 0064281
2017-03-13 17:05 nbv Steps to Reproduce Updated
2017-07-24 09:22 msv Target Version 7.2.0 => 7.3.0
2017-11-02 12:24 mkv Test case number => bugs modalg_7 bug24418_1, bug24418_2
2017-11-02 12:24 mkv Note Added: 0071931
2017-12-05 17:08 msv Target Version 7.3.0 => 7.4.0
2018-06-19 13:10 nbv Relationship added related to 0024772
2018-06-20 14:05 nbv Relationship deleted related to 0028503
2018-07-09 10:50 nbv Steps to Reproduce Updated
2018-11-02 10:28 nbv Relationship added related to 0025956
2019-08-12 19:08 msv Assigned To nbv => msv
2019-08-12 19:11 msv Target Version 7.4.0 => Unscheduled
2019-09-04 12:12 kgv Summary Wrong section curves when intersecting analytical surfaces => Modeling Algorithms - Wrong section curves when intersecting analytical surfaces
2021-08-13 10:27 ifv Assigned To msv => user1069
2021-08-13 12:28 ifv Assigned To user1069 => user1071
2021-08-16 13:20 ifv Assigned To user1071 => user1069
2021-08-16 13:56 bugmaster Assigned To user1069 => knosulko
2021-11-19 14:45 knosulko Note Added: 0105270
2021-11-23 20:35 knosulko Note Added: 0105378
2021-11-26 14:46 knosulko Note Added: 0105449
2021-12-02 15:11 knosulko Note Added: 0105607
2021-12-03 16:05 knosulko Note Added: 0105633
2021-12-10 14:50 knosulko Note Added: 0105783
2021-12-10 14:51 knosulko Note Added: 0105784
2021-12-10 17:24 git Note Added: 0105790
2021-12-10 18:01 git Note Added: 0105791
2021-12-15 23:39 git Note Added: 0106005
2021-12-16 00:08 git Note Added: 0106006
2021-12-16 15:02 knosulko Test case number bugs modalg_7 bug24418_1, bug24418_2 => lowalgos intss bug24418_1
2021-12-17 15:25 knosulko Time allocated 13.12.2021: 8 h. => set
2021-12-17 15:27 knosulko Time allocated 14.12.2021: 8 h. => set
2021-12-17 15:27 knosulko Time allocated 15.12.2021: 8 h. => set
2021-12-17 15:29 knosulko Time allocated 16.12.2021: 4 h. => set
2021-12-17 15:31 knosulko Time allocated 16.12.2021: 4 h. => set
2021-12-17 15:33 knosulko Time allocated 17.12.2021: 8 h. => set
2021-12-23 13:09 knosulko Time allocated 20.12.2021: 8 h. => set
2021-12-23 13:09 knosulko Time allocated 21.12.2021: 8 h. => set
2021-12-23 13:10 knosulko Time allocated 22.12.2021: 8 h. => set
2021-12-23 13:10 knosulko Time allocated 23.12.2021: 8 h. => set
2021-12-23 13:11 knosulko Time allocated 24.12.2021: 8 h. => set
2021-12-24 15:52 git Note Added: 0106185
2021-12-24 16:13 knosulko Assigned To knosulko => ifv
2021-12-24 16:13 knosulko Status assigned => resolved
2021-12-24 16:13 knosulko Note Added: 0106186
2021-12-24 18:14 ifv Assigned To ifv => knosulko
2021-12-24 18:14 ifv Status resolved => assigned
2021-12-24 18:14 ifv Note Added: 0106187
2021-12-30 13:48 git Note Added: 0106243
2021-12-30 17:30 knosulko Time allocated 27.12.2021: 8 h. => set
2021-12-30 17:34 knosulko Time allocated 28.12.2021: 8 h. => set
2021-12-30 17:35 knosulko Time allocated 29.12.2021: 8 h. => set
2021-12-30 17:36 knosulko Time allocated 30.12.2021: 8 h. => set
2022-01-14 16:14 knosulko Time allocated 10.1.2022: 8 h. => set
2022-01-14 16:14 knosulko Time allocated 11.1.2022: 8 h. => set
2022-02-04 14:52 knosulko Time allocated 2.2.2022: 8 h. => set
2022-02-04 14:53 knosulko Time allocated 3.2.2022: 8 h. => set
2022-02-04 14:53 knosulko Time allocated 4.2.2022: 8 h. => set
2022-02-08 22:57 git Note Added: 0106806
2022-02-11 14:54 knosulko Time allocated 7.2.2022: 8 h. => set
2022-02-11 14:54 knosulko Time allocated 8.2.2022: 8 h. => set
2022-02-11 14:54 knosulko Time allocated 9.2.2022: 8 h. => set
2022-02-11 14:55 knosulko Time allocated 10.2.2022: 8 h. => set
2022-02-11 14:55 knosulko Time allocated 11.2.2022: 8 h. => set
2022-02-17 03:21 git Note Added: 0106938
2022-02-17 12:38 git Note Added: 0106943
2022-02-17 14:00 git Note Added: 0106944
2022-02-17 15:45 knosulko Assigned To knosulko => ifv
2022-02-17 15:45 knosulko Status assigned => resolved
2022-02-17 15:45 knosulko Note Added: 0106947
2022-02-18 11:09 ifv Assigned To ifv => knosulko
2022-02-18 11:09 ifv Status resolved => assigned
2022-02-18 11:09 ifv Note Added: 0106957
2022-02-18 11:14 ifv Time allocated 18.2.2022: 3 h. => set
2022-02-18 15:00 git Note Added: 0106959
2022-02-18 15:26 knosulko Time allocated 14.2.2022: 8 h. => set
2022-02-18 15:26 knosulko Time allocated Deleted 2022-02-14: 8,00 h. => deleted
2022-02-18 15:27 knosulko Time allocated 14.2.2022: 8 h. => set
2022-02-18 15:27 knosulko Time allocated 15.2.2022: 8 h. => set
2022-02-18 15:29 knosulko Time allocated 16.2.2022: 8 h. => set
2022-02-18 15:29 knosulko Time allocated 17.2.2022: 8 h. => set
2022-02-18 15:30 knosulko Time allocated 18.2.2022: 8 h. => set
2022-02-18 17:01 knosulko Assigned To knosulko => ifv
2022-02-18 17:01 knosulko Status assigned => resolved
2022-02-18 17:01 knosulko Note Added: 0106961
2022-02-21 10:14 ifv Assigned To ifv => knosulko
2022-02-21 10:14 ifv Status resolved => assigned
2022-02-21 10:14 ifv Note Added: 0106998
2022-02-21 10:33 git Note Added: 0106999
2022-02-21 10:37 knosulko Assigned To knosulko => ifv
2022-02-21 10:37 knosulko Status assigned => resolved
2022-02-21 10:37 knosulko Note Added: 0107000
2022-02-21 10:45 ifv Assigned To ifv => bugmaster
2022-02-21 10:45 ifv Status resolved => reviewed
2022-02-21 10:45 ifv Note Added: 0107004
2022-02-26 18:10 smoskvin Status reviewed => tested
2022-02-26 18:10 smoskvin Note Added: 0107072
2022-02-26 18:37 smoskvin Changeset attached => occt master cfde7eeb
2022-02-26 18:38 bugmaster Status tested => verified
2022-02-26 18:38 bugmaster Resolution open => fixed
2022-02-26 19:21 git Note Added: 0107076
2022-03-17 09:06 azv Target Version Unscheduled => 7.7.0