View Issue Details

IDProjectCategoryView StatusLast Update
0032963Open CASCADEOCCT:Data Exchangepublic2022-06-28 12:10
Reporteratereshi Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status feedbackResolutionopen 
Product Version7.6.0 
Target Version7.7.0 
Summary0032963: Data Exchange - create a convenient mechanism for managing shape healing options when reading STEP or IGES file
DescriptionDuring loading STEP and IGES files automatic shape healing is applied to loaded entities. Parameters of applied shape healing described in resource files
XSTEPResource/STEP
and
XSTEPResource/IGES
files. This method is very inconvenient: you can't dynamically change parameter from the program to adjust healing process for a specific file.
The task is to create a mechanism for enabling and disabling healing options from the program code and the DRAW interpreter.
Steps To ReproduceIt's improvement
TagsNo tags attached.
Test case number

Relationships

duplicate of 0028024 reviewedbugmaster Configuration - revise XSTEPResource initialization 

Activities

msv

2022-05-05 19:17

developer   ~0108353

In addition, it is needed to distribute this improvement on SAT and Parasolid readers in occt-products. See the files
XSTEPResourceAdv/SAT
XSTEPResourceAdv/XT

git

2022-06-02 14:17

administrator   ~0108793

Branch CR32963 has been created by atereshi.

SHA-1: 39180a7045a530d9bd781e3dfc93cc2fd837c4d4


Detailed log of new commits:

Author: atereshi
Date: Thu Jun 2 14:08:13 2022 +0300

    # Added "param2" DRAW command to create and delete Interface_Static parameters.

Author: atereshi
Date: Tue May 31 22:56:27 2022 +0300

    # Classes for options for operators have been developed

Author: atereshi
Date: Wed May 25 18:20:00 2022 +0300

    # Structures parameters for operations have been developed

Author: atereshi
Date: Mon May 16 16:17:12 2022 +0300

    # Coding Rules - removed commented code, braces, idents, spaces

git

2022-06-02 15:25

administrator   ~0108794

Branch CR32963 has been updated by atereshi.

SHA-1: 78f8f37bdf7ccfe89af5aff95b14f7b55cb5ffd8


Detailed log of new commits:

Author: atereshi
Date: Thu Jun 2 15:25:39 2022 +0300

    # Added runtime value of parameters support

git

2022-06-14 11:10

administrator   ~0108987

Branch CR32963 has been deleted by atereshi.

SHA-1: 78f8f37bdf7ccfe89af5aff95b14f7b55cb5ffd8

git

2022-06-14 11:10

administrator   ~0108988

Branch CR32963 has been created by atereshi.

SHA-1: 099a62430ff29170188bdfd0cc9e8fedd9af1bf7


Detailed log of new commits:

Author: atereshi
Date: Tue Jun 14 11:07:36 2022 +0300

    # Added static function "OperatorName2" to each operator options class.

Author: atereshi
Date: Thu Jun 2 15:25:39 2022 +0300

    # Added runtime value of parameters support

Author: atereshi
Date: Thu Jun 2 14:08:13 2022 +0300

    # Added "param2" DRAW command to create and delete Interface_Static parameters.

Author: atereshi
Date: Tue May 31 22:56:27 2022 +0300

    # Classes for options for operators have been developed

Author: atereshi
Date: Wed May 25 18:20:00 2022 +0300

    # Structures parameters for operations have been developed

Author: atereshi
Date: Mon May 16 16:17:12 2022 +0300

    # Coding Rules - removed commented code, braces, idents, spaces

git

2022-06-14 14:57

administrator   ~0109004

Branch CR32963 has been updated by atereshi.

SHA-1: 6fb1418b300697f9392d366ac7404ec6b7704f5a


Detailed log of new commits:

Author: atereshi
Date: Tue Jun 14 12:02:22 2022 +0300

    # The small fix after merge during rebase with master

kgv

2022-06-15 08:46

developer   ~0109019

Please close duplicate of 0028024.

git

2022-06-15 17:04

administrator   ~0109041

Branch CR32963 has been updated by atereshi.

SHA-1: 251f8b3d2e6cb00278b2773891634de8611ac5ae


Detailed log of new commits:

Author: atereshi
Date: Wed Jun 15 17:03:25 2022 +0300

    # Removed the tests "bugs heal bug24" and "bugs xde bug6805" due to lost of the resource files.

Author: atereshi
Date: Wed Jun 15 16:56:25 2022 +0300

    # Removed STEP and IGES resource files. Corrected help files.

Author: atereshi
Date: Wed Jun 15 15:36:29 2022 +0300

    # Fixed some default options

Author: atereshi
Date: Tue Jun 14 20:52:51 2022 +0300

    # Modified the test for bug32922 to use "param2" function

Author: atereshi
Date: Tue Jun 14 20:34:13 2022 +0300

    # Try to restore workability of the test for bug6805

git

2022-06-17 16:19

administrator   ~0109069

Branch CR32963 has been updated by atereshi.

SHA-1: 19d675873ffe5f68636019cb7e7468caab141ab3


Detailed log of new commits:

Author: atereshi
Date: Fri Jun 17 16:17:23 2022 +0300

    # Fixed number of shapes in "heal wire_tails_real A5" test due to a slight change in tolerance.

git

2022-06-20 10:23

administrator   ~0109102

Branch CR32963 has been deleted by atereshi.

SHA-1: 19d675873ffe5f68636019cb7e7468caab141ab3

git

2022-06-20 10:23

administrator   ~0109103

Branch CR32963 has been created by atereshi.

SHA-1: 9c554dcc55d8107240e95c1fa0b820241da4ad6e


Detailed log of new commits:

Author: atereshi
Date: Tue Jun 14 20:34:13 2022 +0300

    # Try to restore workability of the test for bug6805

Author: atereshi
Date: Tue Jun 14 20:52:51 2022 +0300

    # Modified the test for bug32922 to use "param2" function

Author: atereshi
Date: Wed Jun 15 15:36:29 2022 +0300

    # Fixed some default options

Author: atereshi
Date: Wed Jun 15 16:56:25 2022 +0300

    # Removed STEP and IGES resource files. Corrected help files.

Author: atereshi
Date: Wed Jun 15 17:03:25 2022 +0300

    # Removed the tests "bugs heal bug24" and "bugs xde bug6805" due to lost of the resource files.

Author: atereshi
Date: Fri Jun 17 16:17:23 2022 +0300

    # Fixed number of shapes in "heal wire_tails_real A5" test due to a slight change in tolerance.

Author: atereshi
Date: Wed May 25 18:20:00 2022 +0300

    # Structures parameters for operations have been developed

Author: atereshi
Date: Tue May 31 22:56:27 2022 +0300

    # Classes for options for operators have been developed

Author: atereshi
Date: Thu Jun 2 14:08:13 2022 +0300

    # Added "param2" DRAW command to create and delete Interface_Static parameters.

Author: atereshi
Date: Thu Jun 2 15:25:39 2022 +0300

    # Added runtime value of parameters support

Author: atereshi
Date: Tue Jun 14 11:07:36 2022 +0300

    # Added static function "OperatorName2" to each operator options class.

Author: atereshi
Date: Tue Jun 14 12:02:22 2022 +0300

    # The small fix after merge during rebase with master

Author: atereshi
Date: Mon May 16 16:17:12 2022 +0300

    # Coding Rules - removed commented code, braces, idents, spaces

git

2022-06-20 12:44

administrator   ~0109110

Branch CR32963 has been updated by atereshi.

SHA-1: 947e6f63bcb4877dffa2000c32090d941091ac11


Detailed log of new commits:

Author: atereshi
Date: Mon Jun 20 12:44:40 2022 +0300

    # Added the check for null options

git

2022-06-20 15:31

administrator   ~0109119

Branch CR32963 has been updated by atereshi.

SHA-1: dacded5952040e79d4afdbbefe76b88874729fcc


Detailed log of new commits:

Author: atereshi
Date: Mon Jun 20 15:28:49 2022 +0300

    # Made StrToContinuity a public function

git

2022-06-21 18:22

administrator   ~0109164

Branch CR32963 has been updated by atereshi.

SHA-1: d40af4b1cb11d0a1c4e61dfa30d65ab0a6e1a2d4


Detailed log of new commits:

Author: atereshi
Date: Tue Jun 21 18:21:55 2022 +0300

    # removed DEFINE_STANDARD_ALLOC from transient class

git

2022-06-22 16:09

administrator   ~0109178

Branch CR32963 has been updated by atereshi.

SHA-1: c51ac84ef127a903c92c0a56072c6ea8cca74f65


Detailed log of new commits:

Author: atereshi
Date: Wed Jun 22 16:08:56 2022 +0300

    # moved the static keyword to the first position, to avoid errors in SWIG

git

2022-06-23 21:36

administrator   ~0109209

Branch CR32963 has been updated by atereshi.

SHA-1: 86a76ccb1b69699325d907f2b37c7558e5dca704


Detailed log of new commits:

Author: atereshi
Date: Thu Jun 23 21:35:18 2022 +0300

    # deleted the unused headers and done some cosmetic

git

2022-06-24 15:21

administrator   ~0109229

Branch CR32963 has been updated by atereshi.

SHA-1: 10a8d0e7c3f2be1b080ccc9db4b26c77c9cf054d


Detailed log of new commits:

Author: atereshi
Date: Fri Jun 24 15:20:43 2022 +0300

    # removed the unused duplicated DRAW command, removes the duplicated code in PrintPreparationResult()

Author: atereshi
Date: Fri Jun 24 14:11:38 2022 +0300

    # removed the typedef, which generates a long class name in java wrapper

git

2022-06-27 19:35

administrator   ~0109291

Branch CR32963 has been updated by atereshi.

SHA-1: 6160b2664188369b48ad4144bbcd6b46e1e2df8f


Detailed log of new commits:

Author: atereshi
Date: Mon Jun 27 19:35:22 2022 +0300

    # corrected the typedef, which generates a long class name in java wrapper

git

2022-06-27 22:09

administrator   ~0109306

Branch CR32963 has been deleted by atereshi.

SHA-1: 6160b2664188369b48ad4144bbcd6b46e1e2df8f

git

2022-06-27 22:09

administrator   ~0109307

Branch CR32963 has been created by atereshi.

SHA-1: 3e067eb06ba9f9989fba7c4a9ab8bc1ac1c2bbb3


Detailed log of new commits:

Author: atereshi
Date: Thu Jun 23 21:35:18 2022 +0300

    # deleted the unused headers and done some cosmetic

Author: atereshi
Date: Fri Jun 24 14:11:38 2022 +0300

    # removed the typedef, which generates a long class name in java wrapper

Author: atereshi
Date: Fri Jun 24 15:20:43 2022 +0300

    # removed the unused duplicated DRAW command, removes the duplicated code in PrintPreparationResult()

Author: atereshi
Date: Mon Jun 27 19:35:22 2022 +0300

    # corrected the typedef, which generates a long class name in java wrapper

Author: atereshi
Date: Wed Jun 15 16:56:25 2022 +0300

    # Removed STEP and IGES resource files. Corrected help files.

Author: atereshi
Date: Wed Jun 15 17:03:25 2022 +0300

    # Removed the tests "bugs heal bug24" and "bugs xde bug6805" due to lost of the resource files.

Author: atereshi
Date: Fri Jun 17 16:17:23 2022 +0300

    # Fixed number of shapes in "heal wire_tails_real A5" test due to a slight change in tolerance.

Author: atereshi
Date: Mon Jun 20 12:44:40 2022 +0300

    # Added the check for null options

Author: atereshi
Date: Mon Jun 20 15:28:49 2022 +0300

    # Made StrToContinuity a public function

Author: atereshi
Date: Tue Jun 21 18:21:55 2022 +0300

    # removed DEFINE_STANDARD_ALLOC from transient class

Author: atereshi
Date: Wed Jun 22 16:08:56 2022 +0300

    # moved the static keyword to the first position, to avoid errors in SWIG

Author: atereshi
Date: Thu Jun 2 14:08:13 2022 +0300

    # Added "param2" DRAW command to create and delete Interface_Static parameters.

Author: atereshi
Date: Thu Jun 2 15:25:39 2022 +0300

    # Added runtime value of parameters support

Author: atereshi
Date: Tue Jun 14 11:07:36 2022 +0300

    # Added static function "OperatorName2" to each operator options class.

Author: atereshi
Date: Tue Jun 14 12:02:22 2022 +0300

    # The small fix after merge during rebase with master

Author: atereshi
Date: Tue Jun 14 20:34:13 2022 +0300

    # Try to restore workability of the test for bug6805

Author: atereshi
Date: Tue Jun 14 20:52:51 2022 +0300

    # Modified the test for bug32922 to use "param2" function

Author: atereshi
Date: Wed Jun 15 15:36:29 2022 +0300

    # Fixed some default options

Author: atereshi
Date: Tue May 31 22:56:27 2022 +0300

    # Classes for options for operators have been developed

Author: atereshi
Date: Wed May 25 18:20:00 2022 +0300

    # Structures parameters for operations have been developed

Author: atereshi
Date: Mon May 16 16:17:12 2022 +0300

    # Coding Rules - removed commented code, braces, idents, spaces

git

2022-06-28 08:39

administrator   ~0109317

Branch CR32963 has been updated by atereshi.

SHA-1: 0d35d87d48250a10bd369f4adbba5b4cb85c6903


Detailed log of new commits:

Author: atereshi
Date: Tue Jun 28 08:39:14 2022 +0300

    # deleted the empty file

atereshi

2022-06-28 09:27

developer   ~0109320

Branch CR32963_0 is ready to review. Step by step commits are avaliable in branch CR32963.

kgv

2022-06-28 09:31

developer   ~0109321

@atereshi, please read the messages, this bug is a duplicate of 0028024 and should be closed.
Development should be moved to an appropriate ticket.

atereshi

2022-06-28 12:10

developer   ~0109331

Last edited: 2022-06-28 12:10

@kgv
The development moved to 0028024. Please close this issue as a duplicated one.

Issue History

Date Modified Username Field Change
2022-05-05 17:02 atereshi New Issue
2022-05-05 17:02 atereshi Assigned To => msv
2022-05-05 19:14 msv Product Version 7.7.0 => 7.6.0
2022-05-05 19:17 msv Note Added: 0108353
2022-05-05 19:18 msv Assigned To msv => atereshi
2022-05-05 19:18 msv Status new => assigned
2022-06-02 14:17 git Note Added: 0108793
2022-06-02 15:25 git Note Added: 0108794
2022-06-14 11:10 git Note Added: 0108987
2022-06-14 11:10 git Note Added: 0108988
2022-06-14 14:57 git Note Added: 0109004
2022-06-15 08:46 kgv Relationship added duplicate of 0028024
2022-06-15 08:46 kgv Assigned To atereshi => bugmaster
2022-06-15 08:46 kgv Status assigned => feedback
2022-06-15 08:46 kgv Note Added: 0109019
2022-06-15 17:04 git Note Added: 0109041
2022-06-17 16:19 git Note Added: 0109069
2022-06-20 10:23 git Note Added: 0109102
2022-06-20 10:23 git Note Added: 0109103
2022-06-20 12:44 git Note Added: 0109110
2022-06-20 15:31 git Note Added: 0109119
2022-06-21 18:22 git Note Added: 0109164
2022-06-22 16:09 git Note Added: 0109178
2022-06-23 21:36 git Note Added: 0109209
2022-06-24 15:21 git Note Added: 0109229
2022-06-27 19:35 git Note Added: 0109291
2022-06-27 22:09 git Note Added: 0109306
2022-06-27 22:09 git Note Added: 0109307
2022-06-28 08:39 git Note Added: 0109317
2022-06-28 09:27 atereshi Assigned To bugmaster => msv
2022-06-28 09:27 atereshi Status feedback => resolved
2022-06-28 09:27 atereshi Steps to Reproduce Updated
2022-06-28 09:27 atereshi Note Added: 0109320
2022-06-28 09:31 kgv Note Added: 0109321
2022-06-28 09:31 kgv Assigned To msv => bugmaster
2022-06-28 09:31 kgv Status resolved => feedback
2022-06-28 12:10 atereshi Note Added: 0109331
2022-06-28 12:10 atereshi Note Edited: 0109331