MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031001Open CASCADE[OCCT] OCCT:Documentationpublic2019-09-25 17:492019-09-29 12:37
Reporterapn 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.4.0Fixed in Version 
Summary0031001: Documentation - modeling_algos.md can not be generated
DescriptionGenerating OCCT User Guides in PDF format...
Info: Processing file user_guides/modeling_algos/modeling_algos.md
2019-09-25 17:41 Generating Doxyfile...
2019-09-25 17:41 Generating PDF file...
Warning: Doxygen reported 14 messages.
See log in D:/740beta/occt_new/doc/modeling_algos_doxygen_err.log
Warning: PDFLaTeX reported 9 messages.
See log in D:/740beta/occt_new/doc/modeling_algos_pdflatex_err.log
Fatal: PDFLaTeX failed to create output file, stopping!
Steps To Reproducegendoc.bat -overview -pdf -ug=user_guides/modeling_algos/modeling_algos.md
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0030129verifiedapn With newest doxygen 1.8.14 generation of overview gives warnings 

-  Notes
(0087518)
git (administrator)
2019-09-25 19:30

Branch CR31001 has been created by apn.

SHA-1: 546a954d5bb460958bb3342896fbcec1dd5c6808


Detailed log of new commits:

Author: apn
Date: Wed Sep 25 19:30:01 2019 +0300

    0031001: Documentation - modeling_algos.md can not be generated
    
    '\n' was returned to @figure ALIAS because it doesn't cause the appearance of warnings during generation of PDF documentation
(0087519)
apn (administrator)
2019-09-25 19:36

There are no any warnings during generation of overview with doxygen 1.8.14 (regardless of the presence of \n symbol in \resources\occt_ug_html or \resources\occt_ug_pdf doxyfiles).
In the newest doxygen 1.8.16 warnings appear in any cases (with or without \n).
So for successfully generation of tables with images (created by @figure ALIAS) in modeling_algos.md \n was returned in the \resources\occt_ug_pdf.doxyfile.

Dear ski, could you pleae review.
(0087630)
git (administrator)
2019-09-29 12:37

Branch CR31001 has been deleted by inv.

SHA-1: 546a954d5bb460958bb3342896fbcec1dd5c6808

- Related Changesets
occt: master cf976857
Timestamp: 2019-09-25 16:30:01
Author: apn
Committer: bugmaster
Details ] Diff ]
0031001: Documentation - modeling_algos.md can not be generated

'\n' was returned to @figure ALIAS because it doesn't cause the appearance of warnings during generation of PDF documentation
mod - dox/resources/occt_ug_pdf.doxyfile Diff ] File ]

- Issue History
Date Modified Username Field Change
2019-09-25 17:49 apn New Issue
2019-09-25 17:49 apn Assigned To => apn
2019-09-25 17:51 apn Test case number => Not needed
2019-09-25 17:51 apn Description Updated View Revisions
2019-09-25 19:30 git Note Added: 0087518
2019-09-25 19:31 apn Relationship added related to 0030129
2019-09-25 19:36 apn Note Added: 0087519
2019-09-25 19:36 apn Assigned To apn => ski
2019-09-25 19:36 apn Status new => resolved
2019-09-25 19:45 ski Assigned To ski => bugmaster
2019-09-25 19:45 ski Status resolved => reviewed
2019-09-25 21:21 bugmaster Status reviewed => tested
2019-09-29 12:19 bugmaster Changeset attached => occt master cf976857
2019-09-29 12:19 bugmaster Status tested => verified
2019-09-29 12:19 bugmaster Resolution open => fixed
2019-09-29 12:37 git Note Added: 0087630


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker