MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030731Community[OCCT] OCCT:Modeling Datapublic2019-05-23 15:472019-06-01 13:59
ReporterBenjaminBihler 
Assigned Tomsv 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 6.5.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0030731: Modeling Data - B-Spline should have explicit data check error messages
DescriptionThe 2D B-Spline has them!
Steps To ReproduceNot required
TagsNo tags attached.
Test case number
Attached Files

- Relationships
related to 0028550closedbugmaster Open CASCADE Foundation Classes - fix empty message passed to thrown exception 

-  Notes
(0084573)
git (administrator)
2019-05-23 15:53

Branch CR30731 has been created by BenjaminBihler.

SHA-1: 21780a0166c85fb0f1f42021a8edc7eedea04182


Detailed log of new commits:

Author: Benjamin Bihler
Date: Thu May 23 14:49:50 2019 +0200

    0030731: Modeling Data - B-Spline should have explicit data check error messages
    
    Added error messages from Geom2d_BSplineCurve.
(0084577)
msv (developer)
2019-05-23 16:53

Hello Benjamin,

Thank you for the fix. However, it is not complete. The same file Geom_BSplineCurve.cxx contains many other places where throw is used without a message.

Moreover, the same issue is with other files in Geom and Geom2d packages.

Could you, please complete the patch? If you have no time to update all other files, please update at least all B-Spline-related files in order to complete the issue according to its subject.
(0084578)
BenjaminBihler (developer)
2019-05-23 17:08

The issue subject states that "data check" error messages are concerned and therefore fixing CheckCurveData(...) suffices! ;)

I will do my best...
(0084582)
git (administrator)
2019-05-23 18:02

Branch CR30731 has been updated by BenjaminBihler.

SHA-1: c928b44a1e291b37416b546a21484fde34adcf5f


Detailed log of new commits:

Author: Benjamin Bihler
Date: Thu May 23 16:58:40 2019 +0200

     0030731: Modeling Data - B-Spline should have explicit data check error messages
    
    Slightly harmonized error message formatting.

Author: Benjamin Bihler
Date: Thu May 23 16:55:06 2019 +0200

     0030731: Modeling Data - B-Spline should have explicit data check error messages
    
    Added more error messages from Geom2d_BSplineCurve.

(0084583)
git (administrator)
2019-05-23 18:19

Branch CR30731 has been updated by msv.

SHA-1: ee23d1687c777905a4a3665f05ddc43803975a8c


Detailed log of new commits:

Author: msv
Date: Thu May 23 18:19:25 2019 +0300

    #Correct exception message in SetKnot

(0084584)
msv (developer)
2019-05-23 18:26

In Geom_BSplineSurface the method CheckSurfaceData() and others also contain non-informative message or no message at all.
(0084652)
BenjaminBihler (developer)
2019-05-27 09:50

I am sorry, but I couldn't justify this additional fix to my boss, since it would be unrelated to my current task.
(0084659)
git (administrator)
2019-05-27 12:22

Branch CR30731_1 has been created by msv.

SHA-1: 1b827f04843bb9323b0e663aacafe3400eaf3eea


Detailed log of new commits:

Author: Benjamin Bihler
Date: Thu May 23 15:49:50 2019 +0300

    0030731: Modeling Data - B-Spline should have explicit data check error messages
    
    Error messages have been added in throw statements.
(0084661)
msv (developer)
2019-05-27 12:30

Dear Kirill, please review.
The branch is being tested http://jenkins-test-12.nnov.opencascade.com/view/CR30731-master-MSV/view/COMPARE/ [^]
(0084674)
bugmaster (administrator)
2019-05-27 18:10

Combination -
OCCT branch : CR30731_1
master SHA - 1b827f04843bb9323b0e663aacafe3400eaf3eea
d67d4b811012eef8913d3c535c29654d0acf3c4c
Products branch : master SHA - a9ff0b340afc3724a2378364c2f8a4faf89254d6
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 16286.150000000023 / 16292.829999999974 [-0.04%]
Products
Total CPU difference: 10505.930000000062 / 10481.610000000046 [+0.23%]
Windows-64-VC14:
OCCT
Total CPU difference: 17744.65625 / 17706.828125 [+0.21%]
Products
Total CPU difference: 12108.140625 / 12047.171875 [+0.51%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0084751)
git (administrator)
2019-06-01 13:59

Branch CR30731_1 has been deleted by inv.

SHA-1: 1b827f04843bb9323b0e663aacafe3400eaf3eea
(0084753)
git (administrator)
2019-06-01 13:59

Branch CR30731 has been deleted by inv.

SHA-1: ee23d1687c777905a4a3665f05ddc43803975a8c

- Related Changesets
occt: master 1b827f04
Timestamp: 2019-05-23 12:49:50
Author: msv
Committer: msv
Details ] Diff ]
0030731: Modeling Data - B-Spline should have explicit data check error messages

Error messages have been added in throw statements.
mod - src/Geom/Geom_BSplineCurve.cxx Diff ] File ]
mod - src/Geom/Geom_BSplineSurface.cxx Diff ] File ]
mod - src/Geom/Geom_BSplineSurface_1.cxx Diff ] File ]
mod - src/Geom2d/Geom2d_BSplineCurve.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2019-05-23 15:47 BenjaminBihler New Issue
2019-05-23 15:47 BenjaminBihler Assigned To => msv
2019-05-23 15:48 BenjaminBihler Assigned To msv => BenjaminBihler
2019-05-23 15:53 git Note Added: 0084573
2019-05-23 15:54 BenjaminBihler Assigned To BenjaminBihler => msv
2019-05-23 15:54 BenjaminBihler Status new => resolved
2019-05-23 15:54 BenjaminBihler Steps to Reproduce Updated View Revisions
2019-05-23 16:36 kgv Relationship added related to 0028550
2019-05-23 16:53 msv Note Added: 0084577
2019-05-23 16:53 msv Assigned To msv => BenjaminBihler
2019-05-23 16:53 msv Status resolved => assigned
2019-05-23 17:08 BenjaminBihler Note Added: 0084578
2019-05-23 18:02 git Note Added: 0084582
2019-05-23 18:03 BenjaminBihler Assigned To BenjaminBihler => msv
2019-05-23 18:03 BenjaminBihler Status assigned => resolved
2019-05-23 18:19 git Note Added: 0084583
2019-05-23 18:26 msv Note Added: 0084584
2019-05-23 18:27 msv Assigned To msv => BenjaminBihler
2019-05-23 18:27 msv Status resolved => assigned
2019-05-27 09:50 BenjaminBihler Note Added: 0084652
2019-05-27 09:50 BenjaminBihler Assigned To BenjaminBihler => msv
2019-05-27 12:22 git Note Added: 0084659
2019-05-27 12:30 msv Note Added: 0084661
2019-05-27 12:30 msv Assigned To msv => kgv
2019-05-27 12:30 msv Status assigned => resolved
2019-05-27 17:18 kgv Assigned To kgv => bugmaster
2019-05-27 17:18 kgv Status resolved => reviewed
2019-05-27 18:10 bugmaster Note Added: 0084674
2019-05-27 18:10 bugmaster Status reviewed => tested
2019-06-01 13:50 msv Changeset attached => occt master 1b827f04
2019-06-01 13:50 msv Assigned To bugmaster => msv
2019-06-01 13:50 msv Status tested => verified
2019-06-01 13:50 msv Resolution open => fixed
2019-06-01 13:59 git Note Added: 0084751
2019-06-01 13:59 git Note Added: 0084753


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker