MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030269Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2018-10-19 11:042018-10-28 16:13
Reporterkgv 
Assigned Toapn 
PrioritynormalSeveritytrivial 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.3.1 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0030269: Modeling Algorithms - unhandled Standard_NullObject within BRepBndLib::Add()
DescriptionTrying to compute AABB for an invalid shape with Edge having no curve leads to Standard_NullObject.

This is unexpected and inconsistent to other places within BRepBndLib which just skip Edges without geometry.
TagsNo tags attached.
Test case numberbugs modalg_7 bug30269
Attached Files? file icon f.brep (2,191 bytes) 2018-10-20 13:20

- Relationships
related to 0029939verifiedbugmaster Open CASCADE Modeling Algorithms - add NULL check to BRepGProp_Face::Load() 

-  Notes
(0080117)
git (administrator)
2018-10-19 11:09

Branch CR30269 has been created by kgv.

SHA-1: 96a685718d322d1ef588a80c02913cc5161d039d


Detailed log of new commits:

Author: kgv
Date: Fri Oct 19 11:06:41 2018 +0300

    0030269: Modeling Algorithms - unhandled Standard_NullObject within BRepBndLib::Add()
    
    Added BRep_Tool::IsGeometric() check before every BRepAdaptor_Curve::Initialize().
(0080118)
kgv (developer)
2018-10-19 11:10

Trivial patch is ready for review.
(0080140)
msv (developer)
2018-10-19 16:30

Line 283 is extra if edge is not geometric. The better fix is to put check for geometry in the line 272 "if(BRep_Tool::Degenerated(anE))".
The same is for line 308.
Please consider creating a test case.
(0080149)
git (administrator)
2018-10-20 13:22

Branch CR30269_1 has been created by kgv.

SHA-1: 412c640c012e6dc4cffc992788445f6c46a6dace


Detailed log of new commits:

Author: kgv
Date: Fri Oct 19 11:06:41 2018 +0300

    0030269: Modeling Algorithms - unhandled Standard_NullObject within BRepBndLib::Add()
    
    Added BRep_Tool::IsGeometric() check before every BRepAdaptor_Curve::Initialize().
(0080150)
kgv (developer)
2018-10-20 13:23

Updated patch is ready for review.

The fix has been also propagated to OBB.
(0080151)
msv (developer)
2018-10-20 18:49

No remarks to the code. I did not find test results.
(0080152)
git (administrator)
2018-10-21 12:41

Branch CR30269_1 has been updated forcibly by kgv.

SHA-1: cb5cb3b58ce736c1d709f782c79a6a018770406b
(0080153)
kgv (developer)
2018-10-21 12:43

Test case bugs/vis/bug641 has been updated as IMPROVEMENT
(the original issue #0000641 for the same bug has been closed for unknown reason).

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30269_1-master-KGV/ [^]
(0080157)
git (administrator)
2018-10-21 15:09

Branch CR30269_1 has been updated forcibly by kgv.

SHA-1: e653d5f7172ba5709d1f2979b57fac7c5096d8f1
(0080169)
msv (developer)
2018-10-22 10:46

Reviewed.
(0080198)
apn (administrator)
2018-10-22 16:14

Combination -
OCCT branch : CR30269_1 SHA - e653d5f7172ba5709d1f2979b57fac7c5096d8f1
Products branch : master SHA - cd3543d117f1e585e93c7a94dee07b720ee3fd36
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

Test case:
bugs modalg_7 bug30269 - OK

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17622.289999999895 / 17553.839999999873 [+0.39%]
Products
Total CPU difference: 7428.9400000000605 / 7416.290000000055 [+0.17%]
Windows-64-VC14:
OCCT
Total CPU difference: 17668.174056798347 / 17582.732309098545 [+0.49%]
Products
Total CPU difference: 8346.474702699976 / 8362.40240479998 [-0.19%]

Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0080419)
git (administrator)
2018-10-28 16:13

Branch CR30269_1 has been deleted by inv.

SHA-1: e653d5f7172ba5709d1f2979b57fac7c5096d8f1
(0080420)
git (administrator)
2018-10-28 16:13

Branch CR30269 has been deleted by inv.

SHA-1: 96a685718d322d1ef588a80c02913cc5161d039d

- Related Changesets
occt: master 87a64d53
Timestamp: 2018-10-19 08:06:41
Author: kgv
Committer: apn
Details ] Diff ]
0030269: Modeling Algorithms - unhandled Standard_NullObject within BRepBndLib::Add()

Added BRep_Tool::IsGeometric() check before every BRepAdaptor_Curve::Initialize().
mod - src/BRepBndLib/BRepBndLib.cxx Diff ] File ]
mod - src/BRepBndLib/BRepBndLib_1.cxx Diff ] File ]
add - tests/bugs/modalg_7/bug30269 Diff ] File ]
mod - tests/bugs/vis/bug641 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-10-19 11:04 kgv New Issue
2018-10-19 11:04 kgv Assigned To => msv
2018-10-19 11:09 git Note Added: 0080117
2018-10-19 11:10 kgv Note Added: 0080118
2018-10-19 11:10 kgv Severity minor => trivial
2018-10-19 11:10 kgv Status new => resolved
2018-10-19 11:12 kgv Product Version 7.3.0 => 6.3.1
2018-10-19 16:30 msv Note Added: 0080140
2018-10-19 16:30 msv Assigned To msv => kgv
2018-10-19 16:30 msv Status resolved => assigned
2018-10-20 13:20 kgv File Added: f.brep
2018-10-20 13:22 git Note Added: 0080149
2018-10-20 13:23 kgv Relationship added related to 0029939
2018-10-20 13:23 kgv Note Added: 0080150
2018-10-20 13:23 kgv Assigned To kgv => msv
2018-10-20 13:23 kgv Status assigned => resolved
2018-10-20 13:41 kgv Relationship added related to 0030274
2018-10-20 18:49 msv Note Added: 0080151
2018-10-21 12:27 kgv Relationship added duplicate of 0000641
2018-10-21 12:30 kgv Relationship replaced related to 0000641
2018-10-21 12:41 git Note Added: 0080152
2018-10-21 12:43 kgv Note Added: 0080153
2018-10-21 12:44 kgv Relationship replaced has duplicate 0000641
2018-10-21 15:09 git Note Added: 0080157
2018-10-22 10:46 msv Note Added: 0080169
2018-10-22 10:46 msv Assigned To msv => bugmaster
2018-10-22 10:46 msv Status resolved => reviewed
2018-10-22 16:14 apn Test case number => bugs modalg_7 bug30269
2018-10-22 16:14 apn Note Added: 0080198
2018-10-22 16:14 apn Status reviewed => tested
2018-10-28 13:20 apn Changeset attached => occt master 87a64d53
2018-10-28 13:20 apn Assigned To bugmaster => apn
2018-10-28 13:20 apn Status tested => verified
2018-10-28 13:20 apn Resolution open => fixed
2018-10-28 16:13 git Note Added: 0080419
2018-10-28 16:13 git Note Added: 0080420


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker