MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029250Open CASCADE[OCCT] OCCT:Configurationpublic2017-10-19 15:472018-06-29 21:19
Reporterapn 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.9.1 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0029250: Configuration, TKIVtk - build failure with VTK 6.3+ due to vtkRenderingFreeTypeOpenGL being removed
DescriptionTKIVtk/EXTERNLIB and TKIVtkDraw/EXTERNLIB contain dependency from vtkRenderingFreeTypeOpenGL, which is not supported in VTK 6.3.0 and above
Steps To Reproducebuild OCCT using VTK 6.3.0 (with VTK_RENDERING_BACKEND equal to OpenGL and OpenGL2) and above
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0071727)
git (administrator)
2017-10-24 11:01

Branch CR29250 has been created by apn.

SHA-1: 84bed06cc3650f388ed0060848bb7a4d535ae630


Detailed log of new commits:

Author: apn
Date: Tue Oct 24 11:00:54 2017 +0300

    0029250: VTK-7 compatibility problem because of RenderingFreeTypeOpenGL module no longer exists in latest vtk
    
    Remove vtkRenderingFreeTypeOpenGL from EXTERNLIB if used vtk version is 6.3.0 and above
(0071732)
kgv (developer)
2017-10-24 11:34
edited on: 2017-10-24 11:34

Please don't forget specifying the OCCT version [Product Version] affected by this problem in bug track (I suppose it is OCCT 6.2.0 and maybe earlier?).

(0071746)
git (administrator)
2017-10-24 15:57

Branch CR29250 has been updated forcibly by apn.

SHA-1: e3c339cc1de235f6cde5ed433f5114071cadf3d1
(0071756)
git (administrator)
2017-10-24 18:16

Branch CR29250 has been updated forcibly by apn.

SHA-1: 542f268b0e5a14c8bed2c8bda0c89b15445645e8
(0071757)
apn (administrator)
2017-10-24 19:06

Dear ski, could you please review CR29250.
(0071779)
bugmaster (administrator)
2017-10-25 14:49

Tested with VTK 7.1.1
(0072077)
git (administrator)
2017-11-08 18:24

Branch CR29250 has been deleted by kgv.

SHA-1: 542f268b0e5a14c8bed2c8bda0c89b15445645e8

- Related Changesets
occt: master 4f26118e
Timestamp: 2017-10-24 08:00:54
Author: apn
Committer: bugmaster
Details ] Diff ]
0029250: Configuration, TKIVtk - build failure with VTK 6.3+ due to vtkRenderingFreeTypeOpenGL being removed

Remove vtkRenderingFreeTypeOpenGL from EXTERNLIB if used vtk version is 6.3.0 and above
mod - adm/cmake/occt_toolkit.cmake Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-10-19 15:47 apn New Issue
2017-10-19 15:47 apn Assigned To => apn
2017-10-24 11:01 git Note Added: 0071727
2017-10-24 11:31 kgv Summary VTK-7 compatibility problem because of RenderingFreeTypeOpenGL module no longer exists in latest vtk => Configuration, TKIVtk - build failure with VTK 6.3+ due to vtkRenderingFreeTypeOpenGL being removed
2017-10-24 11:34 kgv Note Added: 0071732
2017-10-24 11:34 kgv Note Edited: 0071732 View Revisions
2017-10-24 15:57 git Note Added: 0071746
2017-10-24 18:16 git Note Added: 0071756
2017-10-24 19:06 apn Test case number => Not needed
2017-10-24 19:06 apn Note Added: 0071757
2017-10-24 19:06 apn Assigned To apn => ski
2017-10-24 19:06 apn Status new => resolved
2017-10-24 19:06 apn Product Version => 6.9.1
2017-10-24 19:06 apn Steps to Reproduce Updated View Revisions
2017-10-25 12:13 ski Assigned To ski => bugmaster
2017-10-25 12:13 ski Status resolved => reviewed
2017-10-25 14:49 bugmaster Note Added: 0071779
2017-10-25 14:49 bugmaster Status reviewed => tested
2017-10-27 09:54 bugmaster Changeset attached => occt master 4f26118e
2017-10-27 09:54 bugmaster Status tested => verified
2017-10-27 09:54 bugmaster Resolution open => fixed
2017-11-08 18:24 git Note Added: 0072077
2018-02-20 12:58 user533 Target Version 7.4.0* => 7.3.0
2018-06-29 21:15 user533 Fixed in Version => 7.3.0
2018-06-29 21:19 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker