View Issue Details

IDProjectCategoryView StatusLast Update
0027553CommunityOCCT:Modeling Algorithmspublic2021-08-29 18:54
ReporterMarkus Assigned Tojgv  
PrioritynormalSeverityminor 
Status assignedResolutionopen 
PlatformWindowsOSVC++ 2010 
Product Version7.0.0 
Target Version7.7.0 
Summary0027553: Modeling Algorithms - BRepFeat_SplitShape returns self-intersecting result since OCC 7.0.0
DescriptionFor the appended case BRepFeat_SplitShape returns an invalid result for one subshape since OCCT 7.0.0. In OCCT 6.9.1 there was no problem.
The problem cannot be fixed by fixshape command.

The problem occurs for the third face of the initial shell.
In the reproducing script the splitshapes commands differ for OCC 7.0.0 and 6.9.1 in the last argument because the order of shapes in the result of bopsection changed.
Steps To Reproducerestore simple.brep s

whatis s

explode s

whatis s_1

whatis s_2

tolerance s_1

tolerance s_2

checkshape s_1

checkshape s_2

explode s_2

brunparallel 1

bop s_1 s_2

bopsection r

explode r

explode s_2


# OCC 7.0.0
splitshape r1 s_2_1 s_2_1 r_4

splitshape r2 s_2_2 s_2_2 r_2

splitshape r3 s_2_3 s_2_3 r_1

splitshape r4 s_2_4 s_2_4 r_3


checkshape r1

checkshape r2

checkshape r3
#=> invalid !!!
checkshape r4



# OCC 6.9.1
splitshape r1 s_2_1 s_2_1 r_3

splitshape r2 s_2_2 s_2_2 r_4

splitshape r3 s_2_3 s_2_3 r_2

splitshape r4 s_2_4 s_2_4 r_1


checkshape r1

checkshape r2

checkshape r3

checkshape r4
TagsNo tags attached.
Test case numberbugs modalg_7 bug27553

Attached Files

  • simple.brep (1,351,108 bytes)

Relationships

related to 0027648 closedbugmaster Open CASCADE [Regression to 6.9.1] Section produces self-intersecting curve 

Activities

Timo

2016-05-31 12:35

developer  

simple.brep (1,351,108 bytes)

msv

2016-06-27 17:16

developer   ~0055508

The problem is not in SplitShape algorithm. The section produces the curve with self-intersection. See the bug 0027648.

msv

2017-07-21 11:13

developer   ~0068534

Dear bugmaster, please test if it is reproduced.

git

2017-07-21 18:56

administrator   ~0068604

Branch CR27553 has been created by mkv.

SHA-1: fd1d4871697858e54e7ee5ad47d35bffda708194


Detailed log of new commits:

Author: mkv
Date: Fri Jul 21 18:55:57 2017 +0300

    Test for 0027553: BRepFeat_SplitShape returns self-intersecting result since OCC 7.0.0

mkv

2017-07-21 18:58

tester   ~0068605

Dear msv,
problem described in issue is reproduced on current state of OCCT.

jgv

2018-06-28 14:08

developer   ~0077092

Probably fixed by #29511.

msv

2018-06-28 15:29

developer   ~0077098

Please create a test case.

msv

2018-06-28 15:30

developer   ~0077099

Sorry, test is present already.

msv

2018-06-28 15:37

developer   ~0077101

Just need to review and integrate.

jgv

2018-06-28 15:54

developer   ~0077103

Please review the branch CR27553.

msv

2018-06-28 16:12

developer   ~0077105

1. Rebase on current master.
2. Remove from the script unneeded commands that check input shapes. Leave only necessary for test commands.
3. Add commands to check sprops of the result.
4. Remove TODO if the bug is really fixed.
5. Create job on jenkins to check the command on both platforms.

Issue History

Date Modified Username Field Change
2016-05-31 12:35 Timo New Issue
2016-05-31 12:35 Timo Assigned To => msv
2016-05-31 12:35 Timo File Added: simple.brep
2016-05-31 12:35 Timo Issue generated from: 0025798
2016-05-31 12:35 Timo Steps to Reproduce Updated
2016-06-27 17:02 msv Relationship added related to 0027648
2016-06-27 17:16 msv Note Added: 0055508
2016-10-28 17:03 msv Target Version 7.1.0 => 7.2.0
2016-11-02 17:32 msv Status new => assigned
2016-11-02 17:32 msv Target Version 7.2.0 => 7.1.0
2016-11-18 15:59 msv Target Version 7.1.0 => 7.2.0
2017-05-31 15:38 Timo Reporter Timo => Markus
2017-07-21 11:13 msv Note Added: 0068534
2017-07-21 11:13 msv Assigned To msv => bugmaster
2017-07-21 11:13 msv Status assigned => feedback
2017-07-21 14:19 bugmaster Assigned To bugmaster => mkv
2017-07-21 18:56 git Note Added: 0068604
2017-07-21 18:58 mkv Assigned To mkv => msv
2017-07-21 18:58 mkv Note Added: 0068605
2017-07-21 18:59 mkv Test case number => bugs modalg_7 bug27553
2017-07-21 19:34 msv Target Version 7.2.0 => 7.4.0
2018-06-28 14:07 jgv Assigned To msv => bugmaster
2018-06-28 14:08 jgv Note Added: 0077092
2018-06-28 15:29 msv Note Added: 0077098
2018-06-28 15:29 msv Assigned To bugmaster => jgv
2018-06-28 15:30 msv Note Added: 0077099
2018-06-28 15:30 msv Assigned To jgv => bugmaster
2018-06-28 15:37 msv Assigned To bugmaster => jgv
2018-06-28 15:37 msv Status feedback => acknowledged
2018-06-28 15:37 msv Status acknowledged => assigned
2018-06-28 15:37 msv Note Added: 0077101
2018-06-28 15:54 jgv Note Added: 0077103
2018-06-28 15:54 jgv Assigned To jgv => msv
2018-06-28 15:54 jgv Status assigned => resolved
2018-06-28 16:12 msv Note Added: 0077105
2018-06-28 16:13 msv Assigned To msv => jgv
2018-06-28 16:13 msv Status resolved => assigned
2019-08-12 17:59 msv Target Version 7.4.0 => 7.5.0
2019-09-04 12:21 kgv Summary BRepFeat_SplitShape returns self-intersecting result since OCC 7.0.0 => Modeling Algorithms - BRepFeat_SplitShape returns self-intersecting result since OCC 7.0.0
2020-09-15 16:22 msv Target Version 7.5.0 => 7.6.0
2021-08-29 18:54 msv Target Version 7.6.0 => 7.7.0