MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026873Open CASCADE[OCCT] OCCT:Configurationpublic2015-11-15 14:132016-04-20 15:49
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSOS Version
Product Version[OCCT] 6.9.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026873: Tcl 8.6.2 crashes on test caf bugs B3
DescriptionI observe problem with test caf bugs B3: DRAW crashes at the test end, with system message on abnormal program exit.

Debugger reports access violation at some non-null address at the last line of Draw_Interpretor::RecordAndEval(). The situation looks like stack corruption: local variable pLine points to correct string "test caf bugs B3", while function argument "line" points to some wrong address (while it should be the same).

It is not clear where exactly the problem resides: neither valgrind (on Linux) not Dr.Memory (on 32-bit Windows; log is attached) report anything really suspicious, at least for OCCT code. Both produce a number of errors on Tcl code (such as wrong use of GDI resources, access of uninitialized memory, and leaks). The script execution log ends exactly after output of the command "bounding aBox5". If any "puts" command is added before or after that command, the problem disappears. VS debugger shows stack as if it was already corrupted when command "bounding" is entered.

The problem is reproduced on the following configurations:

Workstation 1: Intel i7-4790 CPU 3.6 GHz 16 GiB RAM, Windows 10 Pro 64-bit:
- several states of master since September 2015, built with VC10 x64 and win32 (Release and Debug)
- official distributes of OCCT 6.9.0 and 6.9.1

Workstation 2: Asus K53s notebook (Intel i7-2670OM, 2.2 GHz, 8 GiB RAM):
- official distributes of OCCT 6.9.0 and 6.9.1

Note that all combinations exhibiting this failure use the same build of Tcl 8.6.2 (one available at http://www.opencascade.com/content/3rd-party-components [^]). Fresh rebuild of Tcl 8.6.2 from sources does not help; the effect is still reproduced.

The problem does not occur if Tcl 8.6.4 is used. Therefore, the problem seems to be due to some bug in Tcl 8.6.2, and proposed solution is to update Tcl in OCCT 3rd-parties to 8.6.4.
Steps To Reproduceinfo patchlevel ;# shows version of Tcl - 8.6.2 causes problem
test caf bugs B3 1
TagsNo tags attached.
Test case number
Attached Filestxt file icon results.txt (219,838 bytes) 2015-11-15 14:13

- Relationships

-  Notes
(0048196)
abv (manager)
2015-11-15 14:19

Please check if this problem is reproducible on other machines, and consider upgrading Tcl used for OCCT and distributed as third-party lib to version 8.6.4
(0048200)
abv (manager)
2015-11-16 09:37

Notably, OCCT 6.9.1 Windows distributive comes with Tcl/Tk 8.6.4, thus does not exhibit the problem. The archives on http://www.opencascade.com/content/3rd-party-components [^] still contain Tcl 8.6.2, thus must be updated. Also documentation need to be corrected to reflect this requirement.
(0048326)
bugmaster (administrator)
2015-11-18 10:07

Tcltk archives have been replaced on :
- www.opencascade.com
- \\master\projects\occt-3rdparty\
- in location tcltk for Jenkins building procedure

- Issue History
Date Modified Username Field Change
2015-11-15 14:13 abv New Issue
2015-11-15 14:13 abv Assigned To => bugmaster
2015-11-15 14:13 abv File Added: results.txt
2015-11-15 14:19 abv Note Added: 0048196
2015-11-15 14:19 abv Status new => resolved
2015-11-16 09:37 abv Note Added: 0048200
2015-11-16 09:37 abv Product Version => 6.9.0
2015-11-18 10:06 bugmaster Status resolved => reviewed
2015-11-18 10:07 bugmaster Note Added: 0048326
2015-11-18 10:07 bugmaster Status reviewed => verified
2015-11-18 10:07 bugmaster Resolution open => fixed
2015-12-30 11:54 abv Relationship added related to 0027052
2016-04-20 15:43 aiv Fixed in Version => 7.0.0
2016-04-20 15:49 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker