View Issue Details

IDProjectCategoryView StatusLast Update
0026859Open CASCADEOCCT:Data Exchangepublic2016-04-20 15:50
ReporterikaAssigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Target Version7.0.0Fixed in Version7.0.0 
Summary0026859: Export of GDT from XCAF to STEP
DescriptionExport of GDT from XCAF to STEP, according to AP242.
Steps To Reproducegdt export A1
gdt export A2
gdt export A3
gdt export A4
gdt export A5
TagsNo tags attached.
Test case numbergdt export

Activities

git

2015-11-10 11:58

administrator   ~0047986

Branch CR26859 has been created by ika.

SHA-1: a756ebb089d0f992a777624e5a77ae8847778703


Detailed log of new commits:

Author: ika
Date: Tue Nov 10 11:58:29 2015 +0300

    0026859: Export of GDT from XCAF to STEP
    
    export dimensions,
    draft of datum export.

git

2015-11-23 14:35

administrator   ~0048481

Branch CR26859 has been updated forcibly by ika.

SHA-1: 8e3af6bb1365093ee05ebc88b7232e3482920a21

git

2015-11-23 17:07

administrator   ~0048494

Branch CR26859 has been updated by ika.

SHA-1: f9dc3cbe20c9e402aae8463100866c73e123daaa


Detailed log of new commits:

Author: ika
Date: Mon Nov 23 17:07:11 2015 +0300

    corrections

ika

2015-11-23 17:23

developer   ~0048495

Export/Import:
Add export of dimensions, geometric tolerances and datums, according to AP242.
Add missing STEP entities.
Corrections.

XCAF:
Add new attributes to Datum object: DatumTargetNumber.
Supplement enum XCAFDimTolObjects_GeomToleranceZoneModif.
Corrections.

Dear GKA,
could you please review branch CR26859?

gka

2015-11-23 17:26

developer   ~0048496

Branch CR26859 is ready to be tested.

git

2015-11-24 16:34

administrator   ~0048530

Branch CR26859 has been updated forcibly by apv.

SHA-1: 413a9caddd58266503bdc68dc215f8415cbbee1f

apv

2015-11-24 16:35

tester   ~0048531

Branch CR26859 has been rebased on the current master

apv

2015-11-25 14:11

tester   ~0048560

Last edited: 2015-11-25 14:11

Dear BugMaster,

Branch CR26859 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 413a9caddd58266503bdc68dc215f8415cbbee1f

Number of compiler warnings:
occt component:
   Linux: 5 (0 on master)
   Windows: 0 (0 on master)
   MasOS: 140 (134 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)
There are new additional warnings
on Linux:
http://jenkins-test-01.nnov.opencascade.com/view/CR26859-master/job/CR26859-master_build_occt_linux/1/warnings17Result/
on MacOS:
http://jenkins-test-01.nnov.opencascade.com/view/CR26859-master/job/CR26859-master_prepare_build_occt_MacOS/1/warnings7Result/

Regressions/Differences:
http://occt-tests/CR26859-master-occt-64/Debian70-64/summary.html
http://occt-tests/CR26859-master-occt-64/Windows-64-VC10/summary.html
de step_1 ZQ2
gdt import A1, A2, A3, A4, A5

There is problematic CPU test-case:
bugs step bug25166: 3.4788223 / 2.2776146 [+52.74%]

Testing on Linux:
Total MEMORY difference: 93200391 / 93449169 [-0.27%]
Total CPU difference: 19861.169999999714 / 19723.30999999994 [+0.70%]

Testing on Windows:
Total MEMORY difference: 58323170 / 58330608 [-0.01%]
Total CPU difference: 18197.906652498852 / 18190.995808198873 [+0.04%]

apv

2015-11-25 14:12

tester   ~0048561

Dear ika,

Branch CR26859 has been rejected due to:
- additional warnings
- regressions/differences/improvements
- CPU problem

git

2015-11-30 12:49

administrator   ~0048651

Branch CR26859 has been updated forcibly by ika.

SHA-1: 559af454c1f4ca10a508f7c04cc500aa413e02a4

ika

2015-11-30 13:01

developer   ~0048653

Dear APV,

the problems were fixed, also test cases was added.
Branch CR26859 is ready to be tested.

apv

2015-12-01 13:57

tester   ~0048671

Dear BugMaster,

Branch CR26859 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: 559af454c1f4ca10a508f7c04cc500aa413e02a4

Number of compiler warnings:
occt component:
   Linux: 0 (0 on master)
   Windows: 0 (0 on master)
   MacOS: 134 (134 on master)
products component:
   Linux: 39 (39 on master)
   Windows: 0 (0 on master)

Regressions/Differences:
Not detected

Testing cases:
gdt export
http://occt-tests/CR26859-master-occt-64/Debian70-64/summary.html#gdt-export
http://occt-tests/CR26859-master-occt-64/Windows-64-VC10/summary.html#gdt-export

Testing on Linux:
Total MEMORY difference: 92379443 / 91616080 [+0.83%]
Total CPU difference: 20115.11999999985 / 20030.809999999703 [+0.42%]

Testing on Windows:
Total MEMORY difference: 57787376 / 57833189 [-0.08%]
Total CPU difference: 18680.667347099065 / 20089.76197969905 [-7.01%]

git

2016-04-17 14:07

administrator   ~0053061

Branch CR26859 has been deleted by kgv.

SHA-1: 559af454c1f4ca10a508f7c04cc500aa413e02a4

Related Changesets

occt: master 6595eee7

2015-11-10 08:58:29

ika


Committer: bugmaster Details Diff
0026859: Export of GDT from XCAF to STEP

Export/Import:
Add export of dimensions, geometric tolerances and datums, according to AP242.
Add missing STEP entities.
Corrections.

XCAF:
Add new attributes to Datum object: DatumTargetNumber.
Supplement enum XCAFDimTolObjects_GeomToleranceZoneModif.
Corrections.

Test cases:
gdt export A1
gdt export A2
gdt export A3
gdt export A4
gdt export A5
Affected Issues
0026859
mod - src/RWStepAP214/RWStepAP214_GeneralModule.cxx Diff File
mod - src/RWStepAP214/RWStepAP214_ReadWriteModule.cxx Diff File
mod - src/RWStepDimTol/FILES Diff File
mod - src/RWStepDimTol/RWStepDimTol_RWDatumReferenceCompartment.cxx Diff File
mod - src/RWStepDimTol/RWStepDimTol_RWDatumReferenceElement.cxx Diff File
mod - src/RWStepDimTol/RWStepDimTol_RWGeneralDatumReference.cxx Diff File
add - src/RWStepDimTol/RWStepDimTol_RWGeoTolAndGeoTolWthDatRefAndGeoTolWthMaxTol.cxx Diff File
add - src/RWStepDimTol/RWStepDimTol_RWGeoTolAndGeoTolWthDatRefAndGeoTolWthMaxTol.hxx Diff File
mod - src/RWStepDimTol/RWStepDimTol_RWGeoTolAndGeoTolWthDatRefAndGeoTolWthMod.cxx Diff File
add - src/RWStepDimTol/RWStepDimTol_RWGeoTolAndGeoTolWthMaxTol.cxx Diff File
add - src/RWStepDimTol/RWStepDimTol_RWGeoTolAndGeoTolWthMaxTol.hxx Diff File
mod - src/StepAP214/StepAP214_Protocol.cxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Reader.cxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Writer.cxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Writer.hxx Diff File
mod - src/STEPConstruct/STEPConstruct_GDTProperty.cxx Diff File
mod - src/STEPConstruct/STEPConstruct_GDTProperty.hxx Diff File
mod - src/StepDimTol/FILES Diff File
mod - src/StepDimTol/StepDimTol_GeneralDatumReference.hxx Diff File
add - src/StepDimTol/StepDimTol_GeoTolAndGeoTolWthDatRefAndGeoTolWthMaxTol.cxx Diff File
add - src/StepDimTol/StepDimTol_GeoTolAndGeoTolWthDatRefAndGeoTolWthMaxTol.hxx Diff File
add - src/StepDimTol/StepDimTol_GeoTolAndGeoTolWthMaxTol.cxx Diff File
add - src/StepDimTol/StepDimTol_GeoTolAndGeoTolWthMaxTol.hxx Diff File
mod - src/StepDimTol/StepDimTol_SimpleDatumReferenceModifierMember.hxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DatumObject.cxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DatumObject.hxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_DimensionObject.cxx Diff File
mod - src/XCAFDimTolObjects/XCAFDimTolObjects_GeomToleranceZoneModif.hxx Diff File
mod - src/XCAFDoc/XCAFDoc_Datum.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_DimTolTool.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_DimTolTool.hxx Diff File
mod - src/XCAFDoc/XCAFDoc_GeomTolerance.cxx Diff File
mod - src/XDEDRAW/XDEDRAW_GDTs.cxx Diff File
add - tests/gdt/export/A1 Diff File
add - tests/gdt/export/A2 Diff File
add - tests/gdt/export/A3 Diff File
add - tests/gdt/export/A4 Diff File
add - tests/gdt/export/A5 Diff File
add - tests/gdt/export/begin Diff File
add - tests/gdt/export/end Diff File
mod - tests/gdt/grids.list Diff File
mod - tests/gdt/import/A1 Diff File
mod - tests/gdt/import/A2 Diff File
mod - tests/gdt/import/A3 Diff File
mod - tests/gdt/import/A4 Diff File
mod - tests/gdt/import/A5 Diff File

Issue History

Date Modified Username Field Change
2015-11-10 11:52 ika New Issue
2015-11-10 11:52 ika Assigned To => ika
2015-11-10 11:58 git Note Added: 0047986
2015-11-23 14:35 git Note Added: 0048481
2015-11-23 17:07 git Note Added: 0048494
2015-11-23 17:23 ika Note Added: 0048495
2015-11-23 17:23 ika Assigned To ika => gka
2015-11-23 17:23 ika Status new => resolved
2015-11-23 17:23 ika Steps to Reproduce Updated
2015-11-23 17:26 gka Note Added: 0048496
2015-11-23 17:26 gka Assigned To gka => bugmaster
2015-11-23 17:26 gka Status resolved => reviewed
2015-11-24 16:22 apv Assigned To bugmaster => apv
2015-11-24 16:34 git Note Added: 0048530
2015-11-24 16:35 apv Note Added: 0048531
2015-11-25 14:11 apv Note Added: 0048560
2015-11-25 14:11 apv Assigned To apv => ika
2015-11-25 14:11 apv Status reviewed => assigned
2015-11-25 14:11 apv Note Edited: 0048560
2015-11-25 14:12 apv Note Added: 0048561
2015-11-30 12:49 git Note Added: 0048651
2015-11-30 12:52 ika Steps to Reproduce Updated
2015-11-30 13:01 ika Note Added: 0048653
2015-11-30 13:01 ika Assigned To ika => apv
2015-11-30 13:01 ika Status assigned => feedback
2015-12-01 12:38 apv Test case number => gdt export
2015-12-01 13:57 apv Note Added: 0048671
2015-12-01 13:57 apv Assigned To apv => bugmaster
2015-12-01 13:57 apv Status feedback => tested
2015-12-04 20:05 bugmaster Changeset attached => occt master 6595eee7
2015-12-04 20:05 bugmaster Status tested => verified
2015-12-04 20:05 bugmaster Resolution open => fixed
2016-04-17 14:07 git Note Added: 0053061
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:50 aiv Status verified => closed