MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026809Open CASCADE[OCCT] OCCT:Visualizationpublic2015-10-24 15:292016-12-09 16:39
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformLinuxOSDebian 6.0OS Version64 bit
Product Version[OCCT] 6.9.1 
Target Version[OCCT] 7.1.0Fixed in Version[OCCT] 7.1.0 
Summary0026809: Visualization, TKOpenGl - handle point arrays with per-vertex color within built-in GLSL programs
DescriptionWithin the following tests points are displayed incorrectly within FFP turned off (vcaps -ffp 0):
* v3d raytrace bug24819
* v3d point_cloud sphere
Steps To Reproducetest v3d raytrace bug24819
test v3d point_cloud sphere
TagsNo tags attached.
Test case numberv3d point_cloud sphere, v3d raytrace bug24819
Attached Filespng file icon bug24819_OK_FFP.png (14,508 bytes) 2015-10-24 15:31
png file icon bug24819_KO_GLSL.png (7,755 bytes) 2015-10-24 15:32
png file icon sphere_copper_OK_FFP.png (16,640 bytes) 2015-10-24 15:33
png file icon sphere_copper_KO_GLSL.png (5,688 bytes) 2015-10-24 15:33

- Relationships
related to 0027320closedbugmaster Open CASCADE Visualization - introduce the option to display face boundaries with lighting 
related to 0027633closedbugmaster Open CASCADE Visualization, TKOpenGl - point sprites are inconsistent within Core and Compatible Profiles 
child of 0024838newkgv Open CASCADE Visualization, TKOpenGl - make general rendering path compatible with OpenGL 3.1+ core profiles 

-  Notes
(0051393)
git (administrator)
2016-03-04 12:31

Branch CR26809 has been created by duv.

SHA-1: 2c6b8dfc54e5ddb5a21750fb8cd83846691fad4b


Detailed log of new commits:

Author: duv
Date: Fri Mar 4 12:31:17 2016 +0300

    Point sprites rendering with per-vertex colors fixed.
    Point sprites rendering with shading fixed.
(0051500)
git (administrator)
2016-03-10 11:34

Branch CR26809_1 has been created by duv.

SHA-1: 9019159f37502e47b9aafcde87b116cdffbd5b74


Detailed log of new commits:

Author: duv
Date: Fri Mar 4 12:31:17 2016 +0300

    0026809: Visualization, TKOpenGl - handle point arrays with per-vertex color within built-in GLSL programs
    
    Shader rendering of point sprites with per-vertex colors and shading have been fixed.
(0051501)
duv (developer)
2016-03-10 11:36

Dear kgv,

Please review the patch in CR26809_1.
(0051516)
git (administrator)
2016-03-10 15:35

Branch CR26809_2 has been created by duv.

SHA-1: 0a6ee5e2bc502fc6ae4eb75726636e26a03c80e8


Detailed log of new commits:

Author: duv
Date: Fri Mar 4 12:31:17 2016 +0300

    0026809: Visualization, TKOpenGl - handle point arrays with per-vertex color within built-in GLSL programs
    
    Shader rendering of point sprites with per-vertex colors and shading have been fixed.
    Material state was removed from OpenGl_ShaderManager.
    Material properties now should be modified trough OpenGl_Context.
(0051517)
duv (developer)
2016-03-10 15:36

Dear kgv,

Please review the patch in CR26809_2.
(0051526)
git (administrator)
2016-03-10 16:34

Branch CR26809_2 has been updated by duv.

SHA-1: 2c3268d0e0319e5a00c832f0035f56cf1bfa5cac


Detailed log of new commits:

Author: duv
Date: Thu Mar 10 16:33:49 2016 +0300

    Subtitle text rendering with shaders fixed.

(0052429)
kgv (developer)
2016-04-06 12:38

Please test the patch.
(0052431)
git (administrator)
2016-04-06 13:03

Branch CR26809_2 has been updated forcibly by mkv.

SHA-1: f0105dc9889c8a4bb8d926924a455d2fbcf154f0
(0052462)
mkv (tester)
2016-04-07 12:13

Dear BugMaster,
Branch CR26809_2 was rebased on current master of occt git-repository.
SHA-1: f0105dc9889c8a4bb8d926924a455d2fbcf154f0
(0052463)
mkv (tester)
2016-04-07 12:14

Dear BugMaster,
Branch CR26809_2 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: f0105dc9889c8a4bb8d926924a455d2fbcf154f0

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 68 (68 on master)
Windows: 0 (0 on master)
MacOS : 1142

Regressions/Differences/Improvements:
http://occt-tests/CR26809-2-master-OCCT/Debian70-64/bugs/vis/bug26312.html [^]
http://occt-tests/CR26809-2-master-OCCT/Windows-64-VC10/bugs/vis/bug26312.html [^]
bugs vis bug26312: FAILED
http://occt-tests/CR26809-2-master-OCCT/Debian70-64/bugs/vis/bug26424.html [^]
http://occt-tests/CR26809-2-master-OCCT/Windows-64-VC10/bugs/vis/bug26424.html [^]
bugs vis bug26424: FAILED

Testing cases:
http://occt-tests/CR26809-2-master-OCCT/Debian70-64/v3d/point_cloud/sphere.html [^]
http://occt-tests/CR26809-2-master-OCCT/Windows-64-VC10/v3d/point_cloud/sphere.html [^]
v3d point_cloud sphere: OK
http://occt-tests/CR26809-2-master-OCCT/Debian70-64/v3d/raytrace/bug24819.html [^]
http://occt-tests/CR26809-2-master-OCCT/Windows-64-VC10/v3d/raytrace/bug24819.html [^]
v3d raytrace bug24819: OK

Testing on Linux:
occt component :
Total MEMORY difference: 89176435 / 89114001 [+0.07%]
Total CPU difference: 19257.590000000047 / 19563.27000000005 [-1.56%]
products component :
Total MEMORY difference: 25501289 / 25460320 [+0.16%]
Total CPU difference: 5295.969999999983 / 5253.0299999999925 [+0.82%]

Testing on Windows:
occt component :
Total MEMORY difference: 57524284 / 57541560 [-0.03%]
Total CPU difference: 18153.508767898922 / 17768.139497598855 [+2.17%]
products component :
Total MEMORY difference: 17400005 / 17363771 [+0.21%]
Total CPU difference: 5186.3312454999505 / 5013.029734599948 [+3.46%]

There are following differences in images found by testdiff.
http://occt-tests/CR26809-2-master-OCCT/Debian70-64/diff-Debian70-64.html [^]
demo samples dimensionsglsl
(0052464)
mkv (tester)
2016-04-07 12:14

Dear duv,
Branch CR26809_2 has been rejected due to:
- regressions/differences/improvements
- differences in images
(0052765)
git (administrator)
2016-04-17 12:20

Branch CR26809_2 has been updated forcibly by kgv.

SHA-1: 2ea485217456a55d2d1c1e4b4ca4d2cd476f8c82
(0052766)
git (administrator)
2016-04-17 12:34

Branch CR26809_2 has been updated by kgv.

SHA-1: ccde1d39977e56ec1b855a3702ab092f9df79f10


Detailed log of new commits:

Author: kgv
Date: Sun Apr 17 12:34:22 2016 +0300

    OpenGl_ShaderProgram::Initialize() - fix setting Uniforms without active program

(0052767)
git (administrator)
2016-04-17 12:43

Branch CR26809_3 has been created by kgv.

SHA-1: 3964d537760492ee4f6e5d3ffef6feb3dcee54da


Detailed log of new commits:

Author: duv
Date: Sun Apr 17 12:43:08 2016 +0300

    0026809: Visualization, TKOpenGl - handle point arrays with per-vertex color within built-in GLSL programs
    
    Shader rendering of point sprites with per-vertex colors and shading have been fixed.
    
    Material state was removed from OpenGl_ShaderManager.
    Material properties now should be modified trough OpenGl_Context::SetShadingMaterial().
(0052768)
kgv (developer)
2016-04-17 12:44

Please test the patch CR26809_3.
(0053307)
mkv (tester)
2016-04-19 17:59

Dear BugMaster,
Branch CR26809_3 from occt git-repository (and master from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 3964d537760492ee4f6e5d3ffef6feb3dcee54da

Number of compiler warnings:

occt component :
Linux: 0 (0 on master)
Windows: 0 (0 on master)
MacOS : 0 (0 on master)

products component :
Linux: 68 (68 on master)
Windows: 0 (0 on master)
MacOS : 1132

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
http://occt-tests/CR26809-3-master-OCCT/Debian70-64/v3d/point_cloud/sphere.html [^]
http://occt-tests/CR26809-3-master-OCCT/Windows-64-VC10/v3d/point_cloud/sphere.html [^]
v3d point_cloud sphere: OK
http://occt-tests/CR26809-3-master-OCCT/Debian70-64/v3d/raytrace/bug24819.html [^]
http://occt-tests/CR26809-3-master-OCCT/Windows-64-VC10/v3d/raytrace/bug24819.html [^]
v3d raytrace bug24819: OK

Testing on Linux:
occt component :
Total MEMORY difference: 90277611 / 89577785 [+0.78%]
Total CPU difference: 19453.480000000094 / 19474.700000000117 [-0.11%]
products component :
Total MEMORY difference: 27972975 / 28023929 [-0.18%]
Total CPU difference: 5338.659999999983 / 5337.029999999988 [+0.03%]

Testing on Windows:
occt component :
Total MEMORY difference: 57669496 / 57734720 [-0.11%]
Total CPU difference: 18163.758033598715 / 18085.258330398872 [+0.43%]
products component :
Total MEMORY difference: 19281413 / 19256581 [+0.13%]
Total CPU difference: 5281.772657299958 / 5167.657925799961 [+2.21%]

There are no differences in images found by testdiff.
(0053308)
mkv (tester)
2016-04-19 18:00

Dear BugMaster,
Branch CR26809_3 is TESTED.
(0053471)
git (administrator)
2016-04-21 13:47

Branch CR26809_4 has been created by duv.

SHA-1: 21bb478fa1fa4bdfa1ec8ca472b418bd10b8e2f8


Detailed log of new commits:

Author: duv
Date: Sun Apr 17 12:43:08 2016 +0300

    0026809: Visualization, TKOpenGl - handle point arrays with per-vertex color within built-in GLSL programs
    
    Shader rendering of point sprites with per-vertex colors and shading have been fixed.
    
    Material state was removed from OpenGl_ShaderManager.
    Material properties now should be modified trough OpenGl_Context::SetShadingMaterial().
(0054208)
git (administrator)
2016-05-20 12:22

Branch CR26809_4 has been deleted by inv.

SHA-1: 21bb478fa1fa4bdfa1ec8ca472b418bd10b8e2f8
(0054215)
git (administrator)
2016-05-20 12:23

Branch CR26809_3 has been deleted by inv.

SHA-1: 3964d537760492ee4f6e5d3ffef6feb3dcee54da
(0054216)
git (administrator)
2016-05-20 12:23

Branch CR26809_2 has been deleted by inv.

SHA-1: ccde1d39977e56ec1b855a3702ab092f9df79f10
(0054230)
git (administrator)
2016-05-20 12:23

Branch CR26809_1 has been deleted by inv.

SHA-1: 9019159f37502e47b9aafcde87b116cdffbd5b74
(0054231)
git (administrator)
2016-05-20 12:24

Branch CR26809 has been deleted by inv.

SHA-1: 2c6b8dfc54e5ddb5a21750fb8cd83846691fad4b

- Related Changesets
occt: master 299e0ab9
Timestamp: 2016-04-17 09:43:08
Author: duv
Committer: bugmaster
Details ] Diff ]
0026809: Visualization, TKOpenGl - handle point arrays with per-vertex color within built-in GLSL programs

Shader rendering of point sprites with per-vertex colors and shading have been fixed.

Material state was removed from OpenGl_ShaderManager.
Material properties now should be modified trough OpenGl_Context::SetShadingMaterial().
mod - src/OpenGl/OpenGl_Context.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_PrimitiveArray.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderManager.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderManager.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_ShaderProgram.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Text.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_View_Redraw.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-10-24 15:29 kgv New Issue
2015-10-24 15:29 kgv Assigned To => kgv
2015-10-24 15:31 kgv File Added: bug24819_OK_FFP.png
2015-10-24 15:32 kgv File Added: bug24819_KO_GLSL.png
2015-10-24 15:33 kgv File Added: sphere_copper_OK_FFP.png
2015-10-24 15:33 kgv File Added: sphere_copper_KO_GLSL.png
2015-10-24 15:33 kgv Relationship added child of 0024838
2016-01-06 21:39 kgv Target Version 7.0.0 => 7.1.0
2016-03-03 10:22 kgv Assigned To kgv => duv
2016-03-03 10:22 kgv Status new => assigned
2016-03-04 12:31 git Note Added: 0051393
2016-03-10 11:34 git Note Added: 0051500
2016-03-10 11:36 duv Note Added: 0051501
2016-03-10 11:36 duv Assigned To duv => kgv
2016-03-10 11:36 duv Status assigned => resolved
2016-03-10 11:36 duv Steps to Reproduce Updated View Revisions
2016-03-10 15:35 git Note Added: 0051516
2016-03-10 15:36 duv Note Added: 0051517
2016-03-10 16:34 git Note Added: 0051526
2016-03-30 15:27 kgv Relationship added related to 0027320
2016-04-06 12:38 kgv Note Added: 0052429
2016-04-06 12:38 kgv Assigned To kgv => bugmaster
2016-04-06 12:38 kgv Status resolved => reviewed
2016-04-06 12:48 mkv Assigned To bugmaster => mkv
2016-04-06 13:03 git Note Added: 0052431
2016-04-07 12:13 mkv Note Added: 0052462
2016-04-07 12:14 mkv Note Added: 0052463
2016-04-07 12:14 mkv Note Added: 0052464
2016-04-07 12:14 mkv Assigned To mkv => duv
2016-04-07 12:14 mkv Status reviewed => assigned
2016-04-07 12:15 mkv Test case number => v3d point_cloud sphere, v3d raytrace bug24819
2016-04-17 12:20 git Note Added: 0052765
2016-04-17 12:34 git Note Added: 0052766
2016-04-17 12:43 git Note Added: 0052767
2016-04-17 12:44 kgv Note Added: 0052768
2016-04-17 12:44 kgv Assigned To duv => bugmaster
2016-04-17 12:44 kgv Status assigned => resolved
2016-04-17 12:44 kgv Status resolved => reviewed
2016-04-18 13:42 mkv Assigned To bugmaster => mkv
2016-04-19 17:59 mkv Note Added: 0053307
2016-04-19 18:00 mkv Note Added: 0053308
2016-04-19 18:00 mkv Assigned To mkv => bugmaster
2016-04-19 18:00 mkv Status reviewed => tested
2016-04-21 13:47 git Note Added: 0053471
2016-04-22 16:48 bugmaster Changeset attached => occt master 299e0ab9
2016-04-22 16:48 bugmaster Status tested => verified
2016-04-22 16:48 bugmaster Resolution open => fixed
2016-05-20 12:22 git Note Added: 0054208
2016-05-20 12:23 git Note Added: 0054215
2016-05-20 12:23 git Note Added: 0054216
2016-05-20 12:23 git Note Added: 0054230
2016-05-20 12:24 git Note Added: 0054231
2016-06-23 18:58 kgv Relationship added related to 0027633
2016-11-11 11:01 kgv Relationship added related to 0026072
2016-12-09 16:30 user533 Status verified => closed
2016-12-09 16:39 user533 Fixed in Version => 7.1.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker