MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026787Open CASCADE[OCCT] OCCT:Samplespublic2015-10-16 15:502016-04-20 15:51
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0026787: Do not declare redundant macros WNT, LIN, LININTEL, WIN32, WIN64 within samples project files
DescriptionThe macros WNT, WIN32, WIN64, LIN, LININTEL have been dropped within 0022972 from OCCT.
However, they still defined in some samples. E.g. samples/mfc/standard/04_Viewer3d/adm/win/vc10/Viewer3d.vcxproj:
       <PreprocessorDefinitions>NDEBUG;WIN32;_WINDOWS;WNT;WINVER=0x0500;%(PreprocessorDefinitions)</PreprocessorDefinitions>



It is better to clean up sample project from this stuff.
Steps To ReproduceN/A
TagsNo tags attached.
Test case number
Attached Filesdocx file icon QT_Product_samples_Linux.docx (17,494 bytes) 2015-10-27 15:43

- Relationships
child of 0022972closedkgv Open CASCADE Eliminate macro definitions that has compiler-provided analogs (WNT and so on) 

-  Notes
(0047391)
git (administrator)
2015-10-23 16:12

Branch CR26787 has been created by ski.

SHA-1: 1c9f4da18b4f1d208ce27c840701828dc6e3dc99


Detailed log of new commits:

Author: ski
Date: Fri Oct 23 16:12:34 2015 +0300

    0026787: Do not declare redundant macros WNT, LIN, WIN32, WIN64 within samples project files
    
    Redundant macros were removed.
(0047424)
kgv (developer)
2015-10-26 09:48
edited on: 2015-10-26 09:49

-    !macx | equals(MACOSX_USE_GLX, true): DEFINES += LIN LININTEL
+    !macx | equals(MACOSX_USE_GLX, true): DEFINES += __linux__ LININTEL


-    DEFINES +=WNT WIN32 NO_COMMONSAMPLE_EXPORTS NO_IESAMPLE_EXPORTS
+    DEFINES += _WIN32 NO_COMMONSAMPLE_EXPORTS NO_IESAMPLE_EXPORTS

note that macros _WIN32 and __linux__ are implicitly predefined by compiler within appropriate platform.
There is no much sense defining them explicitly within project settings.
LININTEL usage should be dropped as well.

(0047434)
git (administrator)
2015-10-26 12:12

Branch CR26787 has been updated forcibly by ski.

SHA-1: 30a4e2b4c588dc2aafb1be05f95a62e8114d3082
(0047437)
ski (developer)
2015-10-26 13:57

Dear kgv,

occt branch CR26787 was rebased on current state of master (with applied remarks).

Products branch CR26787 was created.

Please, review.
(0047447)
kgv (developer)
2015-10-26 14:46

Please check compilation of changed samples on all supported platforms.
(0047486)
mkv (tester)
2015-10-27 14:58

Dear BugMaster,
Branch CR26787 from occt git-repository (and CR26787 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested on Release mode.
SHA-1: 30a4e2b4c588dc2aafb1be05f95a62e8114d3082
SHA-1: 8224ca3302b6a1548ddcfb258f36ab55b92fa105

Number of compiler warnings:

occt component :
Linux: 1 (1 on master)
Windows: 0 (0 on master)

products component :
Linux: 39 (39 on master)
Windows: 0 (0 on master)

Regressions/Differences/Improvements:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
occt component :
Total MEMORY difference: 92715858 / 92334582 [+0.41%]
Total CPU difference: 19784.67999999976 / 19731.449999999688 [+0.27%]
products component :
Total MEMORY difference: 26251657 / 26272952 [-0.08%]
Total CPU difference: 7457.359999999993 / 7371.560000000013 [+1.16%]

Testing on Windows:
occt component :
Total MEMORY difference: 58037751 / 58043302 [-0.01%]
Total CPU difference: 18403.03236739902 / 18133.197437699022 [+1.49%]
products component :
Total MEMORY difference: 17162482 / 17167510 [-0.03%]
Total CPU difference: 5729.745128899976 / 5658.655473199974 [+1.26%]

There are no differences in images found by testdiff.
(0047491)
bugmaster (administrator)
2015-10-27 15:41

Compilation of samples and demo.

OCCT:
There is no problems during compilation both Windows and Linux platforms.

Products:
Windows. Problem of compilation
http://jenkins-test-01.nnov.opencascade.com:8080/view/CR26787-CR26787/job/CR26787-CR26787_build_products_java_samples_windows/ [^]

http://jenkins-test-01.nnov.opencascade.com:8080/view/CR26787-CR26787/job/CR26787-CR26787_build_products_mfc_samples_windows/ [^]

http://jenkins-test-01.nnov.opencascade.com:8080/view/CR26787-CR26787/job/CR26787-CR26787_build_products_qt_samples_windows/ [^]

Linux. Problem of compilation
See attached doc file
(0047529)
git (administrator)
2015-10-28 14:35

Branch CR26787 has been updated forcibly by ski.

SHA-1: 4bdc8f738581286601623122eac72961a5ec3af9
(0047576)
ski (developer)
2015-10-29 10:44

occt branch CR26787 and product branch CR26787 were updated and rebased on current state of master.

Compilation of products qt samples ACIS, DXP and Parasolid was fixed.
For other qt samples on Linux platform (in products) separate issue #26824 was created.

Problems of products java samples compilation were not related to the fix.

Problems of products qt samples and mfc samples (on Windows) compilation were caused by redundant macros in products source code.

Dear kgv, please review.
(0047579)
kgv (developer)
2015-10-29 10:50

Please check samples compilation on updated branches.
(0047582)
bugmaster (administrator)
2015-10-29 11:19

All the samples are compiled without errors except registered in 0026824.
Compilation of OCCT and Products qt samples on Linux platform was included to Jenkins certification system for each branch
(0053183)
git (administrator)
2016-04-17 14:30

Branch CR26787 has been deleted by kgv.

SHA-1: 4bdc8f738581286601623122eac72961a5ec3af9

- Related Changesets
occt: master 50fe2dab
Timestamp: 2015-10-23 13:12:34
Author: ski
Committer: bugmaster
Details ] Diff ]
0026787: Do not declare redundant macros WNT, LIN, WIN32, WIN64 within samples project files

Redundant macros were removed.

Defines _WIN32, __linux__ and LININTEL were removed from qt samples *.pro files
mod - samples/CSharp/OCCTProxy/OCCTProxy.vcproj Diff ] File ]
mod - samples/CSharp/OCCTProxy/OCCTProxy.vcxproj Diff ] File ]
mod - samples/CSharp/OCCTProxy_D3D/OCCTProxy_D3D.vcproj Diff ] File ]
mod - samples/CSharp/OCCTProxy_D3D/OCCTProxy_D3D.vcxproj Diff ] File ]
mod - samples/mfc/standard/01_Geometry/adm/win/vc10/Geometry.vcxproj Diff ] File ]
mod - samples/mfc/standard/01_Geometry/adm/win/vc11/Geometry.vcxproj Diff ] File ]
mod - samples/mfc/standard/01_Geometry/adm/win/vc12/Geometry.vcxproj Diff ] File ]
mod - samples/mfc/standard/01_Geometry/adm/win/vc8/Geometry.vcproj Diff ] File ]
mod - samples/mfc/standard/01_Geometry/adm/win/vc9/Geometry.vcproj Diff ] File ]
mod - samples/mfc/standard/01_Geometry/src/GeometryDoc.cpp Diff ] File ]
mod - samples/mfc/standard/01_Geometry/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/02_Modeling/adm/win/vc10/Modeling.vcxproj Diff ] File ]
mod - samples/mfc/standard/02_Modeling/adm/win/vc11/Modeling.vcxproj Diff ] File ]
mod - samples/mfc/standard/02_Modeling/adm/win/vc12/Modeling.vcxproj Diff ] File ]
mod - samples/mfc/standard/02_Modeling/adm/win/vc8/Modeling.vcproj Diff ] File ]
mod - samples/mfc/standard/02_Modeling/adm/win/vc9/Modeling.vcproj Diff ] File ]
mod - samples/mfc/standard/02_Modeling/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/adm/win/vc10/Viewer2d.vcxproj Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/adm/win/vc11/Viewer2d.vcxproj Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/adm/win/vc12/Viewer2d.vcxproj Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/adm/win/vc8/Viewer2d.vcproj Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/adm/win/vc9/Viewer2d.vcproj Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc10/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc11/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc12/Viewer3d.vcxproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc8/Viewer3d.vcproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/adm/win/vc9/Viewer3d.vcproj Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/04_Viewer3d/src/TexturesExt_Presentation.cpp Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/adm/win/vc10/ImportExport.vcxproj Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/adm/win/vc11/ImportExport.vcxproj Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/adm/win/vc12/ImportExport.vcxproj Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/adm/win/vc8/ImportExport.vcproj Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/adm/win/vc9/ImportExport.vcproj Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/src/FSD_Archive.cxx Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/src/FSD_CArchive.hxx Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/src/FSD_CFile.hxx Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/adm/win/vc10/Ocaf.vcxproj Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/adm/win/vc11/Ocaf.vcxproj Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/adm/win/vc12/Ocaf.vcxproj Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/adm/win/vc8/Ocaf.vcproj Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/adm/win/vc9/Ocaf.vcproj Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/adm/win/vc10/Triangulation.vcxproj Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/adm/win/vc11/Triangulation.vcxproj Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/adm/win/vc12/Triangulation.vcxproj Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/adm/win/vc8/Triangulation.vcproj Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/adm/win/vc9/Triangulation.vcproj Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/07_Triangulation/src/Tesselate_Presentation.cpp Diff ] File ]
mod - samples/mfc/standard/08_HLR/adm/win/vc10/HLR.vcxproj Diff ] File ]
mod - samples/mfc/standard/08_HLR/adm/win/vc11/HLR.vcxproj Diff ] File ]
mod - samples/mfc/standard/08_HLR/adm/win/vc12/HLR.vcxproj Diff ] File ]
mod - samples/mfc/standard/08_HLR/adm/win/vc8/HLR.vcproj Diff ] File ]
mod - samples/mfc/standard/08_HLR/adm/win/vc9/HLR.vcproj Diff ] File ]
mod - samples/mfc/standard/08_HLR/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/09_Animation/adm/win/vc10/Animation.vcxproj Diff ] File ]
mod - samples/mfc/standard/09_Animation/adm/win/vc11/Animation.vcxproj Diff ] File ]
mod - samples/mfc/standard/09_Animation/adm/win/vc12/Animation.vcxproj Diff ] File ]
mod - samples/mfc/standard/09_Animation/adm/win/vc8/Animation.vcproj Diff ] File ]
mod - samples/mfc/standard/09_Animation/adm/win/vc9/Animation.vcproj Diff ] File ]
mod - samples/mfc/standard/09_Animation/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/10_Convert/adm/win/vc10/Convert.vcxproj Diff ] File ]
mod - samples/mfc/standard/10_Convert/adm/win/vc11/Convert.vcxproj Diff ] File ]
mod - samples/mfc/standard/10_Convert/adm/win/vc12/Convert.vcxproj Diff ] File ]
mod - samples/mfc/standard/10_Convert/adm/win/vc8/Convert.vcproj Diff ] File ]
mod - samples/mfc/standard/10_Convert/adm/win/vc9/Convert.vcproj Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/Convert_Presentation.cpp Diff ] File ]
mod - samples/mfc/standard/10_Convert/src/WNT/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/Common/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/mfcsample/adm/win/vc10/mfcsample.vcxproj Diff ] File ]
mod - samples/mfc/standard/mfcsample/adm/win/vc11/mfcsample.vcxproj Diff ] File ]
mod - samples/mfc/standard/mfcsample/adm/win/vc12/mfcsample.vcxproj Diff ] File ]
mod - samples/mfc/standard/mfcsample/adm/win/vc8/mfcsample.vcproj Diff ] File ]
mod - samples/mfc/standard/mfcsample/adm/win/vc9/mfcsample.vcproj Diff ] File ]
mod - samples/qt/Common/src/CommonSample.h Diff ] File ]
mod - samples/qt/Common/src/View.cxx Diff ] File ]
mod - samples/qt/IESample/IESample.pro Diff ] File ]
mod - samples/qt/Interface/src/IESample.h Diff ] File ]
mod - samples/qt/Tutorial/Tutorial.pro Diff ] File ]

- Issue History
Date Modified Username Field Change
2015-10-16 15:50 kgv New Issue
2015-10-16 15:50 kgv Assigned To => bugmaster
2015-10-16 15:50 kgv Relationship added child of 0022972
2015-10-16 15:52 kgv Assigned To bugmaster => ski
2015-10-16 15:52 kgv Status new => assigned
2015-10-23 16:12 git Note Added: 0047391
2015-10-26 09:48 kgv Note Added: 0047424
2015-10-26 09:48 kgv Summary Do not declare redundant macros WNT, LIN, WIN32, WIN64 within samples project files => Do not declare redundant macros WNT, LIN, LININTEL, WIN32, WIN64 within samples project files
2015-10-26 09:48 kgv Description Updated View Revisions
2015-10-26 09:48 kgv Note Edited: 0047424 View Revisions
2015-10-26 09:48 kgv Note Edited: 0047424 View Revisions
2015-10-26 09:49 kgv Note Edited: 0047424 View Revisions
2015-10-26 12:12 git Note Added: 0047434
2015-10-26 13:57 ski Note Added: 0047437
2015-10-26 13:57 ski Assigned To ski => kgv
2015-10-26 13:57 ski Status assigned => resolved
2015-10-26 14:46 kgv Note Added: 0047447
2015-10-26 14:46 kgv Assigned To kgv => bugmaster
2015-10-26 14:46 kgv Status resolved => reviewed
2015-10-26 15:26 mkv Assigned To bugmaster => mkv
2015-10-27 14:58 mkv Note Added: 0047486
2015-10-27 14:58 mkv Assigned To mkv => bugmaster
2015-10-27 15:38 bugmaster Assigned To bugmaster => ski
2015-10-27 15:38 bugmaster Status reviewed => feedback
2015-10-27 15:41 bugmaster Note Added: 0047491
2015-10-27 15:43 bugmaster File Added: QT_Product_samples_Linux.docx
2015-10-28 14:35 git Note Added: 0047529
2015-10-29 10:30 ski Relationship added related to 0026824
2015-10-29 10:43 ski Status feedback => assigned
2015-10-29 10:44 ski Note Added: 0047576
2015-10-29 10:44 ski Assigned To ski => kgv
2015-10-29 10:44 ski Status assigned => resolved
2015-10-29 10:50 kgv Note Added: 0047579
2015-10-29 10:50 kgv Assigned To kgv => bugmaster
2015-10-29 10:50 kgv Status resolved => reviewed
2015-10-29 11:19 bugmaster Note Added: 0047582
2015-10-29 11:19 bugmaster Status reviewed => tested
2015-10-30 16:00 bugmaster Changeset attached => occt master 50fe2dab
2015-10-30 16:00 bugmaster Status tested => verified
2015-10-30 16:00 bugmaster Resolution open => fixed
2016-04-17 14:30 git Note Added: 0053183
2016-04-20 15:42 aiv Fixed in Version => 7.0.0
2016-04-20 15:51 aiv Status verified => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker