MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026181Community[OCCT] OCCT:Modeling Algorithmspublic2015-05-03 17:462015-05-14 15:28
ReporterVico Liang 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 6.8.0 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0026181: BOPAlgo_MakerVolume compile error if not adding BOPAlgo_PaveFiller.hxx ahead of BOPAlgo_MakerVolume.hxx.
Descriptioninclude\BOPAlgo_MakerVolume.lxx(112): error C2027: use of undefined type 'BOPAlgo_PaveFiller'
include\BOPAlgo_PPaveFiller.hxx(9) : see declaration of 'BOPAlgo_PaveFiller'
include\BOPAlgo_MakerVolume.lxx(112): error C2227: left of '->ErrorStatus' must point to class/struct/union/generic type

BOPAlgo_MakerVolume.lxx depends on BOPAlgo_PaveFiller.hxx

inline void BOPAlgo_MakerVolume::CheckData()
{
  if (myArguments.IsEmpty()) {
    myErrorStatus = 100; // no arguments to process
    return;
  }
  // myPaveFiller
  if (!myPaveFiller) {
    myErrorStatus = 101;
    return;
  }
  //
  myErrorStatus = myPaveFiller->ErrorStatus();
  if (myErrorStatus) {
    myErrorStatus = 102; // PaveFiller is failed
    return;
  }
}
Steps To ReproduceN/A
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0040529)
git (administrator)
2015-05-04 15:12

Branch CR26181 has been created by abv.

SHA-1: 0507b2b73dbbc1b4db5095413679bd5b9de0d887


Detailed log of new commits:

Author: abv
Date: Mon May 4 09:18:58 2015 +0300

    0026181: BOPAlgo_MakerVolume compile error if not adding BOPAlgo_PaveFiller.hxx ahead of BOPAlgo_MakerVolume.hxx.
    
    BOPAlgo_PaveFiller.hxx is included in BOPAlgo_MakerVolume.lxx
(0040530)
abv (manager)
2015-05-04 15:13

I have pushed correction to branch CR26181, could you please confirm it solves the problem?
(0040535)
msv (developer)
2015-05-05 10:21

There is no error in the current master. The method CheckData that was the reason of possible error has been moved from .lxx to .cxx and made non-inline since the commit SHA-1:b1d15f53b335b880e8195317e825863c1f700c21 dated 28.11.2014.
So, there is no necessity of any change due to this issue.
Dear Vico Liang, please, check that you have up to date version of source code and that your local file inc/BOPAlgo_MakerVolume.lxx is the same as src/BOPAlgo/BOPAlgo_MakerVolume.lxx.
(0040537)
abv (manager)
2015-05-05 10:40

Thank you Mikhail! I switch the issue to Verified
(0040543)
git (administrator)
2015-05-05 11:09

Branch CR26181 has been deleted by abv.

SHA-1: 0507b2b73dbbc1b4db5095413679bd5b9de0d887

- Issue History
Date Modified Username Field Change
2015-05-03 17:46 Vico Liang New Issue
2015-05-03 17:46 Vico Liang Assigned To => msv
2015-05-04 15:12 git Note Added: 0040529
2015-05-04 15:13 abv Note Added: 0040530
2015-05-04 15:13 abv Assigned To msv => Vico Liang
2015-05-04 15:13 abv Status new => resolved
2015-05-04 15:13 abv Steps to Reproduce Updated View Revisions
2015-05-05 10:21 msv Note Added: 0040535
2015-05-05 10:22 msv Assigned To Vico Liang => abv
2015-05-05 10:22 msv Status resolved => reviewed
2015-05-05 10:40 abv Note Added: 0040537
2015-05-05 10:40 abv Status reviewed => verified
2015-05-05 10:40 abv Resolution open => fixed
2015-05-05 10:40 abv Product Version 6.9.0 => 6.8.0
2015-05-05 10:40 abv Fixed in Version => 6.9.0
2015-05-05 10:47 abv Relationship added related to 0025477
2015-05-05 11:09 git Note Added: 0040543
2015-05-14 15:28 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker