MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0025551Open CASCADE[OCCT] OCCT:Meshpublic2014-12-04 11:492020-02-08 13:29
Reporteroan 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.5.0*Fixed in Version 
Summary0025551: BRepMesh can produce internal nodes outside the face interior based on distorted BSpline surface
DescriptionBRepMesh can produce internal nodes outside the face interior based on distorted BSpline surface
Steps To Reproduce# run test mesh advanced_incmesh B6
explode res f
donly res_2
triangles res_2
top
fit
TagsNo tags attached.
Test case numberbugs mesh bug25551
Attached Filespng file icon face_2.png (40,916 bytes) 2014-12-04 11:49
png file icon KO.png (7,826 bytes) 2020-01-30 17:03
png file icon OK.png (7,382 bytes) 2020-01-30 17:07

- Relationships

-  Notes
(0069126)
mkv (tester)
2017-08-04 18:26

Problem described in issue is reproduced on current state of OCCT.
(0088378)
git (administrator)
2019-10-21 11:53

Branch CR25551 has been created by oan.

SHA-1: 81c32cc5e028541b1737194c50d6fb74878061ae


Detailed log of new commits:

Author: oan
Date: Mon Oct 21 11:52:01 2019 +0300

    0025551: BRepMesh can produce internal nodes outside the face interior based on distorted BSpline surface
    
    updated test script to see the difference on current version of OCCT
(0088379)
oan (developer)
2019-10-21 11:54

Please review an updated version of test script that shows actual results of meshing.
(0088718)
abv (manager)
2019-11-04 16:53

Oleg, is the problem with internal node still reproduced? The test script should be able to detect the problem, and report error. When we would see TODO statements in the script if the problem is still there.
(0088724)
oan (developer)
2019-11-04 17:59

No, on current master the problem seems to be solved.
There is no such check to figure out overlapped triangles in the mesh.

This case should be detected only by image comparison.
(0090153)
git (administrator)
2020-01-29 17:05

Branch CR25551 has been updated forcibly by oan.

SHA-1: f5e61c0b68846b0ad8367c538e8f892450cbbdac
(0090165)
oan (developer)
2020-01-29 18:25

Report contains results both for 0025551, 0028247, #26382 and #25827

http://jenkins-test-12.nnov.opencascade.com/view/CR25551-master-OAN/view/COMPARE/ [^]
(0090203)
kgv (developer)
2020-01-30 15:58

It is usually helpful attaching two screenshots - KO (old, with bug reproduced) and OK (problem solved).
(0090393)
bugmaster (administrator)
2020-02-07 14:06

Tested in framework of WEEK-6:

Combination -
OCCT branch : WEEK-6
master SHA - 8b3fbdef34aed600927f10a8d58b56824ca8070d
fe4497f3246e6bc1ced97ac331c148f0809ded15
Products branch : WEEK-6 SHA - af75a25bca53d4cfce0059a706fc86799d3c1182
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17009.640000000178 / 16997.920000000046 [+0.07%]
Products
Total CPU difference: 12143.5600000001 / 12129.400000000101 [+0.12%]
Windows-64-VC14:
OCCT
Total CPU difference: 18438.515625 / 18439.75 [-0.01%]
Products
Products
Total CPU difference: 12143.5600000001 / 12129.400000000101 [+0.11%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0090417)
git (administrator)
2020-02-08 13:29

Branch CR25551 has been deleted by inv.

SHA-1: f5e61c0b68846b0ad8367c538e8f892450cbbdac

- Related Changesets
occt: master 62beabff
Timestamp: 2019-10-21 08:52:01
Author: oan
Committer: bugmaster
Details ] Diff ]
0025551: BRepMesh can produce internal nodes outside the face interior based on distorted BSpline surface

updated test script to see the difference on current version of OCCT
mod - tests/bugs/mesh/bug25551 Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-12-04 11:49 oan New Issue
2014-12-04 11:49 oan Assigned To => oan
2014-12-04 11:49 oan File Added: face_2.png
2014-12-04 11:50 oan Relationship added child of 0025519
2015-06-30 18:22 oan Relationship added has duplicate 0026382
2016-10-25 17:41 oan Target Version 7.1.0 => Unscheduled
2017-08-04 18:26 mkv Test case number => bugs mesh bug25551
2017-08-04 18:26 mkv Note Added: 0069126
2019-10-21 11:53 git Note Added: 0088378
2019-10-21 11:54 oan Note Added: 0088379
2019-10-21 11:54 oan Assigned To oan => abv
2019-10-21 11:54 oan Status new => resolved
2019-11-04 16:53 abv Note Added: 0088718
2019-11-04 16:53 abv Assigned To abv => oan
2019-11-04 16:53 abv Status resolved => feedback
2019-11-04 17:59 oan Note Added: 0088724
2019-11-04 17:59 oan Assigned To oan => abv
2019-11-04 17:59 oan Status feedback => resolved
2019-11-16 13:11 oan Target Version Unscheduled => 7.5.0*
2020-01-29 17:05 git Note Added: 0090153
2020-01-29 18:22 oan Assigned To abv => msv
2020-01-29 18:25 oan Note Added: 0090165
2020-01-30 15:58 kgv Note Added: 0090203
2020-01-30 17:03 oan File Added: KO.png
2020-01-30 17:07 oan File Added: OK.png
2020-01-31 19:03 msv Assigned To msv => bugmaster
2020-01-31 19:03 msv Status resolved => reviewed
2020-02-07 14:06 bugmaster Note Added: 0090393
2020-02-07 14:06 bugmaster Status reviewed => tested
2020-02-08 13:00 bugmaster Changeset attached => occt master 62beabff
2020-02-08 13:00 bugmaster Status tested => verified
2020-02-08 13:00 bugmaster Resolution open => fixed
2020-02-08 13:29 git Note Added: 0090417


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker