MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024570Community[OCCT] OCCT:Visualizationpublic2014-01-24 12:482015-11-17 17:44
ReporterHugues Delorme 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusclosedResolutionduplicate 
PlatformLinuxOSDebian 6.0OS Version64 bit
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.0.0Fixed in Version[OCCT] 7.0.0 
Summary0024570: Qt5 mouse tracking is not working with V3d_View (GNU/Linux)
DescriptionI've recently ported my Qt/OpenCascade code to Qt 5.2 (I was previously using Qt 4.8)
Every thing seems OK except that mouse tracking refuses to work.

Actually it is working on Windows platform but not with Kubuntu (13.04).

Mouse tracking doesn't work after the call to V3d_View::SetWindow().

Here is the source code of my Qt/OCC view widget (based on Pete Dolbey's QtOCC) :
https://github.com/fougsys/fougtools/blob/master/src/occtools/qt_view.h [^]
https://github.com/fougsys/fougtools/blob/master/src/occtools/qt_view.cpp [^]

This not a regression of OpenCascade 6.7.0 (it is also not working with v6.6.0)
Steps To ReproduceI have provided an example in the attached file (qtviewer.zip)
Note: the example is compiled with :
qmake CASCADE_ROOT=/your/path/to/occ qtviewer.pro
(n)make

The example should output in console the message "Mouse move" any time mouse is moved (without button pressed), but as mouse tracking is broken this is not the case ...
Additional information
and documentation updates
The issue was originally reported in the OpenCascade forum :
http://www.opencascade.org/org/forum/thread_25743/?forum=3 [^]
TagsNo tags attached.
Test case number
Attached Fileszip file icon qtviewer.zip (9,532 bytes) 2014-01-24 12:48

- Relationships
related to 0026603closedbugmaster Community Problem with maximization and normalization document windows in Qt samples with Qt 5.x 
related to 0026732closedbugmaster Open CASCADE Visualization, TKOpenGl - add option to request Core profile 3.2+ using GLX 

-  Notes
(0048301)
kgv (developer)
2015-11-17 16:42

The most possible root cause (creation of child window within TKOpenGl in some cases) has been eliminated within 0026732.

It is now up to application to ensure that alien XWindow passed to TKOpenGl has sufficient attributes (e.g. color / depth).
(0048302)
kgv (developer)
2015-11-17 16:43

Dear bugmaster,

please close the issue as duplicate of #0024467.

- Issue History
Date Modified Username Field Change
2014-01-24 12:48 Hugues Delorme New Issue
2014-01-24 12:48 Hugues Delorme Assigned To => san
2014-01-24 12:48 Hugues Delorme File Added: qtviewer.zip
2015-11-17 16:37 kgv Relationship added related to 0026603
2015-11-17 16:38 kgv Relationship added duplicate of 0024467
2015-11-17 16:39 kgv Relationship added related to 0026732
2015-11-17 16:42 kgv Note Added: 0048301
2015-11-17 16:43 kgv Note Added: 0048302
2015-11-17 16:43 kgv Assigned To san => bugmaster
2015-11-17 16:43 kgv Status new => feedback
2015-11-17 16:43 kgv Resolution open => fixed
2015-11-17 16:43 kgv Fixed in Version => 7.0.0
2015-11-17 16:43 kgv Target Version => 7.0.0
2015-11-17 17:43 bugmaster Status feedback => closed
2015-11-17 17:44 bugmaster Resolution fixed => duplicate


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker