MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024547Open CASCADE[OCCT] OCCT:Codingpublic2014-01-21 12:152014-11-11 12:51
Reporterdln 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 6.8.0Fixed in Version[OCCT] 6.8.0 
Summary0024547: Convertation of the generic classes to the non-generic (math)
DescriptionIn the package "math":

- class "math_DoubleTab" was converted to the non-generic class.
  Some changes were made in the class "math_Matrix".

- class "math_SingleTab" was converted to the non-generic template class.
  And classes "math_Vector" and "math_IntegerVector" converted to the non-cdl, because they use template class "math_SingleTab"
  
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0024487closedabv Getting rid of generic CDL classes 

-  Notes
(0027575)
dln (developer)
2014-01-21 14:10

Changes are ready for review in CR24547 branch.
(0027604)
abv (manager)
2014-01-22 15:59

Igor, please review the fix; from my side I have no remarks
(0027610)
ifv (developer)
2014-01-22 17:19

Seems to be Ok
Small remark:
in my opinion, it is possible to remove math_Matrix from friends of math_IntegerVector because it is never used. Natural frieds are math_Matrix and math_Vector, it is used in some methods of math_Matrix and math_Vector.
(0027612)
abv (manager)
2014-01-22 17:42

I have pushed one more commit removing mentioned friend statement.
(0027630)
mkv (tester)
2014-01-23 15:51

Dear BugMaster,

Branch CR24547 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: a0773e04b59aa18a53256631dc829bcdbcbb50fe

Number of compiler warnings:

occt component :
Linux: 48 (48 on master)
Windows: 1 (1 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
http://occt-tests/CR24547-master-occt/Debian60-64/summary.html [^]
http://occt-tests/CR24547-master-occt/Windows-32-VC9/summary.html [^]

Testing cases:
Not needed
(0027798)
dln (developer)
2014-02-06 11:02

Branch CR24547 was updated, check it please.
(0027800)
kgv (developer)
2014-02-06 12:04

Dear dln,

+template<class T> class math_SingleTab
+{
+public:
+
+  DEFINE_STANDARD_ALLOC
+
+  Standard_EXPORT math_SingleTab(const Standard_Integer LowerIndex, const Standard_Integer UpperIndex) 
:
+      Addr(Buf),
+      isAllocated(UpperIndex - LowerIndex + 1 > aLengthOfBuf),

could you please remove Standard_EXPORT from all methods of template classes?
(0027801)
dln (developer)
2014-02-06 12:16
edited on: 2014-02-06 12:31

Dear kgv,

Ok, i'll correct it

(0027802)
dln (developer)
2014-02-06 12:36

Corrected. CR24547
(0027811)
abv (manager)
2014-02-07 12:02

Dmitry, please correct comments in the header files to be suitable for Doxygen generation:

- remove angle brackets (text within <> is considered as HTML tag by Doxygen)
- add @code ... @endcode around sample code blocks (see http://www.stack.nl/~dimitri/doxygen/manual/commands.html#cmdcode [^])
- add empty lines between the method declaration and comment to the next one

Then please verify the result by running Doxygen (command wgendoc in WOK) and checking the resulting HTML documentation
(0027818)
dln (developer)
2014-02-07 18:54

Dear Andrey,

Check it please. (CR24547)
(0027821)
abv (manager)
2014-02-08 17:33

No remarks, please test
(0027833)
mkv (tester)
2014-02-10 17:39

Dear BugMaster,

Branch CR24547 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: e275e53df0b56cbb019baac530ef087fcb90d9ac

Number of compiler warnings:

occt component :
Linux: 40 (40 on master)
Windows: 0 (0 on master)

products component :
Linux: 12 (12 on master)
Windows: 2 (2 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 381611520 / 381831144
Total CPU difference: 42478.560000000005 / 42213.76

Testing on Windows:
Total MEMORY difference: 430537788 / 431123492
Total CPU difference: 32528.59375 / 34130.65625

There are not differences in images found by testdiff.

- Related Changesets
occt: master 3b010a74
Timestamp: 2014-01-21 08:15:53
Author: dln
Committer: apn
Details ] Diff ]
0024547: Convertation of the generic classes to the non-generic (math).

- class "math_DoubleTab" was converted to the non-generic class. Some changes were made in the class "math_Matrix". And some stylish changes were made.

- class "math_SingleTab" was converted to the non-generic template class. And classes "math_Vector" and "math_IntegerVector" converted to the non-cdl, because they use template class "math_Vector". Some stylish changes were made.
mod - src/math/FILES Diff ] File ]
mod - src/math/math.cdl Diff ] File ]
mod - src/math/math_DoubleTab.cdl Diff ] File ]
mod - src/math/math_DoubleTab.lxx Diff ] File ]
rm - src/math/math_IntegerVector.cdl Diff ] File ]
mod - src/math/math_IntegerVector.cxx Diff ] File ]
add - src/math/math_IntegerVector.hxx Diff ] File ]
rm - src/math/math_IntegerVector.lxx Diff ] File ]
mod - src/math/math_Matrix.cdl Diff ] File ]
mod - src/math/math_Matrix.cxx Diff ] File ]
rm - src/math/math_SingleTab.cdl Diff ] File ]
rm - src/math/math_SingleTab.gxx Diff ] File ]
add - src/math/math_SingleTab.hxx Diff ] File ]
rm - src/math/math_SingleTab.lxx Diff ] File ]
rm - src/math/math_Vector.cdl Diff ] File ]
mod - src/math/math_Vector.cxx Diff ] File ]
add - src/math/math_Vector.hxx Diff ] File ]
rm - src/math/math_Vector.lxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-21 12:15 dln New Issue
2014-01-21 12:15 dln Assigned To => abv
2014-01-21 14:05 dln Description Updated View Revisions
2014-01-21 14:09 dln Relationship added child of 0024487
2014-01-21 14:10 dln Note Added: 0027575
2014-01-21 14:57 dln Status new => resolved
2014-01-22 08:21 dln Description Updated View Revisions
2014-01-22 15:59 abv Assigned To abv => ifv
2014-01-22 15:59 abv Note Added: 0027604
2014-01-22 17:19 ifv Note Added: 0027610
2014-01-22 17:19 ifv Status resolved => reviewed
2014-01-22 17:42 abv Note Added: 0027612
2014-01-22 17:42 abv Assigned To ifv => bugmaster
2014-01-23 07:08 mkv Assigned To bugmaster => mkv
2014-01-23 15:51 mkv Note Added: 0027630
2014-01-23 15:51 mkv Test case number => Not needed
2014-01-23 15:51 mkv Assigned To mkv => dln
2014-01-23 15:51 mkv Status reviewed => assigned
2014-02-06 11:02 dln Note Added: 0027798
2014-02-06 11:02 dln Assigned To dln => abv
2014-02-06 11:02 dln Status assigned => resolved
2014-02-06 12:04 kgv Note Added: 0027800
2014-02-06 12:04 kgv Assigned To abv => dln
2014-02-06 12:04 kgv Status resolved => assigned
2014-02-06 12:16 dln Note Added: 0027801
2014-02-06 12:31 dln Note Edited: 0027801 View Revisions
2014-02-06 12:36 dln Note Added: 0027802
2014-02-06 12:36 dln Assigned To dln => abv
2014-02-06 12:36 dln Status assigned => resolved
2014-02-07 12:02 abv Note Added: 0027811
2014-02-07 12:02 abv Assigned To abv => dln
2014-02-07 12:02 abv Status resolved => assigned
2014-02-07 18:54 dln Note Added: 0027818
2014-02-07 18:54 dln Assigned To dln => abv
2014-02-07 18:54 dln Status assigned => resolved
2014-02-08 17:33 abv Note Added: 0027821
2014-02-08 17:33 abv Assigned To abv => bugmaster
2014-02-08 17:33 abv Status resolved => reviewed
2014-02-10 13:01 mkv Assigned To bugmaster => mkv
2014-02-10 17:39 mkv Note Added: 0027833
2014-02-10 17:39 mkv Assigned To mkv => bugmaster
2014-02-10 17:39 mkv Status reviewed => tested
2014-02-14 12:00 apn Changeset attached => occt master 3b010a74
2014-02-14 12:00 apn Assigned To bugmaster => apn
2014-02-14 12:00 apn Status tested => verified
2014-02-14 12:00 apn Resolution open => fixed
2014-04-04 12:36 abv Target Version 6.7.1 => 6.8.0
2014-11-11 12:47 aiv Fixed in Version => 6.8.0
2014-11-11 12:51 aiv Status verified => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker