MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0024345Open CASCADE[OCCT] OCCT:Visualizationpublic2013-11-11 20:362013-12-19 13:59
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2008OS Version32 bit
Product Version 
Target Version[OCCT] 6.7.0Fixed in Version[OCCT] 6.7.0 
Summary0024345: TKOpenGl - GLSL compatibility issues on NV40 (GeForce 6xxx/7xxx)
DescriptionGLSL Phong program compilation fails on NV40 due to hardware limits.
The reason is variable number of light sources used in Fragment shader.
0(215) : error C6013: Only arrays of texcoords may be indexed in this profile, and only with a loop index 
variable


OpenGL info:
  GLvendor    = 'NVIDIA Corporation'
  GLdevice    = 'GeForce 6600 GT/PCIe/SSE2'
  GLversion   = '2.1.2'
  GLSLversion = '1.20 NVIDIA via Cg compiler'
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0024310closedabv TKOpenGl - GLSL compatibility issues 
related to 0024250closedbugmaster TKOpenGl - per-pixel lighting using GLSL program (Phong shading) 
related to 0024363closedkgv Automated Tests - optimize testing environment for visualization tests 

-  Notes
(0026553)
kgv (developer)
2013-11-11 21:14

Patch is ready for review in CR24345 branch.

It seems change has negligible effect on performance (tested on RadeOn HD 6850).

restore [locate_data_file occ/Bottom.brep] b
restore [locate_data_file occ/Top.brep] t
tclean b
tclean t
vdefaults absDefl=0.002
vinit View1
vclear
vaxo vsetdispmode 1
vdisplay b t
vfit
vfps
vshaderprog phong
vfps
(0026566)
apl (developer)
2013-11-12 12:42

Dear Bugmaster,

The patch is reviewed without remarks.

Please test.
(0026591)
mkv (tester)
2013-11-13 13:34

Dear BugMaster,

Branch CR24345 (and products from GIT master) was compiled on Linux and Windows platforms and tested.
SHA-1: 5c3b62efa732dd9f39c428b0e4b8e195d32dd9ef

Number of compiler warnings:

occt component :
Linux: 318 (318 on master)
Windows: 0 (0 on master)

products component :
Linux: 188 (188 on master)
Windows: 287 (287 on master)

Regressions/Differences:
No regressions/differences

Testing cases:
Not needed

Testing on Linux:
Total MEMORY difference: 355879336 / 356024524
Total CPU difference: 43484.69000000019 / 42011.39000000042

Testing on Windows:
Total MEMORY difference: 411162152 / 410757816
Total CPU difference: 30141.953125 / 30177.1875

There are following differences in images found by testdiff.
Only on Linux platform:
http://occt-tests/CR24345-master-occt/Debian60-64/diff-Debian60-64.html [^]
IMAGE v3d glsl phong_fuse2: phong_fuse2_ph2.png differs
IMAGE v3d glsl phong_fuse2: phong_fuse2_ph1.png differs
IMAGE v3d glsl phong_fuse2: phong_fuse2.png differs
IMAGE v3d glsl phong_fuse: phong_fuse2_ph2.png differs
IMAGE v3d glsl phong_fuse: phong_fuse2_ph1.png differs
IMAGE v3d glsl phong_fuse: phong_fuse2.png differs
(0026598)
kgv (developer)
2013-11-13 15:45

OpenGL info:
  GLvendor    = 'Brian Paul'
  GLdevice    = 'Mesa X11'
  GLversion   = '2.1 Mesa 9.1'
  GLSLversion = '1.20'
  GLdebug     =  ON

Dear bugmaster, it looks like a bug in Mesa on Linux.

Could you please evaluate patch (only v3d/glsl/phong_fuse2 test case) on more recent Mesa release?
(0026603)
kgv (developer)
2013-11-13 22:24
edited on: 2013-11-13 22:25

OpenGL info:
  GLvendor    = 'X.Org'
  GLdevice    = 'Gallium 0.4 on AMD BARTS'
  GLversion   = '3.0 Mesa 9.1.7'
  GLSLversion = '1.30'
  GLdebug     =  ON

Tested on RadeOn HD 6850 (Ubuntu 13.04 AMD64, hardware accelerated Mesa) - there no such issues.
Cumulative patch, containing all recent GLSL fixed has been pushed to CR24345_1 branch.


- Related Changesets
occt: master 01eaf654
Timestamp: 2013-11-13 18:01:45
Author: kgv
Committer: bugmaster
Details ] Diff ]
0024345: TKOpenGl - GLSL compatibility issues on NV40 (GeForce 6xxx/7xxx)

Iterate through maximum light sources in Fragment shader instead of active lights
mod - src/OpenGl/OpenGl_ShaderManager.cxx Diff ] File ]
mod - src/Shaders/PhongShading.fs Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-11-11 20:36 kgv New Issue
2013-11-11 20:36 kgv Assigned To => kgv
2013-11-11 20:36 kgv Description Updated View Revisions
2013-11-11 20:37 kgv Relationship added related to 0024310
2013-11-11 20:37 kgv Relationship added related to 0024250
2013-11-11 21:14 kgv Note Added: 0026553
2013-11-11 21:14 kgv Assigned To kgv => apl
2013-11-11 21:14 kgv Status new => resolved
2013-11-12 12:42 apl Note Added: 0026566
2013-11-12 12:42 apl Assigned To apl => bugmaster
2013-11-12 12:42 apl Status resolved => reviewed
2013-11-12 13:57 mkv Assigned To bugmaster => mkv
2013-11-13 13:34 mkv Note Added: 0026591
2013-11-13 13:34 mkv Test case number => Not needed
2013-11-13 13:34 mkv Assigned To mkv => kgv
2013-11-13 13:34 mkv Status reviewed => feedback
2013-11-13 15:45 kgv Note Added: 0026598
2013-11-13 15:45 kgv Assigned To kgv => bugmaster
2013-11-13 22:24 kgv Note Added: 0026603
2013-11-13 22:25 kgv Note Edited: 0026603 View Revisions
2013-11-15 10:24 bugmaster Changeset attached => occt master 01eaf654
2013-11-15 10:24 bugmaster Status feedback => verified
2013-11-15 10:24 bugmaster Resolution open => fixed
2013-11-15 11:29 kgv Relationship added related to 0024363
2013-12-19 13:50 bugmaster Status verified => closed
2013-12-19 13:59 bugmaster Fixed in Version => 6.7.0


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker