MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023922Open CASCADE[OCCT] OCCT:Testspublic2013-04-22 07:302015-05-14 15:33
Reporterabv 
Assigned Tobugmaster 
PriorityhighSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 6.9.0Fixed in Version[OCCT] 6.9.0 
Summary0023922: Systematic review of TODO tests
DescriptionWe have a lot of tests containing TODO statements and thus reporting BAD status. Many of these tests do not really show problem in OCCT but rather have their own implementation problem which can be easily fixed.

For instance, here is result of review of ~ 10 test cases:

bugs vis buc60547 - crashes because cannot read data files; the whole test looks meaningless
bugs vis bug10702 - exception in DRAW command; if fixed, test fails because of attempt to use non-existent command nodalcolor_id

In context of this issue, I suggest that all tests with TODO containing "TEST INCOMPLETE" and / or unstable (containing '?') should be checked.
Steps To ReproduceNot required
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0024223closedbugmaster Review of unstable test cases 
related to 0023626closedbugmaster It's impossible to open files containing localisation characters in the name 

-  Notes
(0025977)
abv (manager)
2013-10-09 00:12

Please consider this issue as high priority, at least fix the cases listed in description, as at least first of them causes real troubles in testing (it hang-ups sometimes, along with the whole test system) and compromise the test system in general.
(0034134)
git (administrator)
2014-11-07 09:53

Branch CR23922 has been created by ski.

SHA-1: eda904e774c9a532e6cc66cebd6bca787e455e56


Detailed log of new commits:

Author: ski
Date: Fri Nov 7 09:50:25 2014 +0300

    0023922: Systematic review of TODO tests
    
    Small corrections for test cases with "TEST INCOMPLETE" result.
(0034136)
ski (developer)
2014-11-07 10:07

All tests with TODO containing "TEST INCOMPLETE" were checked.

bugs / vis / pro20342 is OK now.
bugs / fclasses / bug63 (on Windows) crashes not on locate_data_file, but on brestore command now (for information - CR23626).

The cases listed in description were already fixed.

Tested on Windows-32-VC9 and Debian60-64.

Please, review.
(0034679)
abv (manager)
2014-11-25 16:54

Please correct test cases:

- bugs fclasses bug63: see 0023626 -- the data file should have expected name for the test to be meaningful. I suppose that the data file should be ranamed in Git so that its name contains only Ascii symbols, and copied to local folder with a name containing localization characters by the test (using Tcl) before trying to open it by OCCT. This way we would eliminate dependency on file systems and interfaces. Note that reading files with names containing non-Ascii characters should work since 0025367

- bugs moddata_2 bug2569_2: please try to catch the exception to avoid TEST INCOMPLETE status

Note that we have ~ 300 other tests that are BAD due to crash (TEST INCOMPLETE), these are to be checked
(0034847)
git (administrator)
2014-11-28 16:47

Branch CR23922 has been updated forcibly by ski.

SHA-1: 0258122291a73a91ad9407c58b2344f02b5fa94f
(0034905)
git (administrator)
2014-12-02 11:55

Branch CR23922 has been updated forcibly by ski.

SHA-1: 4eebb24687e2c8b155d61942aee3f55cd8e94eea
(0034920)
ski (developer)
2014-12-02 14:36

Tests with TODO containing "TEST INCOMPLETE" were reviewed and corrected.

Also, product branch CR23922 was created. Unnecessary TODOs were removed.
(0034921)
ski (developer)
2014-12-02 14:39

Changed test cases were tested on Windows-32-VC9 and Debian60-64.
(0035225)
git (administrator)
2014-12-09 17:09

Branch CR23922 has been updated forcibly by ski.

SHA-1: 29fc7cc0ee7944e469510d224fb3001e7d280ea2
(0035227)
ski (developer)
2014-12-09 17:19

Branch CR23922 was rebased on current master.

Test case bugs / fclasses / bug63 will be OK after integration of 0023626,
also, it's necessary to rename shape "box__simplifiée.brep" to "box__simplifie.brep" during testing.

Note that product branch CR23922 was created.

Please, review
(0035790)
abv (manager)
2014-12-26 18:29

No remarks, please test
(0035849)
git (administrator)
2014-12-29 18:50

Branch CR23922 has been updated forcibly by apv.

SHA-1: f9e394132129135bdc304e25471badde27707c93
(0035850)
apv (tester)
2014-12-29 18:54

Branches CR23922 have been rebased on the current masters (occt and products)
(0036016)
apv (tester)
2015-01-13 18:32

Dear BugMaster,

Branch CR23922 from occt git-repository (and CR23922 from products git-repository) was compiled on Linux, MacOS and Windows platforms and tested.
SHA-1: f9e394132129135bdc304e25471badde27707c93
SHA-1: 0e88e0fc2558b47ee5f65bc4036e4ecb356ea26c

Number of compiler warnings:
occt component:
   Linux: 18 (18 on master)
   Windows: 0 (0 on master)
products component :
   Linux: 11 (11 on master)
   Windows: 1 (1 on master)

Regressions/Differences:
Not detected

Testing cases:
Not needed

Testing on Linux:
   occt component:
Total MEMORY difference: 369092300 / 368993888
Total CPU difference: 47504.12999999987 / 46126.530000000064
   products component:
Total MEMORY difference: 111629036 / 111224236
Total CPU difference: 16198.789999999986 / 15635.579999999994

Testing on Windows:
   occt component:
Total MEMORY difference: 275853676 / 276810540
Total CPU difference: 36599.28125 / 38319.9375
   products component:
Total MEMORY difference: 72534384 / 71429320
Total CPU difference: 11507.09375 / 10071.46875
(0036535)
git (administrator)
2015-01-26 12:32

Branch CR23922 has been deleted by inv.

SHA-1: f9e394132129135bdc304e25471badde27707c93

- Related Changesets
occt: master c857a60a
Timestamp: 2015-01-15 12:06:54
Author: ski
Committer: bugmaster
Details ] Diff ]
0023922: Systematic review of TODO tests

Small corrections for test cases with "TEST INCOMPLETE" result.

TODO statements with "TEST INCOMPLETE" were checked and corrected.
mod - tests/3rdparty/fonts/B1 Diff ] File ]
mod - tests/blend/tolblend_simple/C9 Diff ] File ]
mod - tests/blend/tolblend_simple/F5 Diff ] File ]
mod - tests/blend/tolblend_simple/F6 Diff ] File ]
mod - tests/blend/tolblend_simple/F9 Diff ] File ]
mod - tests/blend/tolblend_simple/G1 Diff ] File ]
mod - tests/boolean/bsection/N7 Diff ] File ]
mod - tests/bugs/fclasses/bug63 Diff ] File ]
mod - tests/bugs/modalg_2/bug426 Diff ] File ]
mod - tests/bugs/moddata_2/bug2569_2 Diff ] File ]
mod - tests/bugs/vis/buc60915 Diff ] File ]
mod - tests/bugs/vis/pro20342 Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-04-22 07:30 abv New Issue
2013-04-22 07:30 abv Assigned To => mkv
2013-06-20 16:55 apn Assigned To mkv => apn
2013-06-20 16:55 mkv Status new => assigned
2013-10-09 00:10 abv Relationship added related to 0024223
2013-10-09 00:12 abv Note Added: 0025977
2013-10-09 00:12 abv Priority normal => high
2013-10-09 00:15 abv Description Updated View Revisions
2013-12-12 21:07 abv Target Version 6.7.0 => 6.7.1
2014-04-04 18:32 abv Target Version 6.7.1 => 6.8.0
2014-09-26 11:07 abv Status assigned => feedback
2014-11-07 09:53 git Note Added: 0034134
2014-11-07 10:07 ski Note Added: 0034136
2014-11-07 10:21 apn Test case number => Not needed
2014-11-07 10:21 apn Status feedback => resolved
2014-11-07 10:22 apn Assigned To apn => abv
2014-11-11 01:04 abv Target Version 6.8.0 => 7.0.0
2014-11-25 16:44 abv Relationship added related to 0023626
2014-11-25 16:54 abv Note Added: 0034679
2014-11-25 16:54 abv Assigned To abv => ski
2014-11-25 16:54 abv Status resolved => assigned
2014-11-28 16:47 git Note Added: 0034847
2014-12-02 11:55 git Note Added: 0034905
2014-12-02 14:36 ski Note Added: 0034920
2014-12-02 14:39 ski Note Added: 0034921
2014-12-09 17:09 git Note Added: 0035225
2014-12-09 17:19 ski Note Added: 0035227
2014-12-09 17:19 ski Assigned To ski => abv
2014-12-09 17:19 ski Status assigned => resolved
2014-12-09 17:19 ski Steps to Reproduce Updated View Revisions
2014-12-26 18:29 abv Note Added: 0035790
2014-12-26 18:29 abv Assigned To abv => bugmaster
2014-12-26 18:29 abv Status resolved => reviewed
2014-12-26 19:04 mkv Assigned To bugmaster => apv
2014-12-29 18:50 git Note Added: 0035849
2014-12-29 18:54 apv Note Added: 0035850
2015-01-13 18:32 apv Note Added: 0036016
2015-01-13 18:32 apv Assigned To apv => bugmaster
2015-01-13 18:32 apv Status reviewed => tested
2015-01-16 13:37 bugmaster Changeset attached => occt master c857a60a
2015-01-16 13:37 bugmaster Status tested => verified
2015-01-16 13:37 bugmaster Resolution open => fixed
2015-01-19 16:23 bugmaster Target Version 7.0.0 => 6.9.0
2015-01-26 12:32 git Note Added: 0036535
2015-05-14 15:29 aiv Status verified => closed
2015-05-14 15:33 aiv Fixed in Version => 6.9.0


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker