MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0023144Community[OCCT] OCCT:Modeling Algorithmspublic2012-05-06 19:472013-04-29 15:21
ReporterQbProg 
Assigned Toomy 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version32 bit
Product Version[OCCT] 6.5.3 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0023144: Suspicious if (3)
Descriptioninc\intpatch_impimpintersection_5.gxx , line 111

if (aR1>aR1)

if always false?


TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0023132closedomy Suspicious code snippets 

-  Notes
(0021762)
omy (developer)
2012-10-12 18:45

Dear oan,
Fix is integrated to branch CR23144 (see commit message for details). Please review.
(0021790)
oan (developer)
2012-10-16 12:41

Dear OMY,
the case when result of intersection is IntAna_Line and number of solutions equals one is possible when apices of the given cones are coincident.

If second cone is inside the first, the distance between a point laying on intersection line and line which direction consides with axis of second cone should be less than distance between described point and line of the first cone. So, I guess that aR1 > aR2 is the right solution, isn't it?

Could you please perform detail check in touch of these statements?
(0021829)
omy (developer)
2012-10-18 10:53

Dear OAN,
You are correct in your suggestion. I've fixed it. Please, review.
(0021869)
oan (developer)
2012-10-22 09:47

Dear JGV,
please review the changes
(0021880)
jgv (developer)
2012-10-22 13:52

No remarks
(0022037)
apn (administrator)
2012-10-31 18:25

Dear BugMaster,
Branch CR23144 (and products from GIT master) was compiled on Linux and Windows platforms and tested.

Regression:
Not detected

Improvements:
Not detected

Testing case:
Not needed

- Related Changesets
occt: master 8f905bca
Timestamp: 2012-11-15 09:01:32
Author: omy
Details ] Diff ]
0023144: Suspicious if (3)

Fixed mistake in Standard_Boolean IntCoCo ( ... ) function of IntPatch_ImpImpIntersection_5.gxx file.
Fixed this condition because of the opposite parametrisation direction of the intersection line.
mod - src/IntPatch/IntPatch_ImpImpIntersection_5.gxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-05-06 19:47 QbProg New Issue
2012-05-06 19:47 QbProg Assigned To => abv
2012-05-07 09:18 abv Relationship added child of 0023132
2012-05-07 09:27 abv Assigned To abv => dbv
2012-05-07 09:27 abv Status new => assigned
2012-05-07 09:27 abv Category OCCT:Foundation Classes => OCCT:Modeling Algorithms
2012-05-07 09:27 abv Target Version => 6.5.4
2012-10-09 18:37 oan Assigned To dbv => omy
2012-10-12 18:45 omy Note Added: 0021762
2012-10-12 18:46 omy Assigned To omy => oan
2012-10-12 18:47 omy Status assigned => resolved
2012-10-16 12:41 oan Note Added: 0021790
2012-10-16 12:41 oan Assigned To oan => omy
2012-10-16 12:41 oan Status resolved => reviewed
2012-10-16 12:43 oan Status reviewed => assigned
2012-10-18 10:53 omy Note Added: 0021829
2012-10-18 10:53 omy Status assigned => resolved
2012-10-18 10:54 omy Assigned To omy => oan
2012-10-22 09:46 oan Assigned To oan => jgv
2012-10-22 09:47 oan Note Added: 0021869
2012-10-22 13:52 jgv Note Added: 0021880
2012-10-22 13:52 jgv Status resolved => reviewed
2012-10-23 09:54 abv Target Version 6.5.4 => 6.6.0
2012-10-23 16:17 mkv Assigned To jgv => mkv
2012-10-31 18:25 apn Note Added: 0022037
2012-10-31 18:26 apn Test case number => Not needed
2012-10-31 18:26 apn Assigned To mkv => bugmaster
2012-10-31 18:26 apn Status reviewed => tested
2012-11-16 13:03 omy Changeset attached => occt master 8f905bca
2012-11-16 13:03 omy Assigned To bugmaster => omy
2012-11-16 13:03 omy Status tested => verified
2012-11-16 13:03 omy Resolution open => fixed
2012-12-10 17:16 omy Changeset attached => occt master 8f905bca
2013-04-23 13:36 user533 Status verified => closed
2013-04-29 15:21 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker