MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030498Open CASCADE[OCCT] OCCT:Documentationpublic2019-02-18 11:282019-03-05 13:47
Reportermsv 
Assigned Toapn 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.4.0* 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0030498: Warnings of building documentation
DescriptionThe doxygen documentation is built with warnings:

         D:/git/occt1/samples/qt/AndroidQt/ReadMe.md(89): warning : Reached end of file while still inside a (nested) comment. Nesting level 5 (probable line reference: 19, 18, 17, 17, 1) [D:\git\occt1\build\dox\Overview.vcxproj]
         D:/git/occt1/dox/dev_guides/upgrade/upgrade.md(1681): warning : Reached end of file while still inside a (nested) comment. Nesting level 2 (probable line reference: 1094, 1094) [D:\git\occt1\build\dox\Overview.vcxproj]

It is needed to remove these warnings, and make sure that such warnings are caught by jenkins system. They must not be integrated in OCCT anymore.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0082209)
git (administrator)
2019-02-18 15:04

Branch CR30498 has been created by apn.

SHA-1: 78d5ea7a7141e6583e8526e43cce3e50001a6184


Detailed log of new commits:

Author: apn
Date: Mon Feb 18 14:59:32 2019 +0300

    0030498: Warnings of building documentation
    
    Fix warning 'Reached end of file while still insided a (nested) comment in Markdown' for old versions of doxygen
(0082210)
apn (administrator)
2019-02-18 15:42

Jenkins system controls documentation warnings during each compilation.
These warnings can be reproduced only in doxygen version 1.8.8 or earlier (/* is considered as open comment). This kind of warnings were disabled in doxygen since 1.8.9 version: https://github.com/doxygen/doxygen/issues/5572 [^]

We use doxygen 1.8.13, so these warnings are not appeared during testing on Jenkins.

Fix was pushed to CR30498. Dear msv, could you please review changes.
(0082211)
msv (developer)
2019-02-18 16:18

Reviewed.
(0082649)
git (administrator)
2019-03-05 13:47

Branch CR30498 has been deleted by kgv.

SHA-1: 78d5ea7a7141e6583e8526e43cce3e50001a6184

- Related Changesets
occt: master 78d5ea7a
Timestamp: 2019-02-18 11:59:32
Author: apn
Details ] Diff ]
0030498: Warnings of building documentation

Fix warning 'Reached end of file while still insided a (nested) comment in Markdown' for old versions of doxygen
mod - dox/dev_guides/upgrade/upgrade.md Diff ] File ]
mod - samples/qt/AndroidQt/ReadMe.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2019-02-18 11:28 msv New Issue
2019-02-18 11:28 msv Assigned To => inv
2019-02-18 13:38 bugmaster Assigned To inv => apn
2019-02-18 15:04 git Note Added: 0082209
2019-02-18 15:42 apn Test case number => Not needed
2019-02-18 15:42 apn Note Added: 0082210
2019-02-18 15:42 apn Assigned To apn => msv
2019-02-18 15:42 apn Status new => resolved
2019-02-18 16:18 msv Note Added: 0082211
2019-02-18 16:18 msv Assigned To msv => bugmaster
2019-02-18 16:18 msv Status resolved => reviewed
2019-02-18 16:20 apn Status reviewed => tested
2019-02-23 13:56 apn Changeset attached => occt master 78d5ea7a
2019-02-23 13:56 apn Assigned To bugmaster => apn
2019-02-23 13:56 apn Status tested => verified
2019-02-23 13:56 apn Resolution open => fixed
2019-03-05 13:47 git Note Added: 0082649


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker