MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009456Open CASCADE[OCCT] OCCT:Documentationpublic2005-07-08 13:162015-11-01 13:03
Reporterbugmaster 
Assigned To 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSAllOS Version
Product Version 
Target VersionFixed in Version[OCCT] 6.8.0 
Summary0009456: Development BOP documentation
DescriptionAt present time the human resources are shared by different projects. Often
developers, which do
not participate in a sold project, correct Open CASCADE bugs. When a developer
having expertise in
one technical domain corrects bugs corresponding to another domain he spend more
time than those
developers, which have expertise in this domain.

It is proposed to develop internal technical documentation. This documentation
should contain
programmer?s guide corresponding to different Open CASCADE modeling algorithms.
In particular it is
proposed to develop such documentation for Boolean operations algorithm.
It is necessary to do in order to decrease time of bugs analysis and correction.
It also allows
saving knowledge and expertise accumulated during long time.

The programmer?s guide should contain concept of algorithm, structure of
classes, description of
important functions and algorithms. This document should be developed in the
form, which allows to
easily understand the algorithm and quickly find interesting parts of the source
code.
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0024649closedapn Update user's guide for Boolean operations 

-  Notes
(0047684)
abv (manager)
2015-11-01 13:03

The documentation on BOP is provided within 0024649

- Issue History
Date Modified Username Field Change
2005-07-08 13:16 bugmaster Status new => closed
2005-07-08 13:16 bugmaster Resolution @0@ => suspended
2005-07-08 13:16 bugmaster Summary => Development BOP documentation
2005-07-08 13:16 bugmaster validate => 1
2005-07-08 16:18 bugmaster Type => FIP
2006-01-12 11:32 bugmaster Status closed => assigned
2006-01-12 11:32 bugmaster Resolution suspended => @0@
2006-01-31 14:08 bugmaster Assigned To bugmaster => pkv
2011-08-02 11:19 bugmaster Category OCCT:DOC => OCCT:Documentation
2015-11-01 13:03 abv Relationship added duplicate of 0024649
2015-11-01 13:03 abv Note Added: 0047684
2015-11-01 13:03 abv Assigned To pkv =>
2015-11-01 13:03 abv Status assigned => closed
2015-11-01 13:03 abv Resolution open => fixed
2015-11-01 13:03 abv Fixed in Version EMPTY => 6.8.0
2015-11-01 13:03 abv Description Updated View Revisions


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker