View Issue Details

IDProjectCategoryView StatusLast Update
0000044Open CASCADEOCCT:Documentationpublic2005-09-12 08:27
Reportermsv Assigned Todle-old 
PrioritynormalSeveritytrivial 
Status closedResolutionfixed 
OSAll 
Summary0000044: Serious misinformation in documentation for TCollection_IndexedDataMap::Add
DescriptionThe doc says:
        -- .... If the key was already in the
    -- map the previous item is replaced by .
But indeed the Item is not replaced, as seen in the code.
This may lead to incorrect work of many algorithms in OpenCASCADE.
I suggest to correct the documentation and perform the search of usage of this
function. This search might clear some not yet registered bugs.
TagsNo tags attached.
Test case number

Attached Files

  • TCollection_IndexedDataMap.cdl (6,026 bytes)
  • TCollection_DataMap.cdl (5,340 bytes)

Relationships

duplicate of 0003294 closedabv CDL discription of TCollection_DataMap::Bind() mismatch the real method behavior 

Activities

2003-10-22 16:00

 

TCollection_IndexedDataMap.cdl (6,026 bytes)

2003-10-23 12:18

 

TCollection_DataMap.cdl (5,340 bytes)

abv

2005-09-12 10:27

manager   ~0000321

*** Bug 3294 has been marked as a duplicate of this bug. ***

Issue History

Date Modified Username Field Change
2001-12-05 12:51 bugmaster QAContact in development version => dle
2001-12-05 12:51 bugmaster Category => DOC
2001-12-05 12:51 bugmaster Status new => assigned
2001-12-05 12:51 bugmaster Assigned To bugmaster =>
2002-03-01 14:11 dle-old Status assigned => resolved
2002-03-01 14:12 bugmaster Status resolved => verified
2002-08-02 18:49 bugmaster Status verified => closed
2002-08-02 18:49 bugmaster Resolution @0@ => fixed
2003-10-22 18:03 atp CC => imv
2005-09-12 10:27 abv CC => eap
2011-08-02 11:19 bugmaster Category OCCT:DOC => OCCT:Documentation