View Issue Details

IDProjectCategoryView StatusLast Update
0033443CommunityOCCT:Data Exchangepublic2023-08-07 15:46
Reporterborm Assigned Tobugmaster  
PrioritynormalSeveritycrash 
Status closedResolutionduplicate 
PlatformWindowsOSVC++ 2022 
Product Version7.7.1 
Target VersionUnscheduled 
Summary0033443: Data Exchange - Crash by reading STEP file
DescriptionCrash by reading attached STEP file. We read the file as follows:

STEPCAFControl_Reader stepReader;
stepReader.SetColorMode(Standard_True);
stepReader.SetNameMode(Standard_True);
const auto result = stepReader.Perform(fileName, pOcctDocument);
TagsNo tags attached.
Test case number

Attached Files

  • ABR_BJK.STEP (82,343 bytes)

Relationships

duplicate of 0033444 newika Data Exchange - Crash by reading STEP file 

Activities

borm

2023-08-07 11:37

reporter  

ABR_BJK.STEP (82,343 bytes)

dpasukhi

2023-08-07 11:44

developer   ~0113890

Dear bugmaster, please close the issue.
Problam was dublicated with 0033444 as the main problem with Mantis file attachment

vglukhik

2023-08-07 15:46

administrator   ~0113901

Duplicated with 33444

Issue History

Date Modified Username Field Change
2023-08-07 11:37 borm New Issue
2023-08-07 11:37 borm Assigned To => ika
2023-08-07 11:37 borm File Added: ABR_BJK.STEP
2023-08-07 11:39 dpasukhi Target Version => Unscheduled
2023-08-07 11:39 dpasukhi Summary Crash by reading STEP file => Data Exchange - Crash by reading STEP file
2023-08-07 11:41 dpasukhi Severity major => crash
2023-08-07 11:43 dpasukhi Relationship added duplicate of 0033444
2023-08-07 11:44 dpasukhi Assigned To ika => bugmaster
2023-08-07 11:44 dpasukhi Status new => feedback
2023-08-07 11:44 dpasukhi Note Added: 0113890
2023-08-07 15:46 vglukhik Status feedback => closed
2023-08-07 15:46 vglukhik Resolution open => duplicate
2023-08-07 15:46 vglukhik Note Added: 0113901