View Issue Details

IDProjectCategoryView StatusLast Update
0033244Open CASCADEOCCT:Modeling Algorithmspublic2022-12-18 18:46
Reporteratereshi Assigned Toifv  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Target Version7.7.1 
Summary0033244: Modeling Algorithms - Surface-surface intersection produces the double curves
DescriptionDue to hard setted angular precision in the intersection function the last gives double curves in some borderline cases.
Steps To Reproduce
pload MODELING
binrestore [locate_data 31805_con_surf.brep] y
explode y
mksurf S1 y_1
mksurf S2 y_2
intersect r S1 S2
intersect r S2 S1

TagsNo tags attached.
Test case numberlowalgos/intss/bug33244

Attached Files

  • 31805_con_surf.brep (4,338 bytes)

Activities

atereshi

2022-12-01 17:35

developer   ~0112453

31805_con_surf.brep (4,338 bytes)

git

2022-12-01 18:35

administrator   ~0112454

Branch CR33244 has been created by atereshi.

SHA-1: d71ea32c6f7b5f689b76f35f16c377c3938c62cd


Detailed log of new commits:

Author: atereshi
Date: Tue Nov 29 12:27:13 2022 +0300

    0033244: Modeling Algorithms - Surface-surface intersection produces the double curves
    
    Problem: Due to hard setted angular tolerance in the intersection function the last gives double curves in some borderline cases.
    Change:
     Added the possibility to set angular tolerance to the intersection function.
     Added angular tolerance parameter to DRAW intersect function.
    Result: The user can manage the angular tolerance.

git

2022-12-01 21:17

administrator   ~0112458

Branch CR33244 has been updated forcibly by atereshi.

SHA-1: 627102d83fb49f4dbeb40fbfee763c412c30f836

atereshi

2022-12-01 23:55

developer   ~0112460

http://jenkins-test-10.nnov.opencascade.com/view/CR33244-CR33244-atereshi/view/COMPARE/
As I see from test results:
- parasolid doc_1 A4 and parasolid doc_2 A 1 have improvements on Linux platform;
- test dtk xt B3 has been failed on both platforms and this is the subject of the proceedings;
- other tests are unstable or failed due to timeout (this is know "night" problem of the testing system).

git

2022-12-06 11:44

administrator   ~0112502

Branch CR33244_1 has been created by ifv.

SHA-1: a485847034c6cb9b748902371888e520f3be5aea


Detailed log of new commits:

Author: ifv
Date: Tue Dec 6 10:12:22 2022 +0300

    0033244: Modeling Algorithms - Surface-surface intersection produces the double curves

git

2022-12-08 17:25

administrator   ~0112541

Branch CR33244_1 has been updated forcibly by ifv.

SHA-1: 9acc02d73075315f4ec85b71f4a15de95dcae619

git

2022-12-12 10:37

administrator   ~0112609

Branch CR33244_1 has been updated forcibly by ifv.

SHA-1: 961a306dc4468a3ce5ef1114cfa7389d126b3ca1

ifv

2022-12-13 15:49

developer   ~0112615

Branch CR33244_1 is ready for review

Test results:
http://jenkins-test-10.nnov.opencascade.com/view/CR33244_1-master-ifv/view/COMPARE/

Two regressions concerning memory leaks on Linux do not seem to be caused by this fix.

emv

2022-12-14 09:50

developer   ~0112619

Reviewed. Please integrate CR33244_1 into OCCT.

vglukhik

2022-12-18 18:30

administrator   ~0112670

Combination -
OCCT branch : IR-2022-12-16
Products branch : IR-2022-12-16
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Ubuntu2004-64:
OCCT
Total CPU difference: 17934.520000000408 / 18702.49000000009 [-4.11%]
Products
Total CPU difference: 11699.450000000132 / 11696.740000000156 [+0.02%]
Windows-64-VC142:
OCCT
Total CPU difference: 14250.46875 / 14555.859375 [-2.10%]
Products
Total CPU difference: 14427.09375 / 14146.359375 [+1.98%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-12-18 18:42

administrator   ~0112673

Branch CR33244 has been deleted by mnt.

SHA-1: 627102d83fb49f4dbeb40fbfee763c412c30f836

git

2022-12-18 18:46

administrator   ~0112674

Branch CR33244_1 has been deleted by mnt.

SHA-1: 961a306dc4468a3ce5ef1114cfa7389d126b3ca1

Related Changesets

occt: master 961a306d

2022-12-06 10:12:22

ifv

Details Diff
0033244: Modeling Algorithms - Surface-surface intersection produces the double curves

IntAna_QuadQuadGeo.cxx - estimation of angular tolerance is added for case cone-cone

tests/lowalgos/intss/bug33244 - new test case added
Affected Issues
0033244
mod - src/IntAna/IntAna_QuadQuadGeo.cxx Diff File
add - tests/lowalgos/intss/bug33244 Diff File

Issue History

Date Modified Username Field Change
2022-12-01 17:30 atereshi New Issue
2022-12-01 17:30 atereshi Assigned To => msv
2022-12-01 17:35 atereshi Note Added: 0112453
2022-12-01 17:35 atereshi File Added: 31805_con_surf.brep
2022-12-01 18:35 git Note Added: 0112454
2022-12-01 21:17 git Note Added: 0112458
2022-12-01 23:55 atereshi Note Added: 0112460
2022-12-02 10:47 szy Assigned To msv => ifv
2022-12-02 10:47 szy Status new => assigned
2022-12-06 11:44 git Note Added: 0112502
2022-12-08 17:25 git Note Added: 0112541
2022-12-12 10:37 git Note Added: 0112609
2022-12-13 15:40 ifv Test case number => lowalgos/intss/bug33244
2022-12-13 15:49 ifv Assigned To ifv => msv
2022-12-13 15:49 ifv Status assigned => resolved
2022-12-13 15:49 ifv Note Added: 0112615
2022-12-13 18:58 msv Assigned To msv => emv
2022-12-14 09:50 emv Assigned To emv => bugmaster
2022-12-14 09:50 emv Status resolved => reviewed
2022-12-14 09:50 emv Note Added: 0112619
2022-12-18 18:30 vglukhik Status reviewed => tested
2022-12-18 18:30 vglukhik Note Added: 0112670
2022-12-18 18:37 ifv Changeset attached => occt master 961a306d
2022-12-18 18:37 ifv Assigned To bugmaster => ifv
2022-12-18 18:37 ifv Status tested => verified
2022-12-18 18:37 ifv Resolution open => fixed
2022-12-18 18:42 git Note Added: 0112673
2022-12-18 18:46 git Note Added: 0112674