View Issue Details

IDProjectCategoryView StatusLast Update
0033235Open CASCADEOCCT:Configurationpublic2023-01-13 04:45
Reporterdpasukhi Assigned Todpasukhi  
PriorityhighSeverityminor 
Status verifiedResolutionfixed 
Target Version7.7.1 
Summary0033235: Configuration - Solving the problem with static building of ExpToCasExe
DescriptionWhen build OCCT 7.7 with static option build breaks with error.
It is necessary to update configuration to fix the problem
Steps To ReproduceNot possible
TagsNo tags attached.
Test case number

Relationships

related to 0031481 verifiedabv Data Exchange - provide parser of STEP EXPRESS schema for generation of new STEP entities 
related to 0033241 newmsv Foundation Classes - unrealized support for socket type of OSD_File leads to linking of an unused winsock library 

Activities

git

2022-11-30 00:29

administrator   ~0112411

Branch CR33235 has been created by dpasukhi.

SHA-1: a9ab186bc45795c140259a5d02848bf689debe1a


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 29 21:27:40 2022 +0000

    0033235: Configuration - Solving the problem with static building of ExpToCasExe
    
    Added new dependency to ExpToCasExe - CSF_wsock32 (on Win only)

dpasukhi

2022-11-30 01:15

developer   ~0112413

Dear smoskvin,
please review CR33235

Please make attention, problem represen only with static build option on Win OS. (that not check in Jenkins)
I test on VS19, C++11 with static flag. It is work correct.
The reason of problem is build project as exe. The same problem was in few exe projects in PROD repo.
The fix is add directly dependency.

Shared build is OK, see:
http://jenkins-test-10.nnov.opencascade.com/view/CR33235-master-dpasukhi/view/OCCT%20compile/

dpasukhi

2022-12-02 19:43

developer   ~0112484

To integration:
OCCT - CR33235

git

2022-12-11 22:37

administrator   ~0112583

Branch CR33235 has been deleted by mnt.

SHA-1: a9ab186bc45795c140259a5d02848bf689debe1a

Related Changesets

occt: master 768f3a4a

2022-11-30 00:27:40

dpasukhi


Committer: smoskvin Details Diff
0033235: Configuration - Solving the problem with static building of ExpToCasExe

Added new dependency to ExpToCasExe - CSF_wsock32 (on Win only)
Affected Issues
0033235
mod - src/ExpToCasExe/EXTERNLIB Diff File

Issue History

Date Modified Username Field Change
2022-11-30 00:25 dpasukhi New Issue
2022-11-30 00:25 dpasukhi Assigned To => dpasukhi
2022-11-30 00:25 dpasukhi Priority normal => high
2022-11-30 00:29 git Note Added: 0112411
2022-11-30 00:31 dpasukhi Relationship added related to 0031481
2022-11-30 00:43 dpasukhi Status new => assigned
2022-11-30 01:15 dpasukhi Assigned To dpasukhi => smoskvin
2022-11-30 01:15 dpasukhi Status assigned => resolved
2022-11-30 01:15 dpasukhi Steps to Reproduce Updated
2022-11-30 01:15 dpasukhi Note Added: 0112413
2022-11-30 15:40 atereshi Relationship added related to 0033241
2022-12-02 19:43 dpasukhi Assigned To smoskvin => bugmaster
2022-12-02 19:43 dpasukhi Status resolved => reviewed
2022-12-02 19:43 dpasukhi Note Added: 0112484
2022-12-05 00:22 smoskvin Status reviewed => tested
2022-12-05 00:25 smoskvin Changeset attached => occt master 768f3a4a
2022-12-05 00:25 dpasukhi Assigned To bugmaster => dpasukhi
2022-12-05 00:25 dpasukhi Status tested => verified
2022-12-05 00:25 dpasukhi Resolution open => fixed
2022-12-11 22:37 git Note Added: 0112583
2023-01-13 04:45 vglukhik Project Internal => Open CASCADE