View Issue Details

IDProjectCategoryView StatusLast Update
0033223Open CASCADEPRODUCTS:Canonical Recognitionpublic2022-12-11 22:37
Reportermsv Assigned Tomsv  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version7.7.0 
Target Version7.7.1 
Summary0033223: [Regression to 7.6.0] Canonical Recognition - SIGFPE when recognizing the given shape
DescriptionWith the attached face the algorithm generates SIGFPE exception. The face is based on the surface of linear extrusion of an circular arc-wise bspline curve.
It is needed to protect the algorithm from evaluation of surface values at infinite bounds.
Steps To Reproducepload -DrawPluginProducts CRDRAW
binrestore ll2_so2736.bbrep a
CRcanonical r a
TagsNo tags attached.
Test case number

Attached Files

  • ll2_so2736.bbrep (203,195 bytes)

Activities

msv

2022-11-26 11:45

developer   ~0112319

ll2_so2736.bbrep (203,195 bytes)

msv

2022-11-26 12:47

developer   ~0112320

I think the patches #28620 and #32995 are the source of regression.

msv

2022-11-27 01:23

developer   ~0112329

Branch CR33223 in products is ready for review.
Test job is http://jenkins-test-occt/view/master-CR33223-MSV/view/COMPARE/.

ifv

2022-11-28 13:11

developer   ~0112353

Branch CR33223 in Products repository seems to be valid

Branches for integration:
OCCT - not
Products - CR33223

Related Changesets

occt-products: master c686cf6b

2022-11-26 11:47:11

msv


Committer: smoskvin Details Diff
0033223: Canonical Recognition - SIGFPE when recognizing the given shape Affected Issues
0033223
mod - blob Diff File
mod - src/ShapeConvert/ShapeConvert_GeomToAnalyticalModification.cxx Diff File

Issue History

Date Modified Username Field Change
2022-11-26 11:44 msv New Issue
2022-11-26 11:44 msv Assigned To => msv
2022-11-26 11:45 msv Note Added: 0112319
2022-11-26 11:45 msv File Added: ll2_so2736.bbrep
2022-11-26 11:46 msv Steps to Reproduce Updated
2022-11-26 12:44 msv Summary Canonical Recognition - SIGFPE when recognizing the given shape => [Regression to 7.6.0] Canonical Recognition - SIGFPE when recognizing the given shape
2022-11-26 12:47 msv Note Added: 0112320
2022-11-26 13:04 msv Product Version => 7.7.0
2022-11-27 01:23 msv Assigned To msv => ifv
2022-11-27 01:23 msv Status new => resolved
2022-11-27 01:23 msv Note Added: 0112329
2022-11-28 13:11 ifv Assigned To ifv => bugmaster
2022-11-28 13:11 ifv Status resolved => reviewed
2022-11-28 13:11 ifv Note Added: 0112353
2022-12-05 00:23 smoskvin Status reviewed => tested
2022-12-05 00:25 smoskvin Changeset attached => occt-products master c686cf6b
2022-12-05 00:25 msv Assigned To bugmaster => msv
2022-12-05 00:25 msv Status tested => verified
2022-12-05 00:25 msv Resolution open => fixed