View Issue Details

IDProjectCategoryView StatusLast Update
0033070Open CASCADEPRODUCTS:IFC Importpublic2022-11-20 22:32
Reporteratychini Assigned Toatychini  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version7.6.3 
Target Version7.7.0 
Summary0033070: IFC Import - Upgrade IfcOpenShell to the new version
DescriptionThe last commit made by ifc developers in occ@git.nnov.opencascade.com:ifc4.git was done in 2018. Since that moment it has been improved many times (for example, more than 400 commits in IfcGeom) (https://github.com/IfcOpenShell/IfcOpenShell); therefore we should upgrade the repository to avoid possible bugs.
Steps To ReproduceNot required
TagsNo tags attached.
Test case number

Attached Files

  • 33070_Tests_Comparison.xlsx (20,599 bytes)

Activities

atychini

2022-10-05 22:08

developer   ~0111402

Working on transformation optimisation
Cleaning up the code

git

2022-10-11 16:09

administrator   ~0111494

Branch CR33070 has been created by atychini.

SHA-1: 0b4962a7f04caef12d090d087b7196cefde0703c


No new revisions were added by this update.

atychini

2022-10-11 16:23

developer   ~0111496

Last edited: 2022-11-06 21:21

git

2022-11-03 14:01

administrator   ~0111898

Branch CR33070 has been updated by atychini.

SHA-1: d404757de01e2cd8704349daf5030ac2a8905a8e


No new revisions were added by this update.

atychini

2022-11-06 21:21

developer   ~0111905

Last edited: 2022-11-07 17:26

dpasukhi

2022-11-07 17:03

developer   ~0111921

Dear @atychini, can you update your table with a new column with % time increment?
It's more convenient to understand.

atychini

2022-11-07 17:26

developer   ~0111923

Excel table with results of testing Ifc files on Master version and on 33070
33070_Tests_Comparison.xlsx (20,599 bytes)

atychini

2022-11-08 13:48

developer   ~0111938

Dear @gka, please review branches CR33070 inside occt-products and ifc4 repostitories
All tests are ok, see:
http://jenkins-test-08.nnov.opencascade.com/view/CR33070-CR33070-atychini/view/COMPARE/

gka

2022-11-10 19:23

developer   ~0111996

Last edited: 2022-11-10 20:44

Dear Alexey.

Could you please initialize filed IFCCAFControl_Reader::myBreakLPType in the constructor of the class.
Could you please explain regression by CHECKSHAPE in the tests:
tests/ifc/doc_1/A1, tests/ifc/doc_1/A2 and ...
Seems that listed tests contains errors by checkshape due to building triangulation instead of the surface.
Number of the checkshapes in the master and in the current branch is the same.

gka

2022-11-10 20:40

developer   ~0111998

Branch CR33070 in the occ@git.nnov.opencascade.com:ifc4.git

Why Standard_EXPORT instead of the IFC_PARSE was used in the file ifc_geom/schema_agnostic/Kernel.h
 Standard_EXPORT static bool axis_equal(const gp_Ax3& a, const gp_Ax3& b, double tolerance)

atychini

2022-11-11 11:05

developer   ~0112014

Dear gka, remarks have been fixed, tests are still ok:
http://jenkins-test-08.nnov.opencascade.com/view/CR33070-CR33070-atychini/view/COMPARE/

gka

2022-11-11 11:36

developer   ~0112018

Branches CR33070 from OCCT Products internal repository and CR33070 from occ@git.nnov.opencascade.com:ifc4.git repository were reviewed

git

2022-11-20 22:31

administrator   ~0112189

Branch CR33070 has been deleted by mnt.

SHA-1: d404757de01e2cd8704349daf5030ac2a8905a8e

Related Changesets

occt-products: master 33851e2b

2022-07-30 22:05:39

atychini


Committer: smoskvin Details Diff
0033070: IFC Import - Upgrade IfcOpenShell to the new version

Upgrading Ifc product to the newer IfcOpenShell API.
Affected Issues
0033070
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - diff Diff File
mod - src/IFCCAFControl/IFCCAFControl_Reader.cxx Diff File
mod - src/IFCCAFControl/IFCCAFControl_Reader.hxx Diff File
mod - tests/ifc/doc_1/A1 Diff File
mod - tests/ifc/doc_1/A2 Diff File
mod - tests/ifc/doc_1/A7 Diff File
mod - tests/ifc/doc_1/A8 Diff File
mod - tests/ifc/doc_1/A9 Diff File
mod - tests/ifc/doc_1/B1 Diff File
mod - tests/ifc/doc_1/B3 Diff File
mod - tests/ifc/doc_1/B4 Diff File
mod - tests/ifc/doc_1/B5 Diff File
mod - tests/ifc/doc_1/B6 Diff File
mod - tests/ifc/doc_1/B7 Diff File
mod - tests/ifc/doc_1/B8 Diff File
mod - tests/ifc/doc_1/C5 Diff File
mod - tests/ifc/end Diff File

Issue History

Date Modified Username Field Change
2022-07-21 09:38 atychini New Issue
2022-07-21 09:38 atychini Assigned To => atychini
2022-07-21 09:48 atychini Description Updated
2022-08-01 14:33 atychini Summary Upgrade IfcOpenShell to the new version => IFC Import - Upgrade IfcOpenShell to the new version
2022-09-22 11:08 szy Status new => assigned
2022-10-05 22:08 atychini Note Added: 0111402
2022-10-11 16:09 git Note Added: 0111494
2022-10-11 16:23 atychini Note Added: 0111496
2022-10-11 16:23 atychini File Added: Test_Comparison.xlsx
2022-11-03 14:01 git Note Added: 0111898
2022-11-06 21:19 atychini Note Edited: 0111496
2022-11-06 21:19 atychini File Deleted: Test_Comparison.xlsx
2022-11-06 21:21 atychini Note Added: 0111905
2022-11-06 21:21 atychini File Added: 33070_Tests_Comparison.xlsx
2022-11-06 21:21 atychini Note Edited: 0111496
2022-11-07 17:03 dpasukhi Note Added: 0111921
2022-11-07 17:26 atychini File Deleted: 33070_Tests_Comparison.xlsx
2022-11-07 17:26 atychini Note Edited: 0111905
2022-11-07 17:26 atychini Note Added: 0111923
2022-11-07 17:26 atychini File Added: 33070_Tests_Comparison.xlsx
2022-11-08 13:47 atychini Assigned To atychini => gka
2022-11-08 13:47 atychini Status assigned => resolved
2022-11-08 13:47 atychini Steps to Reproduce Updated
2022-11-08 13:47 atychini Steps to Reproduce Updated
2022-11-08 13:48 atychini Note Added: 0111938
2022-11-10 19:23 gka Note Added: 0111996
2022-11-10 19:24 gka Assigned To gka => atychini
2022-11-10 19:24 gka Status resolved => assigned
2022-11-10 20:40 gka Note Added: 0111998
2022-11-10 20:44 gka Note Edited: 0111996
2022-11-11 11:05 atychini Assigned To atychini => gka
2022-11-11 11:05 atychini Status assigned => resolved
2022-11-11 11:05 atychini Steps to Reproduce Updated
2022-11-11 11:05 atychini Note Added: 0112014
2022-11-11 11:36 gka Assigned To gka => bugmaster
2022-11-11 11:36 gka Status resolved => reviewed
2022-11-11 11:36 gka Note Added: 0112018
2022-11-20 21:15 smoskvin Status reviewed => tested
2022-11-20 22:08 smoskvin Changeset attached => occt-products master 33851e2b
2022-11-20 22:08 atychini Assigned To bugmaster => atychini
2022-11-20 22:08 atychini Status tested => verified
2022-11-20 22:08 atychini Resolution open => fixed
2022-11-20 22:31 git Note Added: 0112189