View Issue Details

IDProjectCategoryView StatusLast Update
0033054Open CASCADEOCCT:Configurationpublic2022-07-10 12:09
Reporterkgv Assigned Tokgv  
PrioritynormalSeverityblock 
Status verifiedResolutionfixed 
Product Version7.7.0 
Target Version7.7.0 
Summary0033054: Configuration - link errors due to missing references to new TKXDE toolkit
DescriptionCurrent development branch cannot be build with `genproj`due to missing references caused by #32821:
Severity	Code	Description	Project	File	Line	Suppression State
Error	LNK1181	cannot open input file 'TKSTL.lib'	TKXSDRAW	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDE.lib'	TKSTL	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDE.lib'	TKXDEIGES	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDE.lib'	TKRWMesh	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDE.lib'	TKXDESTEP	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDE.lib'	TKVRML	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDE.lib'	TKXDEDRAW	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	
Error	LNK1181	cannot open input file 'TKXDESTEP.lib'	TKQADraw	C:\occt-tmp.git\adm\msvc\vc14\LINK	1	


In addition, building of DRAWEXE fails withing static build CMake configuration due to linkage errors.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberN/A

Activities

git

2022-07-06 22:07

administrator   ~0109629

Branch CR33054 has been created by kgv.

SHA-1: 1d02b6fd2901d57bd23249a50c2a58e50df4aca8


Detailed log of new commits:

Author: kgv
Date: Wed Jul 6 21:32:46 2022 +0300

    0033054: Configuration - link errors due to missing references to new TKXDE toolkit
    
    src/OS/DataExchange.tcl - added missing new toolkits.
    TKRWMesh - added missing reference to TKTopAlgo (for using BRepLib_PointCloudShape).
    Removed redundant dependency from TKBinXCAF.
    THE_CONFIGURATION_SCOPE definition has been corrected to postpoine calling constructor till the first variable usage.

git

2022-07-06 22:57

administrator   ~0109634

Branch CR33054 has been updated forcibly by kgv.

SHA-1: 275479297671c6774c39e271bf03a7a78b62e77a

kgv

2022-07-06 23:59

developer   ~0109636

Please raise the patch
- OCCT: branch CR33054.

http://jenkins-test-occt.nnov.opencascade.com/view/CR33054-master-KGV/view/OCCT%20compile/

smoskvin

2022-07-10 11:21

administrator   ~0109710

Combination -
OCCT branch : IR-2022-07-08
master SHA - changes and them, and you can discard any commits you make in this
33c8a72788661285860902f261062e39f32a2d46
changes and them, and you can discard any commits you make in this
e0ceb716c70188b98130b1550914140d0502a6f9
Products branch : IR-2022-07-08 SHA - 79a687f1cd4081ec53ec08c201360e89fce62abc
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18685.930000000586 / 18908.870000000694 [-1.18%]
Products
Total CPU difference: 11796.890000000125 / 11832.130000000114 [-0.30%]
Windows-64-VC14:
OCCT
Total CPU difference: 20784.828125 / 20752.59375 [+0.16%]
Products
Total CPU difference: 13361.3125 / 13368.90625 [-0.06%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-07-10 12:09

administrator   ~0109742

Branch CR33054 has been deleted by mnt.

SHA-1: 275479297671c6774c39e271bf03a7a78b62e77a

Related Changesets

occt: master dee5eb82

2022-07-06 21:32:46

kgv


Committer: smoskvin Details Diff
0033054: Configuration - link errors due to missing references to new TKXDE toolkit

src/OS/DataExchange.tcl - added missing new toolkits.
TKRWMesh - added missing reference to TKTopAlgo (for using BRepLib_PointCloudShape).
Removed redundant dependency from TKBinXCAF.
DRAWEXE - added missing references for a static build.

THE_CONFIGURATION_SCOPE definition has been corrected to postpoine calling constructor till the first variable usage.
Fixed compiler warning at SelectMgr_Frustum<3>::DumpJson() due to misleading Standard_EXPORT for an inline template method definition.
Affected Issues
0033054
mod - src/DE/DE_Wrapper.cxx Diff File
mod - src/DEBRepCascade/DEBRepCascade_ConfigurationNode.cxx Diff File
mod - src/DEXCAFCascade/DEXCAFCascade_ConfigurationNode.cxx Diff File
mod - src/DRAWEXE/EXTERNLIB_STATIC Diff File
mod - src/IGESCAFControl/IGESCAFControl_ConfigurationNode.cxx Diff File
mod - src/OS/DataExchange.tcl Diff File
mod - src/RWGltf/RWGltf_ConfigurationNode.cxx Diff File
mod - src/RWObj/RWObj_ConfigurationNode.cxx Diff File
mod - src/RWStl/RWStl_ConfigurationNode.cxx Diff File
mod - src/SelectMgr/SelectMgr_Frustum.hxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_ConfigurationNode.cxx Diff File
mod - src/TKRWMesh/EXTERNLIB Diff File
mod - src/TKSTL/EXTERNLIB Diff File
mod - src/TKVRML/EXTERNLIB Diff File
mod - src/TKXDECascade/EXTERNLIB Diff File
mod - src/TKXDEIGES/EXTERNLIB Diff File
mod - src/TKXDESTEP/EXTERNLIB Diff File
mod - src/Vrml/Vrml_ConfigurationNode.cxx Diff File

Issue History

Date Modified Username Field Change
2022-07-06 21:24 kgv New Issue
2022-07-06 21:24 kgv Assigned To => bugmaster
2022-07-06 21:24 kgv Severity minor => block
2022-07-06 21:24 kgv Description Updated
2022-07-06 21:30 kgv Summary Configuration - link errors due to missing references => Configuration - link errors due to missing references to new TKXDE toolkit
2022-07-06 21:30 kgv Test case number => N/A
2022-07-06 22:07 git Note Added: 0109629
2022-07-06 22:57 git Note Added: 0109634
2022-07-06 23:59 kgv Status new => resolved
2022-07-06 23:59 kgv Note Added: 0109636
2022-07-07 00:00 kgv Status resolved => reviewed
2022-07-07 00:01 kgv Description Updated
2022-07-07 00:01 kgv Description Updated
2022-07-10 11:21 smoskvin Status reviewed => tested
2022-07-10 11:21 smoskvin Note Added: 0109710
2022-07-10 12:03 smoskvin Changeset attached => occt master dee5eb82
2022-07-10 12:03 kgv Assigned To bugmaster => kgv
2022-07-10 12:03 kgv Status tested => verified
2022-07-10 12:03 kgv Resolution open => fixed
2022-07-10 12:09 git Note Added: 0109742