View Issue Details

IDProjectCategoryView StatusLast Update
0032993Open CASCADEOCCT:Codingpublic2022-06-14 13:44
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeveritytrivial 
Status closedResolutionduplicate 
Product Version7.4.0 
Target Version7.7.0 
Summary0032993: Coding Rules - compilation error on including IntAna_Quadric.hxx
DescriptionIncluding IntAna_Quadric.hxx header produces compilation errors:
Severity	Code	Description	Project	File	Line	Suppression State
Error	C4430	missing type specifier - int assumed. Note: C++ does not support default-int	FAIprs	inc\IntAna_Quadric.hxx	42	


Regression after 0029807.
Steps To ReproduceN/A
TagsNo tags attached.
Test case number

Relationships

duplicate of 0032969 verifiedkgv Coding - get rid of unused headers [IMeshData to PLib] 
child of 0029807 closedbugmaster [Regression to 7.0.0] Impossible to cut cone from prism 

Activities

kgv

2022-05-30 23:03

developer   ~0108749

Already fixed by patch for 0032969, please close.

Issue History

Date Modified Username Field Change
2022-05-30 22:51 kgv New Issue
2022-05-30 22:51 kgv Assigned To => kgv
2022-05-30 23:02 kgv Relationship added has duplicate 0032969
2022-05-30 23:03 kgv Assigned To kgv => bugmaster
2022-05-30 23:03 kgv Status new => feedback
2022-05-30 23:03 kgv Note Added: 0108749
2022-05-30 23:04 kgv Relationship added child of 0029807
2022-05-30 23:04 kgv Product Version 7.6.0 => 7.4.0
2022-05-30 23:04 kgv Description Updated
2022-06-14 13:44 azv Status feedback => closed
2022-06-14 13:44 azv Resolution open => duplicate
2022-06-14 13:44 azv Relationship replaced duplicate of 0032969