View Issue Details

IDProjectCategoryView StatusLast Update
0032965Open CASCADEPRODUCTS:PMI Visualizationpublic2022-12-05 00:25
Reporterdbv Assigned Todbv  
PrioritynormalSeveritymajor 
Status verifiedResolutionfixed 
Product Version7.6.0 
Target Version7.7.0 
Summary0032965: PMI Visualization - PMIVis_TOT_Vectorized text regressions
DescriptionPMIVisTest does not currently have tests for PMIVis_TOT_Vectorized type of text. Moreover, it is not even possible to use this functionality in tests. This resulted in following regressions:
- Non-zoomable text is still zoomable and drawn in the wrong place;
- Flippable text is not flipping;

This functionality worked in the 7.4.0 version. Reproduced on master branch.
Steps To Reproduce#################################################################################
test non-zoomable
#################################################################################
pload VISUALIZATION
pload MODELING
catch {pload -DrawPluginProducts PMIVIS}

vclose all
vinit
box aBox 600 600 600
vdisplay aBox

PMIparams -textType vectorized
PMIparams text -size 40
PMIparams arrow -length 15
PMIdimension lendim length -firstpnt 600 0 600 -secondpnt 600 600 600 -textpnt 650 300 600 -plane 0 0 1 1 0 0 -valign center -value 42 -padding 0

#################################################################################
test flipping
#################################################################################
pload VISUALIZATION
pload MODELING
catch {pload -DrawPluginProducts PMIVIS}

vclose all
vinit
box aBox 600 600 600
vdisplay aBox

PMIparams -textType vectorized
PMIparams text -size 40
PMIparams arrow -length 15
PMIdimension lendim length -firstpnt 600 0 600 -secondpnt 600 600 600 -textpnt 650 300 600 -plane 0 0 1 1 0 0 -valign center -value 42 -padding 0 -zoomable
TagsNo tags attached.
Test case number

Attached Files

  • non-zoomable_issue.png (33,656 bytes)
  • flippable_issue.png (26,967 bytes)
  • bug32965_non_zoomable.png (4,489 bytes)
  • bug32965_flipping.png (4,382 bytes)

Activities

dbv

2022-05-11 00:34

developer  

non-zoomable_issue.png (33,656 bytes)
flippable_issue.png (26,967 bytes)

git

2022-05-16 12:11

administrator   ~0108440

Branch CR32965 has been created by svetlana.shutina_170290.

SHA-1: 27560559d31fe2fffcfb51342ea96800a1d84806


Detailed log of new commits:

Author: sshutina
Date: Mon May 16 12:11:15 2022 +0300

    draw shaded shape in the required group
    
     0032965: PMIVis - PMIVis_TOT_Vectorized text regressions

git

2022-10-20 15:16

administrator   ~0111690

Branch CR32965 has been updated forcibly by mzernova.

SHA-1: 7aa26fedcf462cb1b3b2ba506e3b3f91f492df4b

mzernova

2022-10-20 15:18

developer   ~0111691

Branches
OCCT: CR32965
OCCT Products: CR32965_1

mzernova

2022-10-20 15:30

developer   ~0111693

http://jenkins-test-occt.nnov.opencascade.com/view/CR32965-CR32965_1-mzernova/

mzernova

2022-10-21 10:23

developer   ~0111704

bug32965_non_zoomable.png (4,489 bytes)
bug32965_flipping.png (4,382 bytes)

szy

2022-10-25 10:42

manager   ~0111737

Find, please somebody for reviewing the issue.

vpozdyayev

2022-10-25 21:40

administrator   ~0111745

[PMIVis_DimensionLabel.cxx] As far as I can tell, the intent of the two "SetFlippingOptions" invocations is to set up the flipping, configure locations, then tear it down. If so, the invocations should be symmetrical: they should work with the same group under the same conditions (up to having both instances start with the same if-conditions).

I also recommend splitting the test, since we are effectively testing two different features.

git

2022-11-18 13:05

administrator   ~0112171

Branch CR32965 has been updated forcibly by mzernova.

SHA-1: e415bc40e7f09869b1b1a9821e38e01aa4f4d1ea

mzernova

2022-11-18 17:22

developer   ~0112173

http://jenkins-test-occt.nnov.opencascade.com/view/CR32965-CR32965_1-mzernova/view/ALL/

mzernova

2022-11-18 17:23

developer   ~0112174

Ready for review

git

2022-11-30 16:34

administrator   ~0112426

Branch CR32965 has been updated forcibly by mzernova.

SHA-1: 69f9bd101468116621b31f17f125035e8fa6cf3e

Related Changesets

occt-products: master d0858cb8

2022-05-10 18:07:54

dbv


Committer: smoskvin Details Diff
0032965: PMIVis - PMIVis_TOT_Vectorized text regressions

Draw the flipper, text and using trsf persistence in the one group
Added type of text option to PMIparams

Test case added: pmivis/bugs/bug32965
Affected Issues
0032965
mod - diff Diff File
mod - src/PMIVis/PMIVis_BRepTextManager.cxx Diff File
mod - src/PMIVis/PMIVis_ElementMinDistance.cxx Diff File
mod - src/PMIVis/PMIVis_SingleSegments.cxx Diff File
mod - src/PMIVisTest/PMIVisTest.cxx Diff File
add - tests/pmivis/bugs/bug32965 Diff File

occt: master 7eeb5d5f

2022-05-16 12:11:15

sshutina


Committer: smoskvin Details Diff
0032965: PMIVis - PMIVis_TOT_Vectorized text regressions

Added the ability to draw a shaded shape in the required group.
Affected Issues
0032965
mod - src/StdPrs/StdPrs_ShadedShape.cxx Diff File
mod - src/StdPrs/StdPrs_ShadedShape.hxx Diff File

Issue History

Date Modified Username Field Change
2022-05-11 00:34 dbv New Issue
2022-05-11 00:34 dbv Assigned To => nds
2022-05-11 00:34 dbv File Added: non-zoomable_issue.png
2022-05-11 00:34 dbv File Added: flippable_issue.png
2022-05-11 00:37 dbv Description Updated
2022-05-11 11:26 kgv Target Version => 7.7.0
2022-05-11 11:26 kgv Summary PMIVis_TOT_Vectorized text regressions => PMI Visualization - PMIVis_TOT_Vectorized text regressions
2022-05-16 12:11 git Note Added: 0108440
2022-08-17 12:02 kgv Target Version 7.7.0 => 7.8.0
2022-10-04 16:16 szy Target Version 7.8.0 => 7.7.0
2022-10-04 16:16 szy Assigned To nds => mzernova
2022-10-04 16:43 szy Status new => assigned
2022-10-20 15:16 git Note Added: 0111690
2022-10-20 15:18 mzernova Note Added: 0111691
2022-10-20 15:30 mzernova Note Added: 0111693
2022-10-20 15:30 mzernova Assigned To mzernova => vpozdyayev
2022-10-20 15:30 mzernova Status assigned => resolved
2022-10-21 10:23 mzernova Note Added: 0111704
2022-10-21 10:23 mzernova File Added: bug32965_non_zoomable.png
2022-10-21 10:23 mzernova File Added: bug32965_flipping.png
2022-10-25 10:42 szy Note Added: 0111737
2022-10-25 21:40 vpozdyayev Note Added: 0111745
2022-10-25 21:41 vpozdyayev Assigned To vpozdyayev => mzernova
2022-10-25 21:41 vpozdyayev Status resolved => assigned
2022-11-18 13:05 git Note Added: 0112171
2022-11-18 17:22 mzernova Note Added: 0112173
2022-11-18 17:23 mzernova Assigned To mzernova => vpozdyayev
2022-11-18 17:23 mzernova Status assigned => resolved
2022-11-18 17:23 mzernova Note Added: 0112174
2022-11-30 15:46 vpozdyayev Assigned To vpozdyayev => bugmaster
2022-11-30 15:46 vpozdyayev Status resolved => reviewed
2022-11-30 16:34 git Note Added: 0112426
2022-12-05 00:22 smoskvin Status reviewed => tested
2022-12-05 00:25 smoskvin Changeset attached => occt master 7eeb5d5f
2022-12-05 00:25 sshutina Assigned To bugmaster => sshutina
2022-12-05 00:25 sshutina Status tested => verified
2022-12-05 00:25 sshutina Resolution open => fixed
2022-12-05 00:25 smoskvin Changeset attached => occt-products master d0858cb8
2022-12-05 00:25 dbv Assigned To sshutina => dbv