View Issue Details

IDProjectCategoryView StatusLast Update
0032937Open CASCADEOCCT:Modeling Algorithmspublic2022-04-20 13:31
Reporteraml Assigned Toaml  
PrioritynormalSeverityminor 
Status closedResolutionwon't fix 
Product Version7.6.0 
Target Version7.7.0 
Summary0032937: Modeling Algorithms - cannot maximize attached shape
DescriptionThe attached shape cannot be maximized (unifysamedomain) for unknown reason.

When I pick several adjacent faces and call maximization operation, the result is valid.
explode a F
compound a_1 a_2 a_91 a_92 a_93 comp
unifysamedom r comp
see attachment - result_ok.png
Steps To Reproducerestore d:/bug32937.brep a
unifysamedom res a
don res; axo; fit
TagsNo tags attached.
Test case number

Attached Files

  • bug32937.brep (281,140 bytes)
  • result_ok.png (13,330 bytes)

Activities

aml

2022-04-20 10:34

developer   ~0108034

Attach model.
bug32937.brep (281,140 bytes)

aml

2022-04-20 10:51

developer   ~0108036

result_ok.png (13,330 bytes)

aml

2022-04-20 13:25

developer   ~0108043

I have found that some faces are flipped, so unification cannot be performed. So, let's close this issue.

aml

2022-04-20 13:25

developer   ~0108044

Dear bugmaster,

Please close this issue since it is caused by improper input shape.

Issue History

Date Modified Username Field Change
2022-04-20 10:33 aml New Issue
2022-04-20 10:33 aml Assigned To => azv
2022-04-20 10:33 aml Summary Modeling lgorithms - cannot maximize attached shape => Modeling Algorithms - cannot maximize attached shape
2022-04-20 10:33 aml Description Updated
2022-04-20 10:34 aml Note Added: 0108034
2022-04-20 10:34 aml File Added: bug32937.brep
2022-04-20 10:35 aml Steps to Reproduce Updated
2022-04-20 10:35 aml Steps to Reproduce Updated
2022-04-20 10:51 aml Description Updated
2022-04-20 10:51 aml Note Added: 0108036
2022-04-20 10:51 aml File Added: result_ok.png
2022-04-20 13:25 aml Note Added: 0108043
2022-04-20 13:25 aml Assigned To azv => bugmaster
2022-04-20 13:25 aml Status new => feedback
2022-04-20 13:25 aml Note Added: 0108044
2022-04-20 13:31 azv Assigned To bugmaster => aml
2022-04-20 13:31 azv Status feedback => closed
2022-04-20 13:31 azv Resolution open => won't fix