View Issue Details

IDProjectCategoryView StatusLast Update
0032915CommunityOCCT:Modeling Algorithmspublic2022-06-26 11:58
Reporterbglee Assigned Toazv  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
PlatformWindowsOSVC++ 2017 
Product Version7.4.0 
Target Version7.6.3 
Summary0032915: Geom2dAPI_InterCurveCurve, The algorithm lost an intersection point.
Description One intersection point is not found.
Steps To Reproduce
restore [locate_data_file bug32915.brep] e
mkcurve c3d e
plane p 0 0 1
project c2d c3d p

2dintersect c2d
# ERROR: 28 intersection points found, but 29 expected

v2d
2dfit
TagsNo tags attached.
Test case numberbugs/modalg_8/bug32915

Attached Files

  • lost intf point.png (16,795 bytes)
  • testBsplineCurve.BRep (1,491 bytes)

Activities

bglee

2022-04-07 10:19

reporter  

lost intf point.png (16,795 bytes)
testBsplineCurve.BRep (1,491 bytes)

git

2022-04-08 11:04

administrator   ~0107746

Branch CR32915 has been created by azv.

SHA-1: 2727e278150f2465a9aeb2025177781b047cfd9b


Detailed log of new commits:

Author: azv
Date: Fri Apr 8 11:03:53 2022 +0300

    0032915: Geom2dAPI_InterCurveCurve, The algorithm lost an intersection point.
    
    Get rid of strange code: preliminary check of self-intersections is made on a polygonal representation of a curve, it is able to find possible intersections, but after that it filter out segments neighbor to the pair of non-intersected segments.

git

2022-06-21 09:24

administrator   ~0109130

Branch CR32915 has been updated forcibly by azv.

SHA-1: a42c89dd6c1bf443189b3e8f56b24b93bcc6f0ee

git

2022-06-22 17:05

administrator   ~0109180

Branch CR32915 has been updated forcibly by azv.

SHA-1: ec0bd519f60c5fc062dc329acac761d1f0999d4a

git

2022-06-23 08:01

administrator   ~0109187

Branch CR32915 has been updated forcibly by azv.

SHA-1: 6676fbcb7c9c29842e6e91390030eaac56e486b1

git

2022-06-23 08:03

administrator   ~0109188

Branch CR32915 has been updated forcibly by azv.

SHA-1: b0b10491c2eff0c145117e1214be1c2c88051060

azv

2022-06-23 08:06

administrator   ~0109189

Dear Igor,

Please, review the following branches:
OCCT: CR32915
Products: NO
Test results: http://jenkins-test-occt/view/CR32915-master-AZV/view/COMPARE/

There were found several test cases which contain self-intersected edges, but which were not treated as failure before. These tests are marked BAD.

ifv

2022-06-23 11:44

developer   ~0109202

According to provided test results test de step_4 I1 is OK, but it must be BAD because has TODO. In my local PC I have BAD status of this test.
Probably there is instability. Please check.

azv

2022-06-23 17:21

administrator   ~0109207

Please, check the latest results. I've forgotten to rerun testing procedure after the last update of the patch.

ifv

2022-06-23 17:30

developer   ~0109208

Branch CR32915 seems to be valid

smoskvin

2022-06-26 11:28

administrator   ~0109240

Combination -
OCCT branch : IR-2022-06-24
master SHA - 63fa56bc83f2f366068fd2e67fce3ea4ff0c5ee3
e0ceb716c70188b98130b1550914140d0502a6f9
Products branch : IR-2022-06-24 SHA - bcdc36ce997b4a080c8321c2737db7a880a55028
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18881.26000000074 / 18769.080000000537 [+0.60%]
Products
Total CPU difference: 11821.570000000123 / 11750.840000000107 [+0.60%]
Windows-64-VC14:
OCCT
Total CPU difference: 20729.625 / 20650.390625 [+0.38%]
Products
Total CPU difference: 13355.9375 / 13264.28125 [+0.69%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-06-26 11:58

administrator   ~0109247

Branch CR32915 has been deleted by mnt.

SHA-1: b0b10491c2eff0c145117e1214be1c2c88051060

Related Changesets

occt: master 63fa56bc

2022-04-08 11:03:53

azv


Committer: afokin Details Diff
0032915: Geom2dAPI_InterCurveCurve, The algorithm lost an intersection point.

Get rid of strange code: preliminary check of self-intersections is made on a polygonal representation of a curve, it is able to find possible intersections, but after that it filter out segments neighbor to the pair of non-intersected segments.

Test case de step_4 I1 has been marked BAD, because the self-intersection is treated correctly, but the projection algorithm generates such crooked 2D curve.

Reference data in test cases heal split_angle_advanced ZA5 and ZA6 has been updated, because those shapes have self-intersected edges, which are being detected now.
Affected Issues
0032915
mod - src/IntCurve/IntCurve_IntPolyPolyGen.gxx Diff File
add - tests/bugs/modalg_8/bug32915 Diff File
mod - tests/de/step_4/I1 Diff File
mod - tests/heal/data/advanced/ZA5 Diff File
mod - tests/heal/data/advanced/ZA6 Diff File

Issue History

Date Modified Username Field Change
2022-04-07 10:19 bglee New Issue
2022-04-07 10:19 bglee Assigned To => msv
2022-04-07 10:19 bglee File Added: lost intf point.png
2022-04-07 10:19 bglee File Added: testBsplineCurve.BRep
2022-04-07 10:35 msv Assigned To msv => azv
2022-04-07 16:58 azv Target Version => 7.7.0
2022-04-07 16:58 azv Steps to Reproduce Updated
2022-04-08 09:57 azv Status new => assigned
2022-04-08 11:04 git Note Added: 0107746
2022-06-21 09:24 git Note Added: 0109130
2022-06-22 17:05 git Note Added: 0109180
2022-06-23 08:01 git Note Added: 0109187
2022-06-23 08:03 git Note Added: 0109188
2022-06-23 08:06 azv Assigned To azv => ifv
2022-06-23 08:06 azv Status assigned => resolved
2022-06-23 08:06 azv Note Added: 0109189
2022-06-23 08:07 azv Target Version 7.7.0 => 7.6.3
2022-06-23 08:07 azv Test case number => bugs/modalg_8/bug32915
2022-06-23 11:44 ifv Assigned To ifv => azv
2022-06-23 11:44 ifv Status resolved => assigned
2022-06-23 11:44 ifv Note Added: 0109202
2022-06-23 17:21 azv Assigned To azv => ifv
2022-06-23 17:21 azv Status assigned => resolved
2022-06-23 17:21 azv Note Added: 0109207
2022-06-23 17:30 ifv Assigned To ifv => bugmaster
2022-06-23 17:30 ifv Status resolved => reviewed
2022-06-23 17:30 ifv Note Added: 0109208
2022-06-26 11:28 smoskvin Status reviewed => tested
2022-06-26 11:28 smoskvin Note Added: 0109240
2022-06-26 11:46 afokin Changeset attached => occt master 63fa56bc
2022-06-26 11:46 azv Assigned To bugmaster => azv
2022-06-26 11:46 azv Status tested => verified
2022-06-26 11:46 azv Resolution open => fixed
2022-06-26 11:58 git Note Added: 0109247