View Issue Details

IDProjectCategoryView StatusLast Update
0032906Open CASCADEOCCT:Codingpublic2022-04-26 11:24
Reporterddzama Assigned Toddzama  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
PlatformWindowsOSVC++ 2019 
Product Version7.6.0 
Target Version7.7.0 
Summary0032906: Coding Rules - get rid of std::iterator inheritance (deprecated since C++17)
DescriptionGet rid of std::iterator inheritance (deprecated since C++17).
TagsNo tags attached.
Test case numberNot required

Relationships

parent of 0032950 newddzama Problem compile CSharp sample on Windows with VC12, VC14, VC142 
child of 0032887 assignedddzama Coding - Problem of compilation on VS2019/C++20 
Not all the children of this issue are yet resolved or closed.

Activities

git

2022-04-05 10:01

administrator   ~0107623

Branch CR32906 has been created by ddzama.

SHA-1: 4ba40e7b548f41326a0cc9d699b0a69320cb5597


Detailed log of new commits:

Author: Dmitry DZAMA
Date: Wed Mar 30 09:24:49 2022 +0300

    0032906: Get rid of std::iterator inheritance (deprecated since C++17).

git

2022-04-07 14:32

administrator   ~0107692

Branch CR32906 has been updated forcibly by ddzama.

SHA-1: 528862636602adb3778b519f560b9859f6eddbee

git

2022-04-07 14:37

administrator   ~0107694

Branch CR32906 has been updated forcibly by ddzama.

SHA-1: 3fab9e9f76c17358d61229caf2aa8417266b7612

git

2022-04-07 15:21

administrator   ~0107719

Branch CR32906 has been updated forcibly by ddzama.

SHA-1: f483048c0b27348f20a5b34b7563cfa903ed7bbe

git

2022-04-07 16:33

administrator   ~0107726

Branch CR32906 has been updated forcibly by ddzama.

SHA-1: 67d16f78b4ff86ee89519de308de05a6fc417039

git

2022-04-08 09:41

administrator   ~0107738

Branch CR32906 has been updated forcibly by ddzama.

SHA-1: 453669de9c67007fd80734034bae5c2c028bf59c

kgv

2022-04-08 18:03

developer   ~0107762

@abv, could you please take a look into this patch>?

abv

2022-04-21 14:35

manager   ~0108081

I have no remarks, provided that this change does not break compatibility with older compilers that we are still supporting

smoskvin

2022-04-23 14:00

administrator   ~0108123

Combination -
OCCT branch : IR-2022-04-22
master SHA - a0b4fff17a6ad88f569052733d24723dd53e0919
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2022-04-22 SHA - 75f214de3df3529ee06eee62bf6c9b71e35e8c8b
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18635.800000000607 / 18527.100000000686 [+0.59%]
Products
Total CPU difference: 11716.970000000136 / 11769.420000000111 [-0.45%]
Windows-64-VC14:
OCCT
Total CPU difference: 20692.578125 / 20548.828125 [+0.70%]
Products
Total CPU difference: 13247.5625 / 13272.65625 [-0.19%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-04-26 02:06

administrator   ~0108172

Branch CR32906 has been updated forcibly by ddzama.

SHA-1: a0b4fff17a6ad88f569052733d24723dd53e0919

Related Changesets

occt: master 8af9bbd5

2022-03-30 09:24:49

ddzama


Committer: smoskvin Details Diff
0032906: Coding Rules - get rid of std::iterator inheritance (deprecated since C++17) Affected Issues
0032906
mod - src/NCollection/NCollection_StlIterator.hxx Diff File
mod - src/OSD/OSD_Parallel.hxx Diff File

Issue History

Date Modified Username Field Change
2022-04-05 09:49 ddzama New Issue
2022-04-05 09:49 ddzama Assigned To => ddzama
2022-04-05 09:49 ddzama Relationship added child of 0032887
2022-04-05 10:01 git Note Added: 0107623
2022-04-05 10:02 ddzama Relationship deleted child of 0032887
2022-04-05 10:03 ddzama Relationship added child of 0032903
2022-04-05 10:05 ddzama Relationship deleted child of 0032903
2022-04-05 10:05 ddzama Relationship added parent of 0032903
2022-04-05 10:05 ddzama Relationship added child of 0032887
2022-04-05 10:17 ddzama Relationship deleted child of 0032887
2022-04-05 10:17 ddzama Relationship added child of 0032907
2022-04-07 12:31 kgv Relationship added child of 0032887
2022-04-07 12:31 kgv Relationship deleted child of 0032907
2022-04-07 12:31 kgv Product Version 7.7.0 => 7.6.0
2022-04-07 12:31 kgv Summary Get rid of std::iterator inheritance (deprecated since C++17). => Coding Rules - get rid of std::iterator inheritance (deprecated since C++17)
2022-04-07 12:33 kgv Relationship deleted parent of 0032903
2022-04-07 14:32 git Note Added: 0107692
2022-04-07 14:37 git Note Added: 0107694
2022-04-07 14:52 ddzama Relationship deleted child of 0032887
2022-04-07 14:53 ddzama Relationship added child of 0032887
2022-04-07 15:21 git Note Added: 0107719
2022-04-07 16:33 git Note Added: 0107726
2022-04-08 09:41 git Note Added: 0107738
2022-04-08 18:03 kgv Assigned To ddzama => abv
2022-04-08 18:03 kgv Status new => resolved
2022-04-08 18:03 kgv Note Added: 0107762
2022-04-21 14:35 abv Assigned To abv => bugmaster
2022-04-21 14:35 abv Status resolved => reviewed
2022-04-21 14:35 abv Note Added: 0108081
2022-04-23 14:00 smoskvin Status reviewed => tested
2022-04-23 14:00 smoskvin Note Added: 0108123
2022-04-23 14:02 smoskvin Test case number => Not required
2022-04-23 18:43 smoskvin Changeset attached => occt master 8af9bbd5
2022-04-23 18:43 ddzama Assigned To bugmaster => ddzama
2022-04-23 18:43 ddzama Status tested => verified
2022-04-23 18:43 ddzama Resolution open => fixed
2022-04-23 19:44 kgv Relationship added parent of 0032950
2022-04-26 02:06 git Note Added: 0108172