View Issue Details

IDProjectCategoryView StatusLast Update
0032684Open CASCADEOCCT:DRAWpublic2021-11-27 15:05
Reporterkgv Assigned Tosmoskvin  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version7.5.0 
Target Version7.7.0 
Summary0032684: Draw Harness - fix Draw_Interpretor::Add() misuse due to overloaded syntax
DescriptionDraw_Interpretor::Add() defines several overloads leading to seldom mistakes when comma is omitted.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberN/A

Activities

git

2021-11-23 20:36

administrator   ~0105379

Branch CR32684 has been created by kgv.

SHA-1: def84b700f9d8f34bfa5441b27627598e0618678


Detailed log of new commits:

Author: kgv
Date: Tue Nov 23 20:35:58 2021 +0300

    0032684: Draw Harness - fix Draw_Interpretor::Add() misuse due to overloaded syntax

kgv

2021-11-23 22:11

developer   ~0105383

Patch is ready for review:
- OCCT: branch CR32684.

http://jenkins-test-12.nnov.opencascade.com/view/CR32684-master-KGV/

osa

2021-11-25 17:31

developer   ~0105426

The patch was reviewed

aml

2021-11-25 17:46

developer   ~0105427

The patch was reviewed

smoskvin

2021-11-27 14:24

administrator   ~0105467

Combination -
OCCT branch : IR-2021-11-26
master SHA - 4a837ecec21bfe24d9c224c4b59aa9779156f297
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2021-11-26 SHA - 5da5872bffc6c1fa745ee5e33ac09c4fffd349b4
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18390.380000000398 / 18549.650000000624 [-0.86%]
Products
Total CPU difference: 11648.280000000103 / 11661.570000000122 [-0.11%]
Windows-64-VC14:
OCCT
Total CPU difference: 19927.859375 / 19945.046875 [-0.09%]
Products
Total CPU difference: 13059.03125 / 13091.625 [-0.25%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2021-11-27 15:05

administrator   ~0105488

Branch CR32684 has been deleted by mnt.

SHA-1: def84b700f9d8f34bfa5441b27627598e0618678

Related Changesets

occt: master d0cf7e8f

2021-11-23 17:35:58

kgv


Committer: smoskvin Details Diff
0032684: Draw Harness - fix Draw_Interpretor::Add() misuse due to overloaded syntax Affected Issues
0032684
mod - src/BRepTest/BRepTest_CurveCommands.cxx Diff File
mod - src/BRepTest/BRepTest_FeatureCommands.cxx Diff File
mod - src/BRepTest/BRepTest_FilletCommands.cxx Diff File
mod - src/DBRep/DBRep.cxx Diff File
mod - src/Draw/Draw_Interpretor.cxx Diff File
mod - src/GeometryTest/GeometryTest_CurveCommands.cxx Diff File
mod - src/QABugs/QABugs_3.cxx Diff File
mod - src/ViewerTest/ViewerTest.cxx Diff File
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff File
mod - src/XDEDRAW/XDEDRAW_GDTs.cxx Diff File
mod - src/XSDRAW/XSDRAW.cxx Diff File

Issue History

Date Modified Username Field Change
2021-11-23 20:31 kgv New Issue
2021-11-23 20:31 kgv Assigned To => kgv
2021-11-23 20:36 git Note Added: 0105379
2021-11-23 22:11 kgv Test case number => N/A
2021-11-23 22:11 kgv Assigned To kgv => bugmaster
2021-11-23 22:11 kgv Status new => resolved
2021-11-23 22:11 kgv Assigned To bugmaster => osa
2021-11-23 22:11 kgv Note Added: 0105383
2021-11-24 20:12 kgv Assigned To osa => aml
2021-11-25 17:31 osa Note Added: 0105426
2021-11-25 17:31 osa Assigned To aml => bugmaster
2021-11-25 17:31 osa Status resolved => reviewed
2021-11-25 17:46 aml Note Added: 0105427
2021-11-27 14:24 smoskvin Note Added: 0105467
2021-11-27 14:24 smoskvin Status reviewed => tested
2021-11-27 14:52 smoskvin Changeset attached => occt master d0cf7e8f
2021-11-27 14:52 smoskvin Assigned To bugmaster => smoskvin
2021-11-27 14:52 smoskvin Status tested => verified
2021-11-27 14:52 smoskvin Resolution open => fixed
2021-11-27 15:05 git Note Added: 0105488