View Issue Details

IDProjectCategoryView StatusLast Update
0032647Open CASCADEOCCT:Visualizationpublic2022-06-14 13:54
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionno change required 
PlatformWindowsOSVC++ 2015 
Product Version7.5.0 
Target Version7.7.0 
Summary0032647: Visualization, TKOpenGles - maximized window has stretched content
Description3D Viewer window in maximized state in Draw Harness produced a stretched content when using Angle OpenGL ES implementation.

The reason is the following lines within OpenGl_Window::Init():
eglQuerySurface ((EGLDisplay )myGlContext->myDisplay, (EGLSurface )myGlContext->myWindow, EGL_WIDTH,  &myWidth);
eglQuerySurface ((EGLDisplay )myGlContext->myDisplay, (EGLSurface )myGlContext->myWindow, EGL_HEIGHT, &myHeight);


Within tested version of ANGLE, the behavior of these getters is clumsy - they are updated after eglSwapBuffers(), making it difficult relying on these properties BEFORE redrawing the contents.
It looks like a bug in particular EGL implementation.
Steps To Reproduce
pload XDE MODELING VISUALIZATION
vdriver -load GLES
box b 1 2 3
vinit View1
vdisplay -dispMode 1 b
vfit

Then maximize viewer window.
Result: KO - viewer content doesn't entirely fit into window.
TagsNo tags attached.
Test case numberN/A

Relationships

related to 0032648 verifiedinv Visualization, TKOpenGles - support MSAA anti-aliasing within WebGL 2.0 

Activities

kgv

2021-11-02 12:38

developer   ~0104998

Reproduced on:
  EGLVersion: 1.4 (ANGLE 2.1.0.46ad513f4e5b)


Not reproduced on:
  EGLVersion: 1.4 (ANGLE 2.1.0.57ea533f79a7)

Seems to be bug has been fixed within some ANGLE update.

Need to rebuild thirdparties.

kgv

2021-11-09 21:49

developer   ~0105077

Please close the bug.

Issue History

Date Modified Username Field Change
2021-11-02 12:27 kgv New Issue
2021-11-02 12:27 kgv Assigned To => kgv
2021-11-02 12:28 kgv Test case number => N/A
2021-11-02 12:28 kgv Steps to Reproduce Updated
2021-11-02 12:32 kgv Description Updated
2021-11-02 12:38 kgv Note Added: 0104998
2021-11-02 12:38 kgv Description Updated
2021-11-03 10:48 kgv Resolution open => no change required
2021-11-09 21:49 kgv Note Added: 0105077
2021-11-09 21:49 kgv Assigned To kgv => bugmaster
2021-11-09 21:49 kgv Status new => feedback
2021-11-09 21:49 kgv Relationship added related to 0032648
2022-06-14 13:54 azv Status feedback => closed