View Issue Details

IDProjectCategoryView StatusLast Update
0032642Open CASCADEOCCT:Codingpublic2022-01-31 09:47
Reporteraml Assigned Tobugmaster  
PrioritynormalSeverityintegration request 
Status closedResolutionno change required 
Product Version7.5.0 
Target Version7.6.0 
Summary0032642: Coding - missing Standard_EXPORT in public interface of Standard_ErrorHandler
DescriptionGmsh cannot be linked against the current development version of OCCT due to the `unresolved external symbol` error pointing to this file.

//! Registers this callback object in the current error handler (if found).
void RegisterCallback();

//! Unregisters this callback object from the error handler.
void UnregisterCallback();

//! Destructor
virtual ~Callback();
TagsNo tags attached.
Test case number

Relationships

duplicate of 0032810 verifiedaml Coding - missing Standard_EXPORT in Standard_ErrorHandler 

Activities

git

2021-10-25 18:39

administrator   ~0104856

Branch CR32642 has been created by aml.

SHA-1: b4922948a76ea7e6c44988dd49a470193cf616fe


Detailed log of new commits:

Author: aml
Date: Mon Oct 25 18:38:25 2021 +0300

    0032642: Coding - missing Standard_EXPORT in public interface of Standard_ErrorHandler
    Add missing Standard_EXPORT macro.

kgv

2021-10-25 19:50

developer   ~0104858

Standard_EXPORT should be added only in case when OCC_CONVERT_SIGNALS is defined while building OCCT.

git

2021-10-26 06:41

administrator   ~0104864

Branch CR32642 has been deleted by aml.

SHA-1: b4922948a76ea7e6c44988dd49a470193cf616fe

aml

2021-10-26 06:50

developer   ~0104865

Kirill's message explains the root cause of the problem.

aml

2021-10-26 06:51

developer   ~0104866

Dear bugmaster,
Please close this ticket, it was created mistakenly.

Issue History

Date Modified Username Field Change
2021-10-25 18:36 aml New Issue
2021-10-25 18:36 aml Assigned To => aml
2021-10-25 18:39 git Note Added: 0104856
2021-10-25 19:50 kgv Note Added: 0104858
2021-10-26 06:41 git Note Added: 0104864
2021-10-26 06:50 aml Note Added: 0104865
2021-10-26 06:51 aml Note Added: 0104866
2021-10-26 06:51 aml Assigned To aml => bugmaster
2021-10-26 06:51 aml Status new => feedback
2021-10-29 17:09 bugmaster Status feedback => closed
2021-10-29 17:09 bugmaster Resolution open => no change required
2022-01-31 09:47 kgv Relationship added duplicate of 0032810