View Issue Details

IDProjectCategoryView StatusLast Update
0032615Open CASCADEOCCT:Codingpublic2022-05-06 20:47
Reporteraml Assigned Tobugmaster  
PrioritynormalSeverityintegration request 
Status closedResolutionfixed 
Product Version7.5.0 
Target Version7.7.0 
Summary0032615: Coding - get rid of unused forward declarations
DescriptionThis is a parent ticket for automatic headers processing by the Include-What-You-Use tool.

The next step would be deleting unused friend class declarations (generated by WOK for a root class within each Package).
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberN/A

Relationships

parent of 0032614 closedbugmaster Coding - get rid of unsused forward declarations [Adaptor2d to GccAna] 
parent of 0032603 closedsmoskvin Coding - get rid of unsused forward declarations [Adaptor2d to BRepMesh] 
parent of 0032630 closedsmoskvin Coding - get rid of unsused forward declarations [BinMDF to IFSelect] 
parent of 0032641 closedsmoskvin Coding - get rid of unused forward declarations [IGESAppli to LDOM] 
parent of 0032667 verifiedsmoskvin Coding - get rid of unused forward declarations [LibCtl to StepRepr] 
parent of 0032696 verifiedsmoskvin Coding - get rid of unused forward declarations [StepSelect to Xw] 
parent of 0032743 verifiedkgv Coding Rules - remove unused class friends of Package classes 
parent of 0032838 verifiedaml Coding - get rid of unused forward declarations (misc) 

Activities

aml

2021-12-19 09:45

developer   ~0106075

Dear bugmaster,

please close this issue since all children are processed. No more activity is expected in the frames of this ticket.

Issue History

Date Modified Username Field Change
2021-10-12 10:40 aml New Issue
2021-10-12 10:40 aml Assigned To => aml
2021-10-12 10:41 aml Relationship added parent of 0032614
2021-10-12 10:41 aml Relationship added related to 0032603
2021-10-12 10:42 kgv Relationship replaced parent of 0032603
2021-10-18 17:37 aml Relationship added parent of 0032630
2021-10-25 17:36 aml Relationship added parent of 0032641
2021-11-16 17:42 aml Relationship added parent of 0032667
2021-11-17 16:11 kgv Test case number => N/A
2021-11-17 16:11 kgv Description Updated
2021-11-17 16:11 kgv Steps to Reproduce Updated
2021-11-29 11:20 aml Relationship added parent of 0032696
2021-12-19 09:44 aml Status new => resolved
2021-12-19 09:45 aml Assigned To aml => bugmaster
2021-12-19 09:45 aml Status resolved => reviewed
2021-12-19 09:45 aml Note Added: 0106075
2021-12-19 10:31 kgv Status reviewed => feedback
2021-12-19 12:15 kgv Relationship added parent of 0032743
2022-02-16 12:59 aml Relationship added related to 0032838
2022-02-17 08:44 kgv Relationship replaced parent of 0032838
2022-05-04 11:48 kgv Status feedback => reviewed
2022-05-06 20:47 smoskvin Status reviewed => closed
2022-05-06 20:47 smoskvin Resolution open => fixed