MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0032531Community[OCCT] OCCT:Application Frameworkpublic2021-08-12 11:452021-09-11 13:43
ReporterBenjaminBihler 
Assigned Tosmoskvin 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformAOSLOS VersionL
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0032531: Application Framework - There should be methods to get explanations of PCDM_StoreStatus and PCDM_ReaderStatus values
DescriptionWhen reading or writing OCAF documents, something might fail and there is the need to tell the user what has gone wrong. This is hard, because the enumeration values of PCDM_StoreStatus and PCDM_ReaderStatus are useless for the user.

For PCDM_ReaderStatus I have found some cryptic strings in TObj_Application::LoadDocument, but for PCDM_StoreStatus there is already a lot of work done to output the reasons of the failure. In the methods OCC381_Save and OCC381_SaveAs there are good (duplicated?!) strings that could be used and TObj_Application::SaveDocument contains again quite cryptic strings.

I would propose to implement GetMessage(...) methods that return explanation strings. This would greatly simplify outputting reasonable error messages.
Steps To ReproduceNot required
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
related to 0032125verifiedbugmaster Open CASCADE Application Framework, OCAF - need to have adequate message if document cannot be saved due to unrecognized format 

-  Notes
(0103151)
kgv (developer)
2021-08-12 12:45

Probably related to 0032125, but extends it's context to both reading and writing operations.
(0103912)
git (administrator)
2021-09-08 09:50

Branch CR32531 has been created by vro.

SHA-1: b420b8a3ed014e2f82324202bdae8228f0fc234a


Detailed log of new commits:

Author: vro
Date: Wed Sep 8 09:49:52 2021 +0300

    0032531: Application Framework - There should be methods to get explanations of PCDM_StoreStatus and PCDM_ReaderStatus values
    
    Documentation is added for PCDM_ReaderStatus enumeration.
    
    Modified:
    - PCDM_ReaderStatus.hxx: each value received a short explanation.
(0103913)
vro (developer)
2021-09-08 10:20

I added a documentation for the PCDM_ReaderStatus enumeration. Similar to PCDM_StoreStatus from the issue 0032125. Now we have both enumerations documented.

Compilation and testing is not done because only commented code is added (locally I compiled to check on occasional errors).

The branch is CR32531.
(0103934)
mpv (developer)
2021-09-09 11:14

Reviewed.
OCCT branch: CR32531
PRODUCTS branch: NOTHING
(0104008)
smoskvin (administrator)
2021-09-11 13:25

Combination -
OCCT branch : IR-2021-09-10
master SHA - 9ae883970dd77a39d856b49e6883ed5d0e60d20f
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2021-09-10 SHA - 2d2bc879e2da9d770a1938ab3410f5885c8555e7
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17358.54000000042 / 17496.500000000422 [-0.79%]
Products
Total CPU difference: 11397.800000000112 / 11567.680000000111 [-1.47%]
Windows-64-VC14:
OCCT
Total CPU difference: 19328.109375 / 19307.609375 [+0.11%]
Products
Total CPU difference: 12733.328125 / 12920.953125 [-1.45%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

- Related Changesets
occt: master e8ae1c42
Timestamp: 2021-09-08 06:49:52
Author: vro
Committer: smoskvin
Details ] Diff ]
0032531: Application Framework - There should be methods to get explanations of PCDM_StoreStatus and PCDM_ReaderStatus values

Documentation is added for PCDM_ReaderStatus enumeration.

Modified:
- PCDM_ReaderStatus.hxx: each value received a short explanation.
mod - src/PCDM/PCDM_ReaderStatus.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2021-08-12 11:45 BenjaminBihler New Issue
2021-08-12 11:45 BenjaminBihler Assigned To => gka
2021-08-12 12:44 kgv Relationship added related to 0032125
2021-08-12 12:45 kgv Note Added: 0103151
2021-08-12 12:45 kgv Assigned To gka => mpv
2021-08-12 12:45 kgv Category OCCT:Data Exchange => OCCT:Application Framework
2021-08-12 12:45 kgv Summary Data Exchange - There should be methods to get explanations of PCDM_StoreStatus and PCDM_ReaderStatus values => Application Framework - There should be methods to get explanations of PCDM_StoreStatus and PCDM_ReaderStatus values
2021-08-12 12:46 kgv Product Version 7.5.2 => 7.5.0
2021-08-13 18:46 mpv Assigned To mpv => vro
2021-09-03 09:00 mpv Status new => assigned
2021-09-08 09:50 git Note Added: 0103912
2021-09-08 10:20 vro Note Added: 0103913
2021-09-08 10:20 vro Assigned To vro => mpv
2021-09-08 10:20 vro Status assigned => resolved
2021-09-08 10:20 vro Steps to Reproduce Updated View Revisions
2021-09-09 11:14 mpv Note Added: 0103934
2021-09-09 11:14 mpv Assigned To mpv => bugmaster
2021-09-09 11:14 mpv Status resolved => reviewed
2021-09-11 13:25 smoskvin Note Added: 0104008
2021-09-11 13:25 smoskvin Status reviewed => tested
2021-09-11 13:34 smoskvin Test case number => Not required
2021-09-11 13:43 smoskvin Changeset attached => occt master e8ae1c42
2021-09-11 13:43 smoskvin Assigned To bugmaster => smoskvin
2021-09-11 13:43 smoskvin Status tested => verified
2021-09-11 13:43 smoskvin Resolution open => fixed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker