View Issue Details

IDProjectCategoryView StatusLast Update
0032445CommunityOCCT:Modeling Algorithmspublic2022-07-02 15:33
ReporterJerome Caucat Assigned Toakaftasev  
PrioritynormalSeveritycrash 
Status verifiedResolutionfixed 
PlatformLinuxOSUbuntu 20.04 
Target Version7.7.0 
Summary0032445: BRepOffsetAPI_MakePipeShell crash when using -DT mode and DT_ShapeDivide on the spine
DescriptionUsing OCCT 7.5.2 with the patch for https://tracker.dev.opencascade.org/view.php?id=29645 and https://tracker.dev.opencascade.org/view.php?id=31147.

When trying to build a pipe with the provided spine, profiles and .tcl file I get a crash in C++ and in DRAW, with the following error in DRAW:

An exception was caught 0x56027a06dee0 : OSD_SIGSEGV: SIGSEGV 'segmentation violation' detected. Address 60

I am using "DT_ShapeDivide" with a tolerance of 0.01 on the spine, "setsweep -DT" and "buildsweep r -C -S".

Possibly linked to https://tracker.dev.opencascade.org/view.php?id=32444
Steps To Reproducetest bugs modalg_7 bug32445
TagsNo tags attached.
Test case numberbugs/modalg_7/bug32445

Attached Files

  • sample.zip (5,556 bytes)
  • Screenshot.png (8,904 bytes)

Relationships

related to 0032444 closedsmoskvin BRepOffsetAPI_MakePipeShell crash when using -DT mode and DT_ShapeDivide on the spine 

Activities

Jerome Caucat

2021-06-16 16:13

reporter  

sample.zip (5,556 bytes)

kgv

2021-06-16 16:34

developer   ~0101870

Jerome, it would be helpful renaming attachments in some unique way (like sample-1.zip) as well as renaming bugs themselves, so that they wouldn't be erroneously confused as duplicates. Feel free to also set "New relationship" field to bind similar issues.

Jerome Caucat

2021-06-16 16:57

reporter   ~0101872

> it would be helpful renaming attachments in some unique way (like sample-1.zip) as well as renaming bugs themselves

It doesn't look like I can edit my issue, but I'll keep that in mind for next time.

> Feel free to also set "New relationship" field to bind similar issues.

I would gladly do it, but don't see any button or field do to that, perhaps I don't have enough rights.

kgv

2021-06-16 17:12

developer   ~0101873

Jerome, sorry for misdirection.

I wasn't expected that user with "reporter" access level will not have access to "Relationships" field and to Edit "Summary".
Probably these restrictions do make sense... But I'm not sure ;).

Jerome Caucat

2021-09-14 16:44

reporter   ~0104077

This bug raises the same problem as in https://tracker.dev.opencascade.org/view.php?id=32444#c104076.

akaftasev

2021-10-14 16:01

developer  

Screenshot.png (8,904 bytes)

akaftasev

2021-10-14 16:03

developer   ~0104638

Last edited: 2021-10-14 17:44

Dear Jerome Caucat, current bug have a similar solution, as 0032444
(resulting shape you can see on the attached Screenshot.png)

azv

2022-06-28 06:43

administrator   ~0109311

Andrey, could you provide a test case to prove the issue is solved?

git

2022-06-29 10:33

administrator   ~0109360

Branch CR32445 has been created by andrey.kaftasev_159541.

SHA-1: fc4d072da1b8f68ca4bdacc28d6ce86b84da7d77


Detailed log of new commits:

Author: akaftasev
Date: Wed Jun 29 10:32:52 2022 +0300

    0032445: BRepOffsetAPI_MakePipeShell crash when using -DT mode and DT_ShapeDivide on the spine
    
    Added test case

akaftasev

2022-06-29 15:41

developer   ~0109386

Branch for review:
OCCT - CR32445

Results of testing:
http://jenkins-test-occt.nnov.opencascade.com/view/CR32446-master-akaftasev/view/COMPARE/

azv

2022-06-29 15:52

administrator   ~0109388

Branches for integration:
OCCT: CR32445
Products: NOT

bugmaster

2022-07-02 15:19

administrator   ~0109478

Combination -
OCCT branch : IR-2022-07-01
master SHA - e01ce0cd52b37150679c833d1db2cc5edd620341
e0ceb716c70188b98130b1550914140d0502a6f9
Products branch : IR-2022-07-01 SHA - 78f14e59f6cde821eed22399cb05bb1295820b58
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18877.730000000698 / 18881.360000000743 [-0.02%]
Products
Total CPU difference: 11831.730000000112 / 11827.420000000122 [+0.04%]
Windows-64-VC14:
OCCT
Total CPU difference: 20719.265625 / 20729.6875 [-0.05%]
Products
Total CPU difference: 13368.265625 / 13360.71875 [+0.06%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-07-02 15:33

administrator   ~0109492

Branch CR32445 has been deleted by mnt.

SHA-1: fc4d072da1b8f68ca4bdacc28d6ce86b84da7d77

Related Changesets

occt: master a0ffd4a5

2022-06-29 10:32:52

akaftasev


Committer: smoskvin Details Diff
0032445: BRepOffsetAPI_MakePipeShell crash when using -DT mode and DT_ShapeDivide on the spine

Added test case
Affected Issues
0032445
add - tests/bugs/modalg_7/bug32445 Diff File

Issue History

Date Modified Username Field Change
2021-06-16 16:13 Jerome Caucat New Issue
2021-06-16 16:13 Jerome Caucat Assigned To => msv
2021-06-16 16:13 Jerome Caucat File Added: sample.zip
2021-06-16 16:34 kgv Note Added: 0101870
2021-06-16 16:57 Jerome Caucat Note Added: 0101872
2021-06-16 17:12 kgv Note Added: 0101873
2021-09-14 16:44 Jerome Caucat Note Added: 0104077
2021-09-14 16:50 msv Relationship added related to 0032444
2021-10-14 16:01 akaftasev File Added: Screenshot.png
2021-10-14 16:03 akaftasev Note Added: 0104638
2021-10-14 16:03 akaftasev Assigned To msv => Jerome Caucat
2021-10-14 16:03 akaftasev Status new => feedback
2021-10-14 16:09 akaftasev Note Edited: 0104638
2021-10-14 17:44 szy Note Edited: 0104638
2022-06-28 06:43 azv Assigned To Jerome Caucat => akaftasev
2022-06-28 06:43 azv Status feedback => assigned
2022-06-28 06:43 azv Note Added: 0109311
2022-06-28 06:45 azv Target Version => 7.7.0
2022-06-29 10:33 git Note Added: 0109360
2022-06-29 15:41 akaftasev Assigned To akaftasev => azv
2022-06-29 15:41 akaftasev Status assigned => resolved
2022-06-29 15:41 akaftasev Steps to Reproduce Updated
2022-06-29 15:41 akaftasev Note Added: 0109386
2022-06-29 15:52 azv Assigned To azv => bugmaster
2022-06-29 15:52 azv Status resolved => reviewed
2022-06-29 15:52 azv Note Added: 0109388
2022-06-29 15:52 azv Test case number => bugs/modalg_7/bug32445
2022-07-02 15:19 bugmaster Note Added: 0109478
2022-07-02 15:26 smoskvin Changeset attached => occt master a0ffd4a5
2022-07-02 15:26 akaftasev Assigned To bugmaster => akaftasev
2022-07-02 15:26 akaftasev Status reviewed => verified
2022-07-02 15:26 akaftasev Resolution open => fixed
2022-07-02 15:33 git Note Added: 0109492