View Issue Details

IDProjectCategoryView StatusLast Update
0032421CommunityOCCT:Data Exchangepublic2021-10-16 11:30
Reporterh.p.rice_161188 Assigned Todpasukhi  
PrioritynormalSeverityminor 
Status assignedResolutionopen 
OSWindows 
Product Version7.5.0 
Target Version7.7.0 
Summary0032421: STEP parsing problem: incorrect PRODUCT text
DescriptionWhen reading a STEP file with a PRODUCT name that contains multiple single apostrophes, only one apostrophe is retained.
Steps To ReproduceI loaded a STEP file, and compared the PRODUCT lines of the STEP file from which the names are taken to the names displayed on screen using a CAD viewer I am developing.

One part in particular is named "C''''''''SK HD SCREW M4 x 12_ISO 10642 - M4 x 12 - 12C", but when parsed becomes "C'SK HD SCREW M4 x 12_ISO 10642 - M4 x 12 - 12C", i.e. seven of the eight apostrophes have been removed.

I also reproduced the bug with FreeCAD, which I believe also relies on Open Cascade.

I'm sorry that I can't share the STEP file that caused me to find the bug, due to confidentiality. However, I expect it can be reproduced with any PRODUCT name containing that combination of characters.
Additional information
and documentation updates
I am using Open Cascade view PythonOCC 7.5.1.
TagsNo tags attached.
Test case number

Attached Files

  • Torch Assembly_for OCC bug.STEP (3,127,956 bytes)

Relationships

related to 0032310 closedsmoskvin Open CASCADE Data Exchange - Invalid STEP export/import of backslashes in names [Regression since OCCT 7.5.0] 

Activities

kgv

2021-06-04 17:44

developer   ~0101618

Last edited: 2021-06-04 17:52

> I'm sorry that I can't share the STEP file that caused me to find the bug, due to confidentiality.
> However, I expect it can be reproduced with any PRODUCT name containing that combination of characters.
I'm afraid we wouldn't be able processing the issue without a reproducer.

Either - try preparing a reproducer from a non-confidential shape (e.g. by modifying STEP file in a text editor or another CAD software for producing similar effect), or consider sharing file privately with development team (using Contact Us form).

h.p.rice_161188

2021-06-04 18:11

reporter  

Torch Assembly_for OCC bug.STEP (3,127,956 bytes)

h.p.rice_161188

2021-06-04 18:14

reporter   ~0101619

Apologies for not being able to attach a file earlier, I've created another that is not subject to any confidentiality. I've added some apostrophes to the second text field of the PRODUCT line for the part named "TORCH BODY - UPPER" and the bug is reproduced.

dpasukhi

2021-10-16 11:30

developer   ~0104672

The current problem has been fixed with 0032310
The attached test file is not valid, because "''" is a decoded as a single apostrophe. To create a sequence of apostrophes, need to double a number of expected apostrophes in the file.
Test case for 0032310 issue contains a case of sequence of apostrophes and tested for import and export process.

Issue History

Date Modified Username Field Change
2021-06-04 17:36 h.p.rice_161188 New Issue
2021-06-04 17:36 h.p.rice_161188 Assigned To => gka
2021-06-04 17:44 kgv Note Added: 0101618
2021-06-04 17:44 kgv Assigned To gka => h.p.rice_161188
2021-06-04 17:44 kgv Status new => feedback
2021-06-04 17:44 kgv Note Edited: 0101618
2021-06-04 17:45 kgv Resolution open => unable to reproduce
2021-06-04 17:45 kgv Target Version => 7.6.0
2021-06-04 17:52 kgv Note Edited: 0101618
2021-06-04 18:11 h.p.rice_161188 File Added: Torch Assembly_for OCC bug.STEP
2021-06-04 18:14 h.p.rice_161188 Note Added: 0101619
2021-06-04 18:47 kgv Assigned To h.p.rice_161188 => gka
2021-06-04 18:47 kgv Status feedback => assigned
2021-06-04 18:48 kgv Resolution unable to reproduce => open
2021-06-04 18:50 kgv Product Version 7.5.1 => 7.5.0
2021-08-31 14:16 gka Target Version 7.6.0 => 7.7.0
2021-10-12 14:08 dpasukhi Relationship added related to 0032310
2021-10-16 11:16 dpasukhi Assigned To gka => dpasukhi
2021-10-16 11:30 dpasukhi Note Added: 0104672