View Issue Details

IDProjectCategoryView StatusLast Update
0032318Open CASCADEOCCT:Configurationpublic2021-09-20 11:10
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status newResolutionopen 
PlatformLinuxOSUbuntu 18.04 
Product Version7.5.0 
Target Version7.7.0 
Summary0032318: Configuration - Draw Harness is unable to load plugins on Ubuntu 21.04
DescriptionUnfortunately, official packages coming with the most recent release of Ubuntu (21.04) still provides non-working Draw Harness experience.
/usr/bin/occt-draw-7.5 nor /usr/share/opencascade/bin/draw.sh are unable to load plugins.

It is desired helping Debian/Ubuntu package maintainers to package workable Draw Harness.
Steps To Reproduce
sudo apt-get install occt-draw
occt-draw
> pload ALL

KO

sudo apt-get install libocct-draw-dev
occt-draw
> pload ALL

OK

Problem 1: DRAWEXE should be able loading plugins without development package installed.
Problem 2: samples coming with DRAWEXE unable to find necessary resources
TagsNo tags attached.
Test case number

Attached Files

  • ubu2104_occt_draw_KO.png (195,069 bytes)

Relationships

related to 0030339 closedapn Configuration - add project files for qmake 
parent of 0032321 newkgv Draw Harness - pload should be able loading plugins with version suffix 
Not all the children of this issue are yet resolved or closed.

Activities

kgv

2021-04-23 07:41

developer  

ubu2104_occt_draw_KO.png (195,069 bytes)

Issue History

Date Modified Username Field Change
2021-04-22 20:07 kgv New Issue
2021-04-22 20:07 kgv Assigned To => bugmaster
2021-04-22 20:07 kgv Product Version => 7.5.0
2021-04-22 20:11 kgv Relationship added related to 0030339
2021-04-23 07:41 kgv File Added: ubu2104_occt_draw_KO.png
2021-04-23 08:10 kgv Steps to Reproduce Updated
2021-04-23 09:43 kgv Relationship added parent of 0032321
2021-09-20 11:10 kgv Target Version 7.6.0 => 7.7.0