View Issue Details

IDProjectCategoryView StatusLast Update
0032286CommunityOCCT:Configurationpublic2021-06-15 09:45
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Target Version7.6.0 
Summary0032286: Configuration, TKService - make Xlib dependency optional
DescriptionIn some cases Xlib dependency is a redundant burden in TKService on application not using 3D Viewer, but using other features (like TKXCAF depending on TKV3d).

The simplest solution could be making Xlib optional within TKService itself, but this might be not the most optimal solution, so other options to be considered as well like moving Xw/WNT/Cocoa packages to a dedicated toolkit or in opposite direction (moving Graphics / Image / V3d to TKGraphics and keeping TKService only for platform-dependent wrappers).
TagsNo tags attached.
Test case number

Relationships

duplicate of 0032308 closedbugmaster Open CASCADE Configuration - make Xlib dependency optional 
child of 0031401 newkgv Open CASCADE Visualization - revise Toolkits dependency graph 
child of 0032268 resolvedkgv Community Configuration, CMake - a proposal for minimal build flag in CMake 

Activities

kgv

2021-06-10 17:01

developer   ~0101752

Please close as duplicate of 0032308.

Issue History

Date Modified Username Field Change
2021-04-06 21:18 kgv New Issue
2021-04-06 21:18 kgv Assigned To => bugmaster
2021-04-06 21:18 kgv Relationship added child of 0031401
2021-04-06 21:18 kgv Relationship added child of 0032268
2021-04-06 21:19 kgv Summary Configuration, TKService - make Xlib dependency option => Configuration, TKService - make Xlib dependency optional
2021-06-10 16:59 kgv Relationship added related to 0029187
2021-06-10 16:59 kgv Relationship deleted related to 0029187
2021-06-10 17:00 kgv Relationship added duplicate of 0032308
2021-06-10 17:01 kgv Note Added: 0101752
2021-06-10 17:01 kgv Status new => feedback
2021-06-10 17:01 kgv Resolution open => duplicate
2021-06-15 09:45 bugmaster Status feedback => closed