MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0032273Community[OCCT] OCCT:Data Exchangepublic2021-03-31 14:392021-04-07 16:03
Reporterorgot 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusclosedResolutionduplicate 
PlatformWindowsOSVC++ 2013OS Version64 bit
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0032273: Data Exchange - STEP Export producing bad geometry from BREP Files
DescriptionDear OCCT team,

I have several BREP Files which seems broken when I export them in STEP.

I tried OCCT 7.5.0 and 7.6.0.
Others Tools : ShapeFix_Face, ShapeFix_FixSmallFace, ShapeFix_Shape ...
The ShapeFix_Wireframe(FixGaps3d) resolved the problem for other volumes but not this one.

Thank you for your help

Steps To Reproduce
pload XDE MODELING
restore initial.brep initial
testwritestep tostep.stp initial
testreadstep  tostep.stp new
Additional information
and documentation updates
I changed those global configuration variable and tried to tweak with it but to no avail.
("write.surfacecurve.mode",0);
("read.precision.mode",1);
("write.precision.val",0.01);
("write.step.assembly",0);
TagsNo tags attached.
Test case number
Attached Filesrar file icon sample.rar (4,653,767 bytes) 2021-03-31 14:39
7z file icon initial.7z (3,281,388 bytes) 2021-03-31 17:20
png file icon initial_fixed.png (25,355 bytes) 2021-03-31 17:21

- Relationships
duplicate of 0032264verifiedbugmaster Data Exchange - STEP exporter generates bad geometry [REGRESSION since 7.4.0] 

-  Notes
(0099910)
gka (developer)
2021-03-31 15:04
edited on: 2021-03-31 15:26

Please note that seems that this problem is same as described in the issue 0032264. Fix for issue 032264 is in process of testing.

(0099922)
gka (developer)
2021-03-31 17:20

Please note that fix made for 0032265 fixes your problem.
Please find attached written in the branch CR32264 step file in the archive initial.7z ans attached picture initial_fixed.png
(0099923)
orgot (reporter)
2021-03-31 17:38

Thanks for your quick answer ! Now it works just fine.
(0099929)
gka (developer)
2021-04-01 09:12

Problem was fixed by fix for case 0032264
(0100090)
kgv (developer)
2021-04-03 14:11

Please close as duplicate of 0032264.

- Issue History
Date Modified Username Field Change
2021-03-31 14:39 orgot New Issue
2021-03-31 14:39 orgot Assigned To => gka
2021-03-31 14:39 orgot File Added: sample.rar
2021-03-31 14:55 gka Relationship added related to 0032264
2021-03-31 15:04 gka Note Added: 0099910
2021-03-31 15:26 gka Note Edited: 0099910 View Revisions
2021-03-31 17:20 gka File Added: initial.7z
2021-03-31 17:20 gka Note Added: 0099922
2021-03-31 17:21 gka File Added: initial_fixed.png
2021-03-31 17:38 orgot Note Added: 0099923
2021-04-01 09:12 gka Note Added: 0099929
2021-04-01 09:12 gka Status new => resolved
2021-04-01 10:28 kgv Target Version => 7.6.0*
2021-04-03 14:11 kgv Resolution open => duplicate
2021-04-03 14:11 kgv Summary STEP Export producing bad geometry from BREP Files => Data Exchange - STEP Export producing bad geometry from BREP Files
2021-04-03 14:11 kgv Steps to Reproduce Updated View Revisions
2021-04-03 14:11 kgv Additional Information Updated View Revisions
2021-04-03 14:11 kgv Relationship replaced duplicate of 0032264
2021-04-03 14:11 kgv Note Added: 0100090
2021-04-03 14:11 kgv Assigned To gka => bugmaster
2021-04-03 14:11 kgv Status resolved => feedback
2021-04-07 16:03 bugmaster Status feedback => closed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker