View Issue Details

IDProjectCategoryView StatusLast Update
0032257Open CASCADEOCCT:Shape Healingpublic2021-04-01 15:37
Reporterasuraven Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Target Version7.6.0 
Summary0032257: Modeling Algorithms - fixshape generates new faulties
DescriptionIn branch CR23731_7 the model has 2 BRepCheck_CollapsedEdge errors. But executing on this fixshape command added BRepCheck_UnorientableShape & BRepCheck_NotClosed faulties.
Steps To Reproducepload MODELING
restore [locate_data_file bug28501_N9_lf.brep] ls
mkvolume result ls -c -ni
# 2 faulties
checkshape result
fixshape r1 result
# 4 faulties
checkshape r1
Additional information
and documentation updates
The issue 28501 related to this problem too, but requires higher access level
TagsNo tags attached.
Test case number

Relationships

duplicate of 0032272 newgka Shape Healing - Shape healing not corresponded to new edge control in checkshape 

Activities

asuraven

2021-03-29 09:27

developer   ~0099801

asuraven

2021-03-31 16:08

developer   ~0099917

Pleace close as dublicate of 32272

Issue History

Date Modified Username Field Change
2021-03-29 09:25 asuraven New Issue
2021-03-29 09:25 asuraven Assigned To => msv
2021-03-29 09:25 asuraven Relationship added related to 0031871
2021-03-29 09:27 asuraven Note Added: 0099801
2021-03-29 10:45 msv Assigned To msv => gka
2021-03-29 10:45 msv Category OCCT:Modeling Algorithms => OCCT:Shape Healing
2021-03-31 16:08 asuraven Note Added: 0099917
2021-03-31 16:08 asuraven Assigned To gka => bugmaster
2021-03-31 16:08 asuraven Resolution open => duplicate
2021-03-31 16:08 asuraven Relationship added duplicate of 0032272
2021-03-31 16:19 asuraven Status new => feedback
2021-03-31 16:30 asuraven Relationship deleted related to 0031871
2021-04-01 15:37 bugmaster Status feedback => closed