MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0032230Open CASCADE[OCCT] OCCT:Codingpublic2021-03-19 12:092021-04-03 12:52
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0032230: Coding Rules - remove class headers Graphic3d_HighlightStyle.hxx deprecated since OCCT 7.2.0
Description0025695 has deprecated Graphic3d_HighlightStyle, which can be now removed.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
related to 0032161verifiedbugmaster Open CASCADE Coding Rules - deprecate obsolete alias PrsMgr_PresentationManager3d 
child of 0025695closedapn Community Visualization, AIS_InteractiveContext - define default HilightMode 
child of 0032056verifiedbugmaster Open CASCADE Coding Rules - remove package MMgt and other types deprecated since OCCT 7.2.0 
child of 0030687closedkgv Open CASCADE Visualization - remove redundant interfaces SelectBasics_EntityOwner and SelectBasics_SensitiveEntity 

-  Notes
(0099601)
kgv (developer)
2021-03-19 19:14

Patch is ready for review
- OCCT: branch CR32230;
- OCC Products: branch CR32230.

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR32230-master-KGV/ [^]
(0099645)
osa (developer)
2021-03-22 16:00

Patches were reviewed
(0099687)
git (administrator)
2021-03-23 22:19

Branch CR32230 has been created by kgv.

SHA-1: 9abded7c7d72cfd61d4a2c25c40058189d15390c


Detailed log of new commits:

Author: kgv
Date: Fri Mar 19 12:37:30 2021 +0300

    0032230: Coding Rules - remove class headers Graphic3d_HighlightStyle.hxx deprecated since OCCT 7.2.0
    
    Removed unused Graphic3d_HighlightStyle, Graphic3d_CTexture, Graphic3d_MapOfZLayerSettings,
    Graphic3d_TypeOfComposition, Graphic3d_TypeOfComposition, V3d_Parameter, V3d_ViewPointer, SelectMgr_SequenceOfFilter.
    
    Added missing deprecation statements to SelectBasics_SensitiveEntity, SelectMgr_EntityOwner and PrsMgr_Presentation3d.
(0099779)
bugmaster (administrator)
2021-03-27 14:08

Combination -
OCCT branch : WEEK-12
master SHA - 154b4635b8bd4c6c527738f59fd7d9d4f2cda509
a87b7ddc8cb44606b91e3f37113847c3f5f50fdc
Products branch : WEEK-12 SHA - 0779901f5e4c7f986db723d4a181df62079baf71
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17172.74000000034 / 17208.820000000378 [-0.21%]
Products
Total CPU difference: 11546.97000000013 / 11481.660000000102 [+0.57%]
Windows-64-VC14:
OCCT
Total CPU difference: 18612.140625 / 18668.765625 [-0.30%]
Products
Total CPU difference: 12857.140625 / 12879.75 [-0.18%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0100052)
git (administrator)
2021-04-03 12:50

Branch CR32230 has been deleted by inv.

SHA-1: 9abded7c7d72cfd61d4a2c25c40058189d15390c

- Related Changesets
occt: master bbd92927
Timestamp: 2021-03-19 09:37:30
Author: kgv
Committer: bugmaster
Details ] Diff ]
0032230: Coding Rules - remove class headers Graphic3d_HighlightStyle.hxx deprecated since OCCT 7.2.0

Removed unused Graphic3d_HighlightStyle, Graphic3d_CTexture, Graphic3d_MapOfZLayerSettings,
Graphic3d_TypeOfComposition, Graphic3d_TypeOfComposition, V3d_Parameter, V3d_ViewPointer, SelectMgr_SequenceOfFilter.

Added missing deprecation statements to SelectBasics_SensitiveEntity, SelectMgr_EntityOwner and PrsMgr_Presentation3d.
mod - src/Graphic3d/FILES Diff ] File ]
mod - src/Graphic3d/Graphic3d_CStructure.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_CTexture.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_GraphicDriver.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Group.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_HighlightStyle.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_MapOfZLayerSettings.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Structure.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Structure.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Text.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_TransformError.hxx Diff ] File ]
rm - src/Graphic3d/Graphic3d_TypeOfComposition.hxx Diff ] File ]
mod - src/MeshVS/MeshVS_TextPrsBuilder.cxx Diff ] File ]
mod - src/OpenGl/OpenGl_Text.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_Point.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_Text.cxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_Presentation3d.hxx Diff ] File ]
mod - src/Select3D/Select3D_SensitiveEntity.hxx Diff ] File ]
mod - src/Select3D/Select3D_SensitiveWire.cxx Diff ] File ]
mod - src/SelectMgr/FILES Diff ] File ]
mod - src/SelectMgr/SelectMgr_CompositionFilter.hxx Diff ] File ]
rm - src/SelectMgr/SelectMgr_CompositionFilter.lxx Diff ] File ]
mod - src/SelectMgr/SelectMgr_EntityOwner.hxx Diff ] File ]
mod - src/SelectMgr/SelectMgr_SelectionImageFiller.cxx Diff ] File ]
mod - src/SelectMgr/SelectMgr_SensitiveEntity.hxx Diff ] File ]
rm - src/SelectMgr/SelectMgr_SequenceOfFilter.hxx Diff ] File ]
mod - src/V3d/FILES Diff ] File ]
rm - src/V3d/V3d_Parameter.hxx Diff ] File ]
mod - src/V3d/V3d_PositionLight.hxx Diff ] File ]
rm - src/V3d/V3d_ViewPointer.hxx Diff ] File ]
mod - tools/VInspector/VInspector_ItemPresentableObject.cxx Diff ] File ]
mod - tools/VInspector/VInspector_Tools.cxx Diff ] File ]
mod - tools/VInspector/VInspector_Tools.hxx Diff ] File ]
mod - tools/VInspector/VInspector_ViewModel.hxx Diff ] File ]
mod - tools/VInspector/VInspector_Window.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2021-03-19 12:09 kgv New Issue
2021-03-19 12:09 kgv Assigned To => kgv
2021-03-19 12:09 kgv Relationship added child of 0025695
2021-03-19 12:10 kgv Relationship added related to 0029754
2021-03-19 12:11 kgv Relationship deleted related to 0029754
2021-03-19 12:12 kgv Relationship added child of 0032056
2021-03-19 12:12 kgv Summary Coding Rules - remove deprecated class headers Graphic3d_HighlightStyle.hxx => Coding Rules - remove class headers Graphic3d_HighlightStyle.hxx deprecated since OCCT 7.2.0
2021-03-19 13:58 kgv Relationship added child of 0030687
2021-03-19 14:17 kgv Relationship added related to 0032161
2021-03-19 19:14 kgv Note Added: 0099601
2021-03-19 19:14 kgv Assigned To kgv => osa
2021-03-19 19:14 kgv Status new => resolved
2021-03-22 16:00 osa Note Added: 0099645
2021-03-22 16:00 osa Assigned To osa => bugmaster
2021-03-22 16:00 osa Status resolved => reviewed
2021-03-23 22:19 git Note Added: 0099687
2021-03-27 14:08 bugmaster Note Added: 0099779
2021-03-27 14:08 bugmaster Status reviewed => tested
2021-03-27 14:11 bugmaster Test case number => Not required
2021-03-27 14:19 bugmaster Changeset attached => occt master bbd92927
2021-03-27 14:19 bugmaster Status tested => verified
2021-03-27 14:19 bugmaster Resolution open => fixed
2021-04-03 12:50 git Note Added: 0100052


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker