View Issue Details

IDProjectCategoryView StatusLast Update
0032227Open CASCADEOCCT:Modeling Algorithmspublic2021-04-01 15:37
Reporterasuraven Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Target Version7.6.0 
Summary0032227: Modeling Algorithms - "fixshape" command generates an additional "BRepCheck_CollapsedEdge" error
DescriptionIn branch CR23731_7 executing of "fixshape" command on shape generates an additional "BRepCheck_CollapsedEdge" error
Steps To Reproducepload XDE MODELING
#from test bugs modalg_1 buc60462_2
restore [locate_data_file buc60462c.brep] a
checkshape a
restore [locate_data_file buc60462d.brep] b
checkshape b
puts "Fuse begin"
bfuse result a b
puts "Fuse end"
# generate 6 BRepCheck_CollapsedEdge errors
checkshape result

fixshape b result
# generate 7 BRepCheck_CollapsedEdge errors
checkshape b
Additional information
and documentation updates
This issue related to test bugs modalg_1 buc60462_2
TagsNo tags attached.
Test case number

Relationships

duplicate of 0032272 newgka Shape Healing - Shape healing not corresponded to new edge control in checkshape 

Activities

asuraven

2021-03-18 13:45

developer   ~0099574

asuraven

2021-03-31 16:08

developer   ~0099916

Pleace close as dublicate of 32272

Issue History

Date Modified Username Field Change
2021-03-18 13:37 asuraven New Issue
2021-03-18 13:37 asuraven Assigned To => msv
2021-03-18 13:38 asuraven Relationship added related to 0031871
2021-03-18 13:38 asuraven Relationship added related to 0032209
2021-03-18 13:45 asuraven Note Added: 0099574
2021-03-31 15:20 asuraven Steps to Reproduce Updated
2021-03-31 16:08 asuraven Note Added: 0099916
2021-03-31 16:08 asuraven Assigned To msv => bugmaster
2021-03-31 16:08 asuraven Resolution open => duplicate
2021-03-31 16:08 asuraven Relationship added duplicate of 0032272
2021-03-31 16:19 asuraven Status new => feedback
2021-03-31 16:30 asuraven Relationship deleted related to 0031871
2021-03-31 16:30 asuraven Relationship deleted related to 0032209
2021-04-01 15:37 bugmaster Status feedback => closed