MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0032134Open CASCADE[OCCT] OCCT:Configurationpublic2021-02-16 16:412021-02-18 16:29
Reporterbugmaster 
Assigned Tobugmaster 
PrioritynormalSeverityfeature 
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0032134: Configuration: Configuration by the latest CMake versions
DescriptionOCCT now is compiled with CMake 3.16.0
It is necessary to test configuration with the latest 3.19.5 CMake
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0098959)
bugmaster (administrator)
2021-02-18 13:32

We discussed with Alexander MALYSHEV the issue of raising the cmake version in the function
cmake_minimum_required (VERSION 2.8.12 FATAL_ERROR)
and came to the conclusion that it is not reasonable.
Many users are using old versions of Linux and MacOS where the native version of cmake is very old
(0098963)
bugmaster (administrator)
2021-02-18 16:29

OCCT, Products and samples were configured successfully by newest CMake 3.19.5

- Issue History
Date Modified Username Field Change
2021-02-16 16:41 bugmaster New Issue
2021-02-16 16:41 bugmaster Assigned To => bugmaster
2021-02-16 16:52 kgv Severity minor => feature
2021-02-18 13:32 bugmaster Note Added: 0098959
2021-02-18 16:29 bugmaster Note Added: 0098963
2021-02-18 16:29 bugmaster Status new => closed
2021-02-18 16:29 bugmaster Resolution open => no change required


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker