MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0032056Open CASCADE[OCCT] OCCT:Codingpublic2021-01-14 09:502021-01-16 14:20
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0032056: Coding Rules - remove package MMgt and other types deprecated since OCCT 7.2.0
DescriptionMMgt_TShared has been deprecated since OCCT 7.2.0 (0028832) - it's time to remove the package.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
child of 0028832closedbugmaster Community MMgt_TShared can be replaced by Standard_Transient 
child of 0027900closedkgv Open CASCADE Coding rules - drop redundant Name parameter from V3d_Viewer constructor 
child of 0027816closedbugmaster Open CASCADE Visualization - provide an API for overriding clipping planes list 
child of 0027860closedkgv Open CASCADE Visualization - clean up Transformation Persistence API 
child of 0025180closedkgv Open CASCADE Visualization - Homogeneous transformation API in TKV3d 
child of 0026937closedapn Community Eliminate NO_CXX_EXCEPTION macro support 
child of 0028799closedbugmaster Community Coding Rules - elimilate confusing Quantity aliases of Standard_Real type 
child of 0028441closedbugmaster Open CASCADE Coding Rules - move out nested Image_PixMap::ImgFormat enumeration to dedicated enum Image_Format 
child of 0025695closedapn Community Visualization, AIS_InteractiveContext - define default HilightMode 
child of 0028205closedapn Open CASCADE Visualization - add functionality for dumping results of detection algorithms into image 
child of 0027958closedbugmaster Open CASCADE Visualization, AIS_Trihedron - add shaded presentation option 

-  Notes
(0098122)
kgv (developer)
2021-01-14 17:07

Please raise the patch
- OCCT: branch CR32056_1;
- OCC Products: branch CR32056_1.

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR32056_1-CR32056_1-KGV [^]
(0098154)
bugmaster (administrator)
2021-01-16 13:31

Combination -
OCCT branch : IR-2021-01-15
master SHA - 6fab0b34288ef3f29ecf4eabc0283540460dbc31
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2021-01-15 SHA - a8521c25e41405ac279e65e1fcde5de75a344b0b
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17754.160000000134 / 17720.07000000011 [+0.19%]
Products
Total CPU difference: 12412.630000000105 / 12419.360000000095 [-0.05%]
Windows-64-VC14:
OCCT
Total CPU difference: 19336.3125 / 19330.015625 [+0.03%]
Products
Total CPU difference: 13740.03125 / 13831.828125 [-0.66%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

- Related Changesets
occt: master f4e7c307
Timestamp: 2021-01-14 07:03:15
Author: kgv
Committer: bugmaster
Details ] Diff ]
0032056: Coding Rules - remove package MMgt and other types deprecated since OCCT 7.2.0

Removed functionality deprecated since OCCT 7.1.0:
- 0027834 built-in iterator in class SelectMgr_ViewerSelector;
- 0027900 obsolete constructor of V3d_Viewer class;
- 0027816 obsolete clipping plane setters V3d_View/PrsMgr_PresentableObject:SetClipPlanes();
- 0027860 obsolete transformation persistence methods from class PrsMgr_PresentableObject;
- 0027756 obsolete methods Prs3d_Text::Draw();
- 0024393 obsolete enum Graphic3d_ZLayerSetting;
- 0025180 obsolete method Graphic3d_Structure::Transform().

Removed functionality deprecated since OCCT 7.2.0:
- 0028832 obsolete class MMgt_TShared;
- 0026937 obsolete property Standard_Failure::Caught();
- 0028799 obsolete types defined within Quantity package;
- 0028441 obsolete nested enum Image_PixMap::ImgFormat;
- 0025695 obsolete method PrsMgr_PresentationManager::Unhighlight();
- 0028205 obsolete class MeshVS_ColorHasher;
- 0027958 obsolete methods from Prs3d_DatumAspect class;
- 0025695 obsolete class Graphic3d_HighlightStyle;
- 0027954 obsolete BRepOffsetAPI_MakeOffsetShape,BRepOffsetAPI_MakeThickSolid constructors.
mod - adm/UDLIST Diff ] File ]
mod - samples/mfc/standard/03_Viewer2d/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/05_ImportExport/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/06_Ocaf/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/08_HLR/src/StdAfx.h Diff ] File ]
mod - samples/mfc/standard/09_Animation/src/StdAfx.h Diff ] File ]
mod - src/AIS/AIS_InteractiveContext.hxx Diff ] File ]
mod - src/AIS/AIS_MultipleConnectedInteractive.hxx Diff ] File ]
mod - src/BRepOffsetAPI/BRepOffsetAPI_MakeOffsetShape.cxx Diff ] File ]
mod - src/BRepOffsetAPI/BRepOffsetAPI_MakeOffsetShape.hxx Diff ] File ]
mod - src/BRepOffsetAPI/BRepOffsetAPI_MakeThickSolid.cxx Diff ] File ]
mod - src/BRepOffsetAPI/BRepOffsetAPI_MakeThickSolid.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_Structure.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_TransformPers.cxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_TransformPers.hxx Diff ] File ]
mod - src/Graphic3d/Graphic3d_ZLayerSettings.hxx Diff ] File ]
mod - src/Image/Image_PixMap.hxx Diff ] File ]
mod - src/Image/Image_VideoRecorder.cxx Diff ] File ]
mod - src/MeshVS/FILES Diff ] File ]
rm - src/MeshVS/MeshVS_ColorHasher.hxx Diff ] File ]
mod - src/Message/Message_Alert.hxx Diff ] File ]
mod - src/Message/Message_Report.hxx Diff ] File ]
rm - src/MMgt/FILES Diff ] File ]
rm - src/MMgt/MMgt_TShared.hxx Diff ] File ]
mod - src/OpenGl/OpenGl_Context.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_Arrow.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_DatumAspect.cxx Diff ] File ]
mod - src/Prs3d/Prs3d_DatumAspect.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_Drawer.hxx Diff ] File ]
mod - src/Prs3d/Prs3d_Text.hxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_PresentableObject.cxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_PresentableObject.hxx Diff ] File ]
mod - src/PrsMgr/PrsMgr_PresentationManager.hxx Diff ] File ]
mod - src/Quantity/FILES Diff ] File ]
rm - src/Quantity/Quantity_AbsorbedDose.hxx Diff ] File ]
rm - src/Quantity/Quantity_Acceleration.hxx Diff ] File ]
rm - src/Quantity/Quantity_AcousticIntensity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Activity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Admittance.hxx Diff ] File ]
rm - src/Quantity/Quantity_AmountOfSubstance.hxx Diff ] File ]
rm - src/Quantity/Quantity_AngularVelocity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Area.hxx Diff ] File ]
rm - src/Quantity/Quantity_Capacitance.hxx Diff ] File ]
rm - src/Quantity/Quantity_Coefficient.hxx Diff ] File ]
rm - src/Quantity/Quantity_CoefficientOfExpansion.hxx Diff ] File ]
rm - src/Quantity/Quantity_Concentration.hxx Diff ] File ]
rm - src/Quantity/Quantity_Conductivity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Constant.hxx Diff ] File ]
rm - src/Quantity/Quantity_Consumption.hxx Diff ] File ]
rm - src/Quantity/Quantity_Content.hxx Diff ] File ]
rm - src/Quantity/Quantity_Density.hxx Diff ] File ]
rm - src/Quantity/Quantity_DoseEquivalent.hxx Diff ] File ]
rm - src/Quantity/Quantity_ElectricCapacitance.hxx Diff ] File ]
rm - src/Quantity/Quantity_ElectricCharge.hxx Diff ] File ]
rm - src/Quantity/Quantity_ElectricCurrent.hxx Diff ] File ]
rm - src/Quantity/Quantity_ElectricFieldStrength.hxx Diff ] File ]
rm - src/Quantity/Quantity_ElectricPotential.hxx Diff ] File ]
rm - src/Quantity/Quantity_Energy.hxx Diff ] File ]
rm - src/Quantity/Quantity_Enthalpy.hxx Diff ] File ]
rm - src/Quantity/Quantity_Entropy.hxx Diff ] File ]
rm - src/Quantity/Quantity_Factor.hxx Diff ] File ]
rm - src/Quantity/Quantity_Force.hxx Diff ] File ]
rm - src/Quantity/Quantity_Frequency.hxx Diff ] File ]
rm - src/Quantity/Quantity_Illuminance.hxx Diff ] File ]
rm - src/Quantity/Quantity_Impedance.hxx Diff ] File ]
rm - src/Quantity/Quantity_Index.hxx Diff ] File ]
rm - src/Quantity/Quantity_Inductance.hxx Diff ] File ]
rm - src/Quantity/Quantity_KinematicViscosity.hxx Diff ] File ]
rm - src/Quantity/Quantity_KineticMoment.hxx Diff ] File ]
rm - src/Quantity/Quantity_Length.hxx Diff ] File ]
rm - src/Quantity/Quantity_Luminance.hxx Diff ] File ]
rm - src/Quantity/Quantity_LuminousEfficacity.hxx Diff ] File ]
rm - src/Quantity/Quantity_LuminousExposition.hxx Diff ] File ]
rm - src/Quantity/Quantity_LuminousFlux.hxx Diff ] File ]
rm - src/Quantity/Quantity_LuminousIntensity.hxx Diff ] File ]
rm - src/Quantity/Quantity_MagneticFieldStrength.hxx Diff ] File ]
rm - src/Quantity/Quantity_MagneticFlux.hxx Diff ] File ]
rm - src/Quantity/Quantity_MagneticFluxDensity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Mass.hxx Diff ] File ]
rm - src/Quantity/Quantity_MassFlow.hxx Diff ] File ]
rm - src/Quantity/Quantity_MolarConcentration.hxx Diff ] File ]
rm - src/Quantity/Quantity_Molarity.hxx Diff ] File ]
rm - src/Quantity/Quantity_MolarMass.hxx Diff ] File ]
rm - src/Quantity/Quantity_MolarVolume.hxx Diff ] File ]
rm - src/Quantity/Quantity_MomentOfAForce.hxx Diff ] File ]
rm - src/Quantity/Quantity_MomentOfInertia.hxx Diff ] File ]
rm - src/Quantity/Quantity_Momentum.hxx Diff ] File ]
rm - src/Quantity/Quantity_Normality.hxx Diff ] File ]
rm - src/Quantity/Quantity_Parameter.hxx Diff ] File ]
rm - src/Quantity/Quantity_PlaneAngle.hxx Diff ] File ]
rm - src/Quantity/Quantity_Power.hxx Diff ] File ]
rm - src/Quantity/Quantity_Pressure.hxx Diff ] File ]
rm - src/Quantity/Quantity_Quotient.hxx Diff ] File ]
rm - src/Quantity/Quantity_Rate.hxx Diff ] File ]
rm - src/Quantity/Quantity_Ratio.hxx Diff ] File ]
rm - src/Quantity/Quantity_Reluctance.hxx Diff ] File ]
rm - src/Quantity/Quantity_Resistance.hxx Diff ] File ]
rm - src/Quantity/Quantity_Resistivity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Scalaire.hxx Diff ] File ]
rm - src/Quantity/Quantity_SolidAngle.hxx Diff ] File ]
rm - src/Quantity/Quantity_SoundIntensity.hxx Diff ] File ]
rm - src/Quantity/Quantity_SpecificHeatCapacity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Speed.hxx Diff ] File ]
rm - src/Quantity/Quantity_SurfaceTension.hxx Diff ] File ]
rm - src/Quantity/Quantity_Temperature.hxx Diff ] File ]
rm - src/Quantity/Quantity_ThermalConductivity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Torque.hxx Diff ] File ]
rm - src/Quantity/Quantity_Velocity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Viscosity.hxx Diff ] File ]
rm - src/Quantity/Quantity_Volume.hxx Diff ] File ]
rm - src/Quantity/Quantity_VolumeFlow.hxx Diff ] File ]
rm - src/Quantity/Quantity_Weight.hxx Diff ] File ]
rm - src/Quantity/Quantity_Work.hxx Diff ] File ]
mod - src/SelectMgr/SelectMgr_ViewerSelector.cxx Diff ] File ]
mod - src/SelectMgr/SelectMgr_ViewerSelector.hxx Diff ] File ]
mod - src/Standard/Standard_Failure.cxx Diff ] File ]
mod - src/Standard/Standard_Failure.hxx Diff ] File ]
mod - src/TKernel/PACKAGES Diff ] File ]
mod - src/V3d/V3d_View.hxx Diff ] File ]
mod - src/V3d/V3d_Viewer.cxx Diff ] File ]
mod - src/V3d/V3d_Viewer.hxx Diff ] File ]
mod - src/ViewerTest/ViewerTest.cxx Diff ] File ]
mod - src/ViewerTest/ViewerTest_ObjectCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2021-01-14 09:50 kgv New Issue
2021-01-14 09:50 kgv Assigned To => kgv
2021-01-14 09:50 kgv Relationship added child of 0028832
2021-01-14 10:01 kgv Summary Coding Rules - remove deprecated package MMgt => Coding Rules - remove deprecated package MMgt and other types
2021-01-14 11:21 kgv Summary Coding Rules - remove deprecated package MMgt and other types => Coding Rules - remove package MMgt and other types deprecated since OCCT 7.2.0
2021-01-14 17:07 kgv Note Added: 0098122
2021-01-14 17:07 kgv Assigned To kgv => bugmaster
2021-01-14 17:07 kgv Status new => resolved
2021-01-14 17:07 kgv Status resolved => reviewed
2021-01-14 17:08 kgv Relationship added related to 0027834
2021-01-14 17:08 kgv Relationship replaced child of 0027834
2021-01-14 17:08 kgv Relationship added child of 0027900
2021-01-14 17:08 kgv Relationship added child of 0027816
2021-01-14 17:08 kgv Relationship added child of 0027860
2021-01-14 17:08 kgv Relationship added child of 0027756
2021-01-14 17:08 kgv Relationship added child of 0024393
2021-01-14 17:09 kgv Relationship added child of 0025180
2021-01-14 17:09 kgv Relationship added child of 0026937
2021-01-14 17:09 kgv Relationship added child of 0028799
2021-01-14 17:09 kgv Relationship added child of 0028441
2021-01-14 17:09 kgv Relationship added child of 0025695
2021-01-14 17:09 kgv Relationship added child of 0028205
2021-01-14 17:09 kgv Relationship added child of 0027958
2021-01-14 17:09 kgv Relationship added child of 0027954
2021-01-16 13:31 bugmaster Note Added: 0098154
2021-01-16 13:31 bugmaster Status reviewed => tested
2021-01-16 13:56 bugmaster Test case number => Not required
2021-01-16 14:12 bugmaster Changeset attached => occt master f4e7c307
2021-01-16 14:12 bugmaster Status tested => verified
2021-01-16 14:12 bugmaster Resolution open => fixed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker